Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула номер недели - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула номер недели (Формулы/Formulas)
Формула номер недели
lenacia Дата: Понедельник, 29.10.2018, 12:22 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Подскажите, пожалуйста, в моем примере в столбце А проставлена формула номер недели. Т.е. если я ставлю дату в столбе В, то у меня появляется номер недели.
У меня протянута формула вниз, до конца таблицы. Т.е. там где пока нет даты стоит значение 1.
А как можно прописать формулу, что бы пока нет даты ничего в столбце А не проставлялось? просто была пустая клетка
К сообщению приложен файл: 4068494.xls(26.0 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите, пожалуйста, в моем примере в столбце А проставлена формула номер недели. Т.е. если я ставлю дату в столбе В, то у меня появляется номер недели.
У меня протянута формула вниз, до конца таблицы. Т.е. там где пока нет даты стоит значение 1.
А как можно прописать формулу, что бы пока нет даты ничего в столбце А не проставлялось? просто была пустая клетка

Автор - lenacia
Дата добавления - 29.10.2018 в 12:22
TimSha Дата: Понедельник, 29.10.2018, 12:34 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 606
Репутация: 92 ±
Замечаний: 0% ±

Excel 2013 Pro +
Как вариант -
Код
=ЕСЛИ(B2="";"";НОМНЕДЕЛИ(B2; 2))


"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)
 
Ответить
СообщениеКак вариант -
Код
=ЕСЛИ(B2="";"";НОМНЕДЕЛИ(B2; 2))

Автор - TimSha
Дата добавления - 29.10.2018 в 12:34
jakim Дата: Понедельник, 29.10.2018, 12:36 | Сообщение № 3
Группа: Друзья
Ранг: Ветеран
Сообщений: 851
Репутация: 225 ±
Замечаний: 0% ±

Excel 2010
формула

Код
=IF(ISBLANK(B2);"";WEEKNUM(B2;2))
 
Ответить
Сообщение
формула

Код
=IF(ISBLANK(B2);"";WEEKNUM(B2;2))

Автор - jakim
Дата добавления - 29.10.2018 в 12:36
lenacia Дата: Понедельник, 29.10.2018, 12:51 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 92
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо! Работает
 
Ответить
СообщениеСпасибо! Работает

Автор - lenacia
Дата добавления - 29.10.2018 в 12:51
Nic70y Дата: Понедельник, 29.10.2018, 21:17 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4891
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
такой в списке еще не было
Код
=ЕСЛИ(B2;НОМНЕДЕЛИ(B2;2);"")


удалил пробел нафиг (он не мешает, но мне не нравиться)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 29.10.2018, 21:19
 
Ответить
Сообщениетакой в списке еще не было
Код
=ЕСЛИ(B2;НОМНЕДЕЛИ(B2;2);"")


удалил пробел нафиг (он не мешает, но мне не нравиться)

Автор - Nic70y
Дата добавления - 29.10.2018 в 21:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула номер недели (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!