Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать последовательность чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать последовательность чисел (Формулы/Formulas)
Суммировать последовательность чисел
stalber Дата: Понедельник, 05.11.2018, 14:16 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 195
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый день, помогите пожалуйста, необходима формула:

Необходимо суммировать из строки 3-ие по счёту числа, через каждые 8 столбцов. Конец в строке начинается с пустой ячейки.
К сообщению приложен файл: zadacha_0511201.xlsx(8.5 Kb)


Сообщение отредактировал stalber - Понедельник, 05.11.2018, 14:16
 
Ответить
СообщениеДобрый день, помогите пожалуйста, необходима формула:

Необходимо суммировать из строки 3-ие по счёту числа, через каждые 8 столбцов. Конец в строке начинается с пустой ячейки.

Автор - stalber
Дата добавления - 05.11.2018 в 14:16
Nic70y Дата: Понедельник, 05.11.2018, 18:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4891
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
формула массива:
Код
=СУММ(ЕСЛИ(ОСТАТ(СТОЛБЕЦ(A1:BK1)-6;8)=0;A1:BK1))
К сообщению приложен файл: u11.xlsx(9.7 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Понедельник, 05.11.2018, 18:36
 
Ответить
Сообщениеформула массива:
Код
=СУММ(ЕСЛИ(ОСТАТ(СТОЛБЕЦ(A1:BK1)-6;8)=0;A1:BK1))

Автор - Nic70y
Дата добавления - 05.11.2018 в 18:35
_Boroda_ Дата: Вторник, 06.11.2018, 11:37 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13514
Репутация: 5529 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант
Код
=СУММПРОИЗВ(Ч(СМЕЩ(D1;;8*СТОЛБЕЦ(A:J)-6)))

Код
=СУММПРОИЗВ(Ч(СМЕЩ(F1;;8*СТОЛБЕЦ(A:J))))

Немассивная, но волатильная (пересчитывается при любом изменении на листе)
К сообщению приложен файл: 9440024.xlsx(9.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант
Код
=СУММПРОИЗВ(Ч(СМЕЩ(D1;;8*СТОЛБЕЦ(A:J)-6)))

Код
=СУММПРОИЗВ(Ч(СМЕЩ(F1;;8*СТОЛБЕЦ(A:J))))

Немассивная, но волатильная (пересчитывается при любом изменении на листе)

Автор - _Boroda_
Дата добавления - 06.11.2018 в 11:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать последовательность чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!