Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Попарное сравн 2ух строк чисел и подсчет количества совпад. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Попарное сравн 2ух строк чисел и подсчет количества совпад. (Формулы/Formulas)
Попарное сравн 2ух строк чисел и подсчет количества совпад.
sergio_dro Дата: Среда, 07.11.2018, 19:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Уважаемые форумчане. Помогите новичку, как организовать попарное сравнение двух строк чисел, например:
A B C D E F G H I J
A1:J1 = 1 2 3 4 5 6 7 8 9 10
A2:J2 = 9 8 7 6 5 4 3 2 1 0
и подсчитать число совпадений.
В примере число совпадений =1 в пятом столбце E1-E2 (число 5).
Можно ли это реализовать на базе функции СЧЕТЕН () или всё сложнее?
 
Ответить
СообщениеУважаемые форумчане. Помогите новичку, как организовать попарное сравнение двух строк чисел, например:
A B C D E F G H I J
A1:J1 = 1 2 3 4 5 6 7 8 9 10
A2:J2 = 9 8 7 6 5 4 3 2 1 0
и подсчитать число совпадений.
В примере число совпадений =1 в пятом столбце E1-E2 (число 5).
Можно ли это реализовать на базе функции СЧЕТЕН () или всё сложнее?

Автор - sergio_dro
Дата добавления - 07.11.2018 в 19:57
Nic70y Дата: Среда, 07.11.2018, 20:11 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4891
Репутация: 1060 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(--(A1:J1=A2:J2))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(--(A1:J1=A2:J2))

Автор - Nic70y
Дата добавления - 07.11.2018 в 20:11
sergio_dro Дата: Среда, 07.11.2018, 20:44 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Элегантно! Я б не допёр... Огромное спасибо!!!
 
Ответить
СообщениеЭлегантно! Я б не допёр... Огромное спасибо!!!

Автор - sergio_dro
Дата добавления - 07.11.2018 в 20:44
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Попарное сравн 2ух строк чисел и подсчет количества совпад. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!