Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод из многочисленного повтора перечня в персональный. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод из многочисленного повтора перечня в персональный. (Формулы/Formulas)
Вывод из многочисленного повтора перечня в персональный.
Окся Дата: Вторник, 13.11.2018, 15:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброго времени суток ! Снова просьба помочь в решении задачи , в колонке А перечень ( повторяющийся ) производителя к группе товаров ( и он не маленький ). Задача в колонку В прописать формулу которая выведет из всего огромного списка только единое название производителя , в колонке Свручную прописала пример. Помогите пожалуйста. Файл приложила.Заранее благодарна!
К сообщению приложен файл: 6458660.zip(23.7 Kb)


(*_*)
 
Ответить
СообщениеДоброго времени суток ! Снова просьба помочь в решении задачи , в колонке А перечень ( повторяющийся ) производителя к группе товаров ( и он не маленький ). Задача в колонку В прописать формулу которая выведет из всего огромного списка только единое название производителя , в колонке Свручную прописала пример. Помогите пожалуйста. Файл приложила.Заранее благодарна!

Автор - Окся
Дата добавления - 13.11.2018 в 15:11
_Boroda_ Дата: Вторник, 13.11.2018, 15:21 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если немаленький, то лучше сводной таблицей. Формулами будет тормозить
Заодно и по алфавиту построятся
А формулой можно так
Код
=ИНДЕКС(A:A;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ(B$1:B1;A$2:A9999););)+1)&""

Файл перевложил

Или расширенным фильтром (Выделить столбец А - Данные - Сортировка и фильтр - Дополнительно)
Файл перевложил

Сейчас еще придет sboy и сделает через Повер Квери
К сообщению приложен файл: _86.xlsb(39.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли немаленький, то лучше сводной таблицей. Формулами будет тормозить
Заодно и по алфавиту построятся
А формулой можно так
Код
=ИНДЕКС(A:A;ПОИСКПОЗ(;ИНДЕКС(СЧЁТЕСЛИ(B$1:B1;A$2:A9999););)+1)&""

Файл перевложил

Или расширенным фильтром (Выделить столбец А - Данные - Сортировка и фильтр - Дополнительно)
Файл перевложил

Сейчас еще придет sboy и сделает через Повер Квери

Автор - _Boroda_
Дата добавления - 13.11.2018 в 15:21
Окся Дата: Вторник, 13.11.2018, 15:30 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Вот я тормоз...... про сводную забыла( Спасибо огромное))


(*_*)
 
Ответить
СообщениеВот я тормоз...... про сводную забыла( Спасибо огромное))

Автор - Окся
Дата добавления - 13.11.2018 в 15:30
_Boroda_ Дата: Вторник, 13.11.2018, 15:32 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Я там добавил еще вариант расширенным фильтром


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЯ там добавил еще вариант расширенным фильтром

Автор - _Boroda_
Дата добавления - 13.11.2018 в 15:32
sboy Дата: Вторник, 13.11.2018, 15:55 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2224
Репутация: 631 ±
Замечаний: 0% ±

Excel 2010
Сейчас еще придет sboy и сделает через Повер Квери

не буду)
А почему бы не скопировать в другой столбец и применить инструмент "Удалить дубликаты"?
К сообщению приложен файл: _1-1-.xlsm(41.7 Kb)


Сообщение отредактировал sboy - Вторник, 13.11.2018, 15:56
 
Ответить
Сообщение
Сейчас еще придет sboy и сделает через Повер Квери

не буду)
А почему бы не скопировать в другой столбец и применить инструмент "Удалить дубликаты"?

Автор - sboy
Дата добавления - 13.11.2018 в 15:55
Окся Дата: Вторник, 13.11.2018, 16:03 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здорово , спасибо)


(*_*)
 
Ответить
СообщениеЗдорово , спасибо)

Автор - Окся
Дата добавления - 13.11.2018 в 16:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод из многочисленного повтора перечня в персональный. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!