Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск в диапазоне ячейки и выписка данных рядом с ней - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в диапазоне ячейки и выписка данных рядом с ней (Формулы/Formulas)
Поиск в диапазоне ячейки и выписка данных рядом с ней
DimOzerov Дата: Четверг, 15.11.2018, 21:32 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Всем привет.
Уважаемые мастера экселя - подскажите решение с формулой.

На листе расположен диапазон B2:N18. В нем кое-где находятся блоки со словами Блок-1,Блок-2,Блок-4,Блок-X. Напротив каждого слова в диапазоне - желтая ячейка с числом, а под каждой желтой ячейкой - текст.

Рядом - таблица R2:T7.
В нее выписаны слова для поиска, в следующем столбце - текст который идет под каждой желтой ячейкой, в следующем столбце - числа из самих желтых ячеек.

Сейчас я тупо ссылаюсь прямой ссылкой на ячейку, с нужным содержимым (типа =E4). Это неудобно.
Формула в столбце S и в столбце T - должны как-то сканировать диапазон B2:N18 - и если встретят, слово стоящее напротив (в столбце R) - например "Блок-1" - то выводят то что стоит в этом диапазоне (B2:N18), на одну ячейку правее (то есть содержимое ячейки E3: "64").

Как должны выглядеть формулы в столбцах S и T ?

Не соображу как это сделать.
Наверное как-то использовать формулу ИНДЕКС, а может еще каким-то образом. Главное - без использования дополнительных столбцов.
К сообщению приложен файл: 0177476.xls(48.0 Kb)
 
Ответить
СообщениеВсем привет.
Уважаемые мастера экселя - подскажите решение с формулой.

На листе расположен диапазон B2:N18. В нем кое-где находятся блоки со словами Блок-1,Блок-2,Блок-4,Блок-X. Напротив каждого слова в диапазоне - желтая ячейка с числом, а под каждой желтой ячейкой - текст.

Рядом - таблица R2:T7.
В нее выписаны слова для поиска, в следующем столбце - текст который идет под каждой желтой ячейкой, в следующем столбце - числа из самих желтых ячеек.

Сейчас я тупо ссылаюсь прямой ссылкой на ячейку, с нужным содержимым (типа =E4). Это неудобно.
Формула в столбце S и в столбце T - должны как-то сканировать диапазон B2:N18 - и если встретят, слово стоящее напротив (в столбце R) - например "Блок-1" - то выводят то что стоит в этом диапазоне (B2:N18), на одну ячейку правее (то есть содержимое ячейки E3: "64").

Как должны выглядеть формулы в столбцах S и T ?

Не соображу как это сделать.
Наверное как-то использовать формулу ИНДЕКС, а может еще каким-то образом. Главное - без использования дополнительных столбцов.

Автор - DimOzerov
Дата добавления - 15.11.2018 в 21:32
bmv98rus Дата: Четверг, 15.11.2018, 21:36 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 1417
Репутация: 238 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUMIF($C$3:$K$11;R2;$E$3:$M$11)
 
Ответить
Сообщение
Код
=SUMIF($C$3:$K$11;R2;$E$3:$M$11)

Автор - bmv98rus
Дата добавления - 15.11.2018 в 21:36
Nic70y Дата: Четверг, 15.11.2018, 21:44 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4940
Репутация: 1069 ±
Замечаний: 0% ±

Excel 2013
формулы массива:
Код
=ИНДЕКС($A$1:$N$18;1+МИН(ЕСЛИ($B$2:$N$18=$R2;СТРОКА($B$2:$N$18)));2+МИН(ЕСЛИ($B$2:$N$18=$R2;СТОЛБЕЦ($B$2:$N$18))))
Код
=ИНДЕКС($A$1:$N$18;МИН(ЕСЛИ($B$2:$N$18=$R2;СТРОКА($B$2:$N$18)));2+МИН(ЕСЛИ($B$2:$N$18=$R2;СТОЛБЕЦ($B$2:$N$18))))
К сообщению приложен файл: 19.xls(43.0 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщениеформулы массива:
Код
=ИНДЕКС($A$1:$N$18;1+МИН(ЕСЛИ($B$2:$N$18=$R2;СТРОКА($B$2:$N$18)));2+МИН(ЕСЛИ($B$2:$N$18=$R2;СТОЛБЕЦ($B$2:$N$18))))
Код
=ИНДЕКС($A$1:$N$18;МИН(ЕСЛИ($B$2:$N$18=$R2;СТРОКА($B$2:$N$18)));2+МИН(ЕСЛИ($B$2:$N$18=$R2;СТОЛБЕЦ($B$2:$N$18))))

Автор - Nic70y
Дата добавления - 15.11.2018 в 21:44
DimOzerov Дата: Четверг, 15.11.2018, 22:31 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Nic70y, вот такое решение подходит. Спасибо.
 
Ответить
СообщениеNic70y, вот такое решение подходит. Спасибо.

Автор - DimOzerov
Дата добавления - 15.11.2018 в 22:31
bmv98rus Дата: Четверг, 15.11.2018, 22:40 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1417
Репутация: 238 ±
Замечаний: 0% ±

Excel 2013/2016
DimOzerov, очень любопытно, чем #2 не устроила, слишком короткая?
 
Ответить
СообщениеDimOzerov, очень любопытно, чем #2 не устроила, слишком короткая?

Автор - bmv98rus
Дата добавления - 15.11.2018 в 22:40
DimOzerov Дата: Четверг, 15.11.2018, 23:12 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
bmv98rus, да в принципе - устроила.

Только это для одного столбца было решение.
А там же - два столбца.
 
Ответить
Сообщениеbmv98rus, да в принципе - устроила.

Только это для одного столбца было решение.
А там же - два столбца.

Автор - DimOzerov
Дата добавления - 15.11.2018 в 23:12
bmv98rus Дата: Четверг, 15.11.2018, 23:29 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1417
Репутация: 238 ±
Замечаний: 0% ±

Excel 2013/2016
А там же - два столбца.

ну да, тогда яб MIN на SUMPRODUCT заменил в формуле от Nic70y,
 
Ответить
Сообщение
А там же - два столбца.

ну да, тогда яб MIN на SUMPRODUCT заменил в формуле от Nic70y,

Автор - bmv98rus
Дата добавления - 15.11.2018 в 23:29
_Boroda_ Дата: Пятница, 16.11.2018, 01:31 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13681
Репутация: 5580 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще немассивный вариант
адреса (похоже на Николаевское)
Код
=ИНДЕКС(A:M;СУММПРОИЗВ((C$3:K$11=R2)*СТРОКА($4:$12));СУММПРОИЗВ((C$3:K$11=R2)*СТОЛБЕЦ(E:M)))

числа (похоже на Михайловское)
Код
=СУММЕСЛИ(C$3:K$11;R2;E$3)
К сообщению приложен файл: 0177476_1.xls(45.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще немассивный вариант
адреса (похоже на Николаевское)
Код
=ИНДЕКС(A:M;СУММПРОИЗВ((C$3:K$11=R2)*СТРОКА($4:$12));СУММПРОИЗВ((C$3:K$11=R2)*СТОЛБЕЦ(E:M)))

числа (похоже на Михайловское)
Код
=СУММЕСЛИ(C$3:K$11;R2;E$3)

Автор - _Boroda_
Дата добавления - 16.11.2018 в 01:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск в диапазоне ячейки и выписка данных рядом с ней (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!