Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма ячеек массива по двойному условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек массива по двойному условию (Формулы/Formulas)
Сумма ячеек массива по двойному условию
lfuthobr Дата: Пятница, 16.11.2018, 13:34 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, имеется столбец с типом, и второй столбец с числовым значением для этого типа. Задача заключается в выводе суммы значения для определенного типа. Делал это через "суммпроизв". Теперь задача изменилась и в столбце значений кроме цифровых значений могут быть текстовые, соответственно формула выдает ошибку. Как внутри формулы отсеять текстовые значения или заменить на "ложь" или "0". Файл примера прикладываю. Еще хотелось бы добавить проверку для суммы по столбцу B если он не пустой тогда складывать (тоесть на одновременное выполнения условия соответствия типа и не пустой ячейки в столбце)
К сообщению приложен файл: -2-.xlsx(31.6 Kb)
 
Ответить
СообщениеДобрый день, имеется столбец с типом, и второй столбец с числовым значением для этого типа. Задача заключается в выводе суммы значения для определенного типа. Делал это через "суммпроизв". Теперь задача изменилась и в столбце значений кроме цифровых значений могут быть текстовые, соответственно формула выдает ошибку. Как внутри формулы отсеять текстовые значения или заменить на "ложь" или "0". Файл примера прикладываю. Еще хотелось бы добавить проверку для суммы по столбцу B если он не пустой тогда складывать (тоесть на одновременное выполнения условия соответствия типа и не пустой ячейки в столбце)

Автор - lfuthobr
Дата добавления - 16.11.2018 в 13:34
Pelena Дата: Пятница, 16.11.2018, 13:42 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13300
Репутация: 2927 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Код
=СУММЕСЛИМН(C1:C7;ТИП;"ксн";B1:B7;"<>")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=СУММЕСЛИМН(C1:C7;ТИП;"ксн";B1:B7;"<>")

Автор - Pelena
Дата добавления - 16.11.2018 в 13:42
dude Дата: Пятница, 16.11.2018, 13:48 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 122
Репутация: 15 ±
Замечаний: 0% ±

2016
Код
=СУММЕСЛИМН(C1:C7;ТИП;A4)
 
Ответить
Сообщение
Код
=СУММЕСЛИМН(C1:C7;ТИП;A4)

Автор - dude
Дата добавления - 16.11.2018 в 13:48
_Boroda_ Дата: Пятница, 16.11.2018, 13:54 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13681
Репутация: 5580 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Код
=СУММЕСЛИ(ТИП;A4;C1:C7)

Код
=СУММПРОИЗВ(Ч(ТИП="ксн");C1:C7)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Код
=СУММЕСЛИ(ТИП;A4;C1:C7)

Код
=СУММПРОИЗВ(Ч(ТИП="ксн");C1:C7)

Автор - _Boroda_
Дата добавления - 16.11.2018 в 13:54
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма ячеек массива по двойному условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!