Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сортировка столбца по повторяющемуся значению - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка столбца по повторяющемуся значению (Формулы/Formulas)
Сортировка столбца по повторяющемуся значению
federal24 Дата: Пятница, 23.11.2018, 17:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
В 3 столбце только лишь повторяющиеся значения второго столба, но не все. Нужно расположить значения 3 столбца по совпадениям со вторым, а 4 столбец чтобы был привязан к 3му. Вообщем в примере всё более чем понятно.
К сообщению приложен файл: 7716828.xls(33.0 Kb)
 
Ответить
СообщениеВ 3 столбце только лишь повторяющиеся значения второго столба, но не все. Нужно расположить значения 3 столбца по совпадениям со вторым, а 4 столбец чтобы был привязан к 3му. Вообщем в примере всё более чем понятно.

Автор - federal24
Дата добавления - 23.11.2018 в 17:54
Светлый Дата: Пятница, 23.11.2018, 19:22 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 747
Репутация: 198 ±
Замечаний: 0% ±

Excel 2010
И Вам, здравствуйте!
В столбце J:
Код
=ЕСЛИ(СЧЁТЕСЛИ(C$1:C$16;B1);B1;"")
В столбце K:
Код
=ЕСЛИ(J1="";"";ВПР(J1;C$1:D$16;2;))
Устроит?
*Да и название неподходящее. Никакой сортировки нет. Следует поменять.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 23.11.2018, 19:38
 
Ответить
СообщениеИ Вам, здравствуйте!
В столбце J:
Код
=ЕСЛИ(СЧЁТЕСЛИ(C$1:C$16;B1);B1;"")
В столбце K:
Код
=ЕСЛИ(J1="";"";ВПР(J1;C$1:D$16;2;))
Устроит?
*Да и название неподходящее. Никакой сортировки нет. Следует поменять.

Автор - Светлый
Дата добавления - 23.11.2018 в 19:22
federal24 Дата: Пятница, 23.11.2018, 19:36 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 23.11.2018 в 19:22, в сообщении № 2 ()
Устроит?

Более чем! спасибо дедуля!
 
Ответить
Сообщение
Цитата Светлый, 23.11.2018 в 19:22, в сообщении № 2 ()
Устроит?

Более чем! спасибо дедуля!

Автор - federal24
Дата добавления - 23.11.2018 в 19:36
federal24 Дата: Пятница, 23.11.2018, 19:41 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Цитата Светлый, 23.11.2018 в 19:22, в сообщении № 2 ()
*Да и название неподходящее. Никакой сортировки нет. Следует поменять.

Сортировку буду делать по столбцу K
 
Ответить
Сообщение
Цитата Светлый, 23.11.2018 в 19:22, в сообщении № 2 ()
*Да и название неподходящее. Никакой сортировки нет. Следует поменять.

Сортировку буду делать по столбцу K

Автор - federal24
Дата добавления - 23.11.2018 в 19:41
Pelena Дата: Пятница, 23.11.2018, 22:24 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13295
Репутация: 2925 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
спасибо дедуля!

Что за фамильярность?! Вы что, давно знакомы?


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
спасибо дедуля!

Что за фамильярность?! Вы что, давно знакомы?

Автор - Pelena
Дата добавления - 23.11.2018 в 22:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сортировка столбца по повторяющемуся значению (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!