Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммировать последние 10 чисел - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать последние 10 чисел (Формулы/Formulas)
Суммировать последние 10 чисел
stalber Дата: Четверг, 29.11.2018, 19:51 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый вечер, будьте любезны, помогите формулой.

Необходимо суммировать последние (самые нижние в столбце) числа.
К сообщению приложен файл: summirovatj_pos.xlsx(9.7 Kb)
 
Ответить
СообщениеДобрый вечер, будьте любезны, помогите формулой.

Необходимо суммировать последние (самые нижние в столбце) числа.

Автор - stalber
Дата добавления - 29.11.2018 в 19:51
Nic70y Дата: Четверг, 29.11.2018, 19:57 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 4933
Репутация: 1069 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММ(ИНДЕКС(C:C;ПОИСКПОЗ(9E+307;C:C)-9):ИНДЕКС(C:C;ПОИСКПОЗ(9E+307;C:C)))

так вернее
Код
=СУММ(ИНДЕКС(C:C;МАКС(ПОИСКПОЗ(9E+307;C:C)-9;1)):ИНДЕКС(C:C;ПОИСКПОЗ(9E+307;C:C)))


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)


Сообщение отредактировал Nic70y - Четверг, 29.11.2018, 20:00
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(C:C;ПОИСКПОЗ(9E+307;C:C)-9):ИНДЕКС(C:C;ПОИСКПОЗ(9E+307;C:C)))

так вернее
Код
=СУММ(ИНДЕКС(C:C;МАКС(ПОИСКПОЗ(9E+307;C:C)-9;1)):ИНДЕКС(C:C;ПОИСКПОЗ(9E+307;C:C)))

Автор - Nic70y
Дата добавления - 29.11.2018 в 19:57
_Boroda_ Дата: Четверг, 29.11.2018, 19:58 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13660
Репутация: 5574 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММ(C:C)-СУММ(C1:ИНДЕКС(C:C;МАКС(1;СЧЁТ(C:C)-9)))

Был еще вариант
Код
=СУММ(ИНДЕКС(C:C;СЧЁТ(C:C)+1):ИНДЕКС(C:C;СЧЁТ(C:C)-8))
но он не работает с условием
Цитата
Если стереть в столбце A диапазон A6:A34 то формула покажет 2


*Кстати, а что нужно показывать при вообще пустом столбце А?
К сообщению приложен файл: 6586579.xlsx(10.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995


Сообщение отредактировал _Boroda_ - Четверг, 29.11.2018, 20:02
 
Ответить
СообщениеТак нужно?
Код
=СУММ(C:C)-СУММ(C1:ИНДЕКС(C:C;МАКС(1;СЧЁТ(C:C)-9)))

Был еще вариант
Код
=СУММ(ИНДЕКС(C:C;СЧЁТ(C:C)+1):ИНДЕКС(C:C;СЧЁТ(C:C)-8))
но он не работает с условием
Цитата
Если стереть в столбце A диапазон A6:A34 то формула покажет 2


*Кстати, а что нужно показывать при вообще пустом столбце А?

Автор - _Boroda_
Дата добавления - 29.11.2018 в 19:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммировать последние 10 чисел (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!