Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование по несколько критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по несколько критериям (Формулы/Formulas)
Суммирование по несколько критериям
airzi Дата: Среда, 05.12.2018, 10:54 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, во вложении файл.
Суть вопроса такая.
Нужно в столбец D вставить формулу которая считает сумму бюджета (столбец C), начиная с недели из столбца K для номера из столбца J.
То есть, для номера 5000 (J2) найти всю сумму бюджета после 2.2018 (K2) из столбца C.
То есть найти сумму всех 5000 после 2.2018 недели и так же для очень большого файла данных. Нужна какая-то динамическая формула, потому что данных очень много и для каждого номера так прописывать не получится.
Сколько не ломал голову не смог ничего придумать.
Мне кажется можно как-то через СУММЕСЛИМН найти, но не получается.
К сообщению приложен файл: 4140554.xlsx(8.1 Kb)
 
Ответить
СообщениеДобрый день, во вложении файл.
Суть вопроса такая.
Нужно в столбец D вставить формулу которая считает сумму бюджета (столбец C), начиная с недели из столбца K для номера из столбца J.
То есть, для номера 5000 (J2) найти всю сумму бюджета после 2.2018 (K2) из столбца C.
То есть найти сумму всех 5000 после 2.2018 недели и так же для очень большого файла данных. Нужна какая-то динамическая формула, потому что данных очень много и для каждого номера так прописывать не получится.
Сколько не ломал голову не смог ничего придумать.
Мне кажется можно как-то через СУММЕСЛИМН найти, но не получается.

Автор - airzi
Дата добавления - 05.12.2018 в 10:54
_Boroda_ Дата: Среда, 05.12.2018, 11:01 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13698
Репутация: 5587 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если я правильно понял задачу, то зачем Вам это в столбце D? Может, лучше в L?
Код
=СУММЕСЛИМН(C:C;A:A;J2;B:B;">="&K2)

Или то же самое можно и в D
Код
=СУММЕСЛИМН(C:C;A:A;A2;B:B;">="&ВПР(A2;J$2:K$9;2;))


Если неправильно понял, то приложите файл с вручную заполненным необходимым результатом
К сообщению приложен файл: 4140554_1.xlsx(8.7 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли я правильно понял задачу, то зачем Вам это в столбце D? Может, лучше в L?
Код
=СУММЕСЛИМН(C:C;A:A;J2;B:B;">="&K2)

Или то же самое можно и в D
Код
=СУММЕСЛИМН(C:C;A:A;A2;B:B;">="&ВПР(A2;J$2:K$9;2;))


Если неправильно понял, то приложите файл с вручную заполненным необходимым результатом

Автор - _Boroda_
Дата добавления - 05.12.2018 в 11:01
airzi Дата: Среда, 05.12.2018, 11:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое, вторая формула то, что я и искал. Оказывается в этой формуле можно использовать впр)
 
Ответить
СообщениеСпасибо большое, вторая формула то, что я и искал. Оказывается в этой формуле можно использовать впр)

Автор - airzi
Дата добавления - 05.12.2018 в 11:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование по несколько критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2018 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!