Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перемножение ячеек из множества страниц со зн. в столбце - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перемножение ячеек из множества страниц со зн. в столбце (Формулы/Formulas)
Перемножение ячеек из множества страниц со зн. в столбце
RMMMM Дата: Среда, 19.12.2018, 01:19 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте,

Есть данные, одни в столбце, другие в определенной ячейке на каждой странице. Как их перемножить?

Файл приложен
К сообщению приложен файл: Book2.xlsx(13.2 Kb)
 
Ответить
СообщениеЗдравствуйте,

Есть данные, одни в столбце, другие в определенной ячейке на каждой странице. Как их перемножить?

Файл приложен

Автор - RMMMM
Дата добавления - 19.12.2018 в 01:19
Pelena Дата: Среда, 19.12.2018, 08:31 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13485
Репутация: 2971 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если правильно поняла
Код
=СУММ('1:4'!A1)*СУММ(B1:B4)

Код
=СУММПРОИЗВ(СУММ('1:4'!A1)*B1:B4)

Если не угадала, распишите, какой результат должен получиться


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла
Код
=СУММ('1:4'!A1)*СУММ(B1:B4)

Код
=СУММПРОИЗВ(СУММ('1:4'!A1)*B1:B4)

Если не угадала, распишите, какой результат должен получиться

Автор - Pelena
Дата добавления - 19.12.2018 в 08:31
RMMMM Дата: Пятница, 21.12.2018, 15:50 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
Pelena, Спасибо, я наверное неправильно объяснил что мне нужно. Нужно перемножить соответствующие значения и их сложить 1!A1*B1+ 1!A2*B2+ и т.д. Ваша формула сначала складывает столбцы, затем перемножает их.
Код
=SUMPRODUCT('1:4'!A1,B1:B4)
не работает
 
Ответить
СообщениеPelena, Спасибо, я наверное неправильно объяснил что мне нужно. Нужно перемножить соответствующие значения и их сложить 1!A1*B1+ 1!A2*B2+ и т.д. Ваша формула сначала складывает столбцы, затем перемножает их.
Код
=SUMPRODUCT('1:4'!A1,B1:B4)
не работает

Автор - RMMMM
Дата добавления - 21.12.2018 в 15:50
китин Дата: Пятница, 21.12.2018, 16:00 | Сообщение № 4
Группа: Модераторы
Ранг: Участник клуба
Сообщений: 5212
Репутация: 821 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
1!A1*B1+ 1!A2*B2

у вас на листе1 ячейка А2 пустая????


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
1!A1*B1+ 1!A2*B2

у вас на листе1 ячейка А2 пустая????

Автор - китин
Дата добавления - 21.12.2018 в 16:00
Pelena Дата: Пятница, 21.12.2018, 16:26 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 13485
Репутация: 2971 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММПРОИЗВ(Ч(ДВССЫЛ("'"&СТРОКА(1:4)&"'!A1"));B1:B4)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(Ч(ДВССЫЛ("'"&СТРОКА(1:4)&"'!A1"));B1:B4)

Автор - Pelena
Дата добавления - 21.12.2018 в 16:26
Светлый Дата: Пятница, 21.12.2018, 16:53 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 842
Репутация: 214 ±
Замечаний: 0% ±

Excel 2010
Код
=СУММПРОИЗВ(Ч(ДВССЫЛ(СТРОКА(1:4)&"!a1"))*B1:B4)


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(Ч(ДВССЫЛ(СТРОКА(1:4)&"!a1"))*B1:B4)

Автор - Светлый
Дата добавления - 21.12.2018 в 16:53
RMMMM Дата: Пятница, 21.12.2018, 18:07 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 1 ±
Замечаний: 0% ±

Excel 2010
у вас на листе1 ячейка А2 пустая????

Извиняюсь, 1!A1*B1+ 2!A1*B2+ и т.д.

Pelena, Светлый, спасибо, все работает как нужно.
 
Ответить
Сообщение
у вас на листе1 ячейка А2 пустая????

Извиняюсь, 1!A1*B1+ 2!A1*B2+ и т.д.

Pelena, Светлый, спасибо, все работает как нужно.

Автор - RMMMM
Дата добавления - 21.12.2018 в 18:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перемножение ячеек из множества страниц со зн. в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!