Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Заполнить ячейки числами - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить ячейки числами (Формулы/Formulas)
Заполнить ячейки числами
bobrenja Дата: Суббота, 22.12.2018, 19:33 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Помогите решить задачку. Нужно заполнить ячейки числами... На первый взгляд решение простое, но решить не могу.
Детали в примере.
К сообщению приложен файл: primer.xlsx(9.0 Kb)


Сообщение отредактировал bobrenja - Суббота, 22.12.2018, 19:34
 
Ответить
СообщениеПомогите решить задачку. Нужно заполнить ячейки числами... На первый взгляд решение простое, но решить не могу.
Детали в примере.

Автор - bobrenja
Дата добавления - 22.12.2018 в 19:33
bobrenja Дата: Суббота, 22.12.2018, 19:35 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 121
Репутация: 0 ±
Замечаний: 0% ±

Excel для Mac and WIN
Можно с допом.


Сообщение отредактировал bobrenja - Суббота, 22.12.2018, 19:35
 
Ответить
СообщениеМожно с допом.

Автор - bobrenja
Дата добавления - 22.12.2018 в 19:35
Pelena Дата: Суббота, 22.12.2018, 20:00 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 13786
Репутация: 3028 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ЕСЛИ(B2;B2;C1)
К сообщению приложен файл: primer-5-.xlsx(9.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(B2;B2;C1)

Автор - Pelena
Дата добавления - 22.12.2018 в 20:00
Nic70y Дата: Суббота, 22.12.2018, 20:06 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5190
Репутация: 1125 ±
Замечаний: 0% ±

Excel 2013
[vba]
Код
Sub u_187()
    For Each u In Range("b2:b" & Cells(Rows.Count, "b").End(xlUp).Row)
        If u = 0 Then u.Value = u.Offset(-1, 0).Value
    Next
End Sub
[/vba]
К сообщению приложен файл: primer-1-.xlsm(17.5 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение[vba]
Код
Sub u_187()
    For Each u In Range("b2:b" & Cells(Rows.Count, "b").End(xlUp).Row)
        If u = 0 Then u.Value = u.Offset(-1, 0).Value
    Next
End Sub
[/vba]

Автор - Nic70y
Дата добавления - 22.12.2018 в 20:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Заполнить ячейки числами (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!