Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/не считает ЕСЛИ + ВПР - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » не считает ЕСЛИ + ВПР (Формулы/Formulas)
не считает ЕСЛИ + ВПР
koyaanisqatsi Дата: Пятница, 28.12.2018, 14:09 | Сообщение № 1
Группа: Проверенные
Ранг: Ветеран
Сообщений: 694
Репутация: 15 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте. С Наступающим Новым Годом.

Подскажите пожалуйста, почему у меня без если все считается а с ЕСЛИ уже не хочет

Лимак_Комплекс - берется из диспетчера имен. Ячейка $A71=202 такое же значение присутствует и в Имени Лимак_Комплекс. Даже рисует на нем ИСТИНА но по какой-то причине не срабатывает.
на всякий случай дублирую картинку

После нескольких нажатий вычислить в окошке пустота а потом все по новой. (((

Код
{=ЕСЛИ(A71=Лимак_Комплекс;ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ);"")}
не работает формула

Код
{=ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ)}
Работает формула


Сообщение отредактировал koyaanisqatsi - Пятница, 28.12.2018, 14:10
 
Ответить
СообщениеЗдравствуйте. С Наступающим Новым Годом.

Подскажите пожалуйста, почему у меня без если все считается а с ЕСЛИ уже не хочет

Лимак_Комплекс - берется из диспетчера имен. Ячейка $A71=202 такое же значение присутствует и в Имени Лимак_Комплекс. Даже рисует на нем ИСТИНА но по какой-то причине не срабатывает.
на всякий случай дублирую картинку

После нескольких нажатий вычислить в окошке пустота а потом все по новой. (((

Код
{=ЕСЛИ(A71=Лимак_Комплекс;ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ);"")}
не работает формула

Код
{=ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ)}
Работает формула

Автор - koyaanisqatsi
Дата добавления - 28.12.2018 в 14:09
_Boroda_ Дата: Пятница, 28.12.2018, 14:14 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14501
Репутация: 5789 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Лимак_Комплекс - массив. A71=Лимак_Комплекс дает такой же по размерности массив из ИСТИНА или ЛОЖЬ. В условие к ЕСЛИ Вы суете этот массив, на выходе должно получиться тоже много значений (столько, сколько в массиве). В общем случае ВПР будет работать только для первого из них условия (не всегда так, но речь сейчас не об этом)
Можно написать ЕСЛИ(ИЛИ(...
Массивная формула


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЛимак_Комплекс - массив. A71=Лимак_Комплекс дает такой же по размерности массив из ИСТИНА или ЛОЖЬ. В условие к ЕСЛИ Вы суете этот массив, на выходе должно получиться тоже много значений (столько, сколько в массиве). В общем случае ВПР будет работать только для первого из них условия (не всегда так, но речь сейчас не об этом)
Можно написать ЕСЛИ(ИЛИ(...
Массивная формула

Автор - _Boroda_
Дата добавления - 28.12.2018 в 14:14
koyaanisqatsi Дата: Пятница, 28.12.2018, 14:23 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 694
Репутация: 15 ±
Замечаний: 0% ±

Excel 2010
_Boroda_, Спасибо большое. прискорбно конечно что я сам ничего не понял хоть вы и очень толково все объяснили. но Аллелуя заработало)
Код
=ЕСЛИ(ИЛИ(A71=Лимак_Комплекс);ЕСЛИОШИБКА(ЕСЛИ(ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ)=0;0;ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ));0);"")

Еще Раз С Наступающим !!!
 
Ответить
Сообщение_Boroda_, Спасибо большое. прискорбно конечно что я сам ничего не понял хоть вы и очень толково все объяснили. но Аллелуя заработало)
Код
=ЕСЛИ(ИЛИ(A71=Лимак_Комплекс);ЕСЛИОШИБКА(ЕСЛИ(ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ)=0;0;ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ));0);"")

Еще Раз С Наступающим !!!

Автор - koyaanisqatsi
Дата добавления - 28.12.2018 в 14:23
_Boroda_ Дата: Пятница, 28.12.2018, 14:48 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14501
Репутация: 5789 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Вот это
Цитата koyaanisqatsi, 28.12.2018 в 14:23, в сообщении № 3 ()
ЕСЛИ(ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ)=0;0;ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ))

равносильно этому
Код
ВПР($A71;заявки!$A:$AP;P$441;)

Итого получается
Код
=ЕСЛИ(ИЛИ(A71=Лимак_Комплекс);ЕСЛИОШИБКА(ВПР($A71;заявки!$A:$AP;P$441;);0);"")

И ВПР лучше не делать по целым столбцам
Код
=ЕСЛИ(ИЛИ(A71=Лимак_Комплекс);ЕСЛИОШИБКА(ВПР($A71;заявки!$A$1:$AP$9999;P$441;);0);"")


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеВот это
Цитата koyaanisqatsi, 28.12.2018 в 14:23, в сообщении № 3 ()
ЕСЛИ(ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ)=0;0;ВПР($A71;заявки!$A:$AP;P$441;ЛОЖЬ))

равносильно этому
Код
ВПР($A71;заявки!$A:$AP;P$441;)

Итого получается
Код
=ЕСЛИ(ИЛИ(A71=Лимак_Комплекс);ЕСЛИОШИБКА(ВПР($A71;заявки!$A:$AP;P$441;);0);"")

И ВПР лучше не делать по целым столбцам
Код
=ЕСЛИ(ИЛИ(A71=Лимак_Комплекс);ЕСЛИОШИБКА(ВПР($A71;заявки!$A$1:$AP$9999;P$441;);0);"")

Автор - _Boroda_
Дата добавления - 28.12.2018 в 14:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » не считает ЕСЛИ + ВПР (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!