Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Найти значение в столбце а и сложить значения из столбца c - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти значение в столбце а и сложить значения из столбца c (Формулы/Formulas)
Найти значение в столбце а и сложить значения из столбца c
finomengt Дата: Суббота, 29.12.2018, 18:15 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте.
Подскажите пожалуйста как сделать так:
Ищу в столбце А значения "1024" "1416" "1787". Если какие-либо из этих значений найдены, берется информация из той же строки, столбца C. Если найдено несколько значений, например нашлось 1024 1416 - значение в столбце С у 1024 - 3. У 1416 - 68
Нужно чтобы это находилось автоматически и значения с столбца С суммировалось в отдельную ячейку
К сообщению приложен файл: _Microsoft_Exce.xlsx(9.5 Kb)


Сообщение отредактировал finomengt - Суббота, 29.12.2018, 18:43
 
Ответить
СообщениеЗдравствуйте.
Подскажите пожалуйста как сделать так:
Ищу в столбце А значения "1024" "1416" "1787". Если какие-либо из этих значений найдены, берется информация из той же строки, столбца C. Если найдено несколько значений, например нашлось 1024 1416 - значение в столбце С у 1024 - 3. У 1416 - 68
Нужно чтобы это находилось автоматически и значения с столбца С суммировалось в отдельную ячейку

Автор - finomengt
Дата добавления - 29.12.2018 в 18:15
AlexM Дата: Суббота, 29.12.2018, 18:36 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Название темы должно отображать суть задачи. Это требование правил форума, которые нужно прочитать до создания сообщения. Поменяйте название темы.



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
СообщениеНазвание темы должно отображать суть задачи. Это требование правил форума, которые нужно прочитать до создания сообщения. Поменяйте название темы.

Автор - AlexM
Дата добавления - 29.12.2018 в 18:36
AlexM Дата: Суббота, 29.12.2018, 18:47 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Код
=СУММПРОИЗВ((--A1:A29={1024;1416;1787})*C1:C29)



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.
 
Ответить
Сообщение
Код
=СУММПРОИЗВ((--A1:A29={1024;1416;1787})*C1:C29)

Автор - AlexM
Дата добавления - 29.12.2018 в 18:47
finomengt Дата: Суббота, 29.12.2018, 18:50 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=СУММПРОИЗВ((--A1:A29={1024;1416;1787})*C1:C29)

Благодарю :)
 
Ответить
Сообщение
=СУММПРОИЗВ((--A1:A29={1024;1416;1787})*C1:C29)

Благодарю :)

Автор - finomengt
Дата добавления - 29.12.2018 в 18:50
finomengt Дата: Суббота, 29.12.2018, 19:10 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
=SUMPRODUCT((--A1:A29={1024,1416,1787})*C1:C29)

Возникла проблема, я не учел что в документе есть строки на несколько столбцов которые мешают счету
Пример в ячейке H9 и H6
К сообщению приложен файл: 0774749.xlsx(10.6 Kb)
 
Ответить
Сообщение
=SUMPRODUCT((--A1:A29={1024,1416,1787})*C1:C29)

Возникла проблема, я не учел что в документе есть строки на несколько столбцов которые мешают счету
Пример в ячейке H9 и H6

Автор - finomengt
Дата добавления - 29.12.2018 в 19:10
Pelena Дата: Суббота, 29.12.2018, 20:08 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14087
Репутация: 3080 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
У Вас числа сохранены как текст.
Можно так попробовать
Код
=СУММПРОИЗВ((A1:A24={1028;1256;1417;2336}&"")*C1:C24)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеУ Вас числа сохранены как текст.
Можно так попробовать
Код
=СУММПРОИЗВ((A1:A24={1028;1256;1417;2336}&"")*C1:C24)

Автор - Pelena
Дата добавления - 29.12.2018 в 20:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Найти значение в столбце а и сложить значения из столбца c (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!