Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поискпоз всех совпадений в столбце и смещ в отд. ячейки - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поискпоз всех совпадений в столбце и смещ в отд. ячейки (Формулы/Formulas)
Поискпоз всех совпадений в столбце и смещ в отд. ячейки
UpFRONT Дата: Воскресенье, 30.12.2018, 15:12 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Привет всем профессионалам и жителям форума. Помогите пож-та составить правлиьно формулы.
Есть список в столбце с ячейками "ПОмещения". вокруг данной ячейки есть еще необходимая информация. которую необходимо транспонировать.
задача: найти поискпоз все совпадения в столбце А ячеек "ПОмещения". Перенести значения из столба В в соотстветвующей строке с помещением в стобец Н и далее по примеру.
К сообщению приложен файл: 4091804.xlsx(9.5 Kb)
 
Ответить
СообщениеПривет всем профессионалам и жителям форума. Помогите пож-та составить правлиьно формулы.
Есть список в столбце с ячейками "ПОмещения". вокруг данной ячейки есть еще необходимая информация. которую необходимо транспонировать.
задача: найти поискпоз все совпадения в столбце А ячеек "ПОмещения". Перенести значения из столба В в соотстветвующей строке с помещением в стобец Н и далее по примеру.

Автор - UpFRONT
Дата добавления - 30.12.2018 в 15:12
Pelena Дата: Воскресенье, 30.12.2018, 15:57 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13485
Репутация: 2971 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Если группы идут через одинаковое кол-во строк, то можно так
Код
=ИНДЕКС($B$1:$B$17;СТРОКА(A1)*7-6)
К сообщению приложен файл: 9920497.xlsx(10.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если группы идут через одинаковое кол-во строк, то можно так
Код
=ИНДЕКС($B$1:$B$17;СТРОКА(A1)*7-6)

Автор - Pelena
Дата добавления - 30.12.2018 в 15:57
UpFRONT Дата: Понедельник, 31.12.2018, 16:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Если группы идут через одинаковое кол-во строк, то можно так

Спасибо, а если не одинаковое количество строк между группами?.
Вы в примере сделали абсолютно точно то что надо.
Как вообще искать совпадения по таблице не возвращаясь к первому найденному результату а вытащить все СОВПАДЕнИЯ!!!
 
Ответить
Сообщение
Здравствуйте.
Если группы идут через одинаковое кол-во строк, то можно так

Спасибо, а если не одинаковое количество строк между группами?.
Вы в примере сделали абсолютно точно то что надо.
Как вообще искать совпадения по таблице не возвращаясь к первому найденному результату а вытащить все СОВПАДЕнИЯ!!!

Автор - UpFRONT
Дата добавления - 31.12.2018 в 16:33
bmv98rus Дата: Понедельник, 31.12.2018, 16:57 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1468
Репутация: 243 ±
Замечаний: 0% ±

Excel 2013/2016
тогда в доп столбце G массивно
Код
=SMALL(IF($A$1:$A$100="Помещение";ROW($A$1:$A$100));ROW(A1))
и
Код
=INDEX($B:$B;$G5+COLUMN(A1)-1)


Обработку ошибок добавить по вкусу.


Сообщение отредактировал bmv98rus - Понедельник, 31.12.2018, 16:57
 
Ответить
Сообщениетогда в доп столбце G массивно
Код
=SMALL(IF($A$1:$A$100="Помещение";ROW($A$1:$A$100));ROW(A1))
и
Код
=INDEX($B:$B;$G5+COLUMN(A1)-1)


Обработку ошибок добавить по вкусу.

Автор - bmv98rus
Дата добавления - 31.12.2018 в 16:57
jakim Дата: Понедельник, 31.12.2018, 17:05 | Сообщение № 5
Группа: Друзья
Ранг: Ветеран
Сообщений: 875
Репутация: 230 ±
Замечаний: 0% ±

Excel 2010
Предлагаю формулу

Код
=IFERROR(INDEX($B$1:$B$200;AGGREGATE(15;6;ROW($1:$200)/($A$1:$A$200=H$4);ROWS($5:5)));"")

Впишите её в ячейку Н5 и протяните вниз и вправо.
 
Ответить
Сообщение
Предлагаю формулу

Код
=IFERROR(INDEX($B$1:$B$200;AGGREGATE(15;6;ROW($1:$200)/($A$1:$A$200=H$4);ROWS($5:5)));"")

Впишите её в ячейку Н5 и протяните вниз и вправо.

Автор - jakim
Дата добавления - 31.12.2018 в 17:05
Nic70y Дата: Вторник, 01.01.2019, 15:13 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5054
Репутация: 1086 ±
Замечаний: 0% ±

Excel 2013
Еще вариант с доп.столбцом и смещением на 1 строку
Код
=ЕСЛИ(B2=$B$2;A1+1;A1)
Код
=ИНДЕКС($C:$C;ПОИСКПОЗ(СТРОКА(I1);$A:$A;)+СТОЛБЕЦ(A1)-1)
К сообщению приложен файл: 5712144.xlsx(10.2 Kb)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
СообщениеЕще вариант с доп.столбцом и смещением на 1 строку
Код
=ЕСЛИ(B2=$B$2;A1+1;A1)
Код
=ИНДЕКС($C:$C;ПОИСКПОЗ(СТРОКА(I1);$A:$A;)+СТОЛБЕЦ(A1)-1)

Автор - Nic70y
Дата добавления - 01.01.2019 в 15:13
UpFRONT Дата: Вторник, 01.01.2019, 17:23 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Как то все не просто, СПАСИБО!!!. а как найти ссылки на строка-столбец всех совпадений только ячейки с ПОМЕЩЕНИЕМ.
 
Ответить
СообщениеКак то все не просто, СПАСИБО!!!. а как найти ссылки на строка-столбец всех совпадений только ячейки с ПОМЕЩЕНИЕМ.

Автор - UpFRONT
Дата добавления - 01.01.2019 в 17:23
Nic70y Дата: Вторник, 01.01.2019, 17:30 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5054
Репутация: 1086 ±
Замечаний: 0% ±

Excel 2013
Как то все не просто
как-то не понятен Ваш вопрос.
Неужели ни одна формула не подошла?


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Как то все не просто
как-то не понятен Ваш вопрос.
Неужели ни одна формула не подошла?

Автор - Nic70y
Дата добавления - 01.01.2019 в 17:30
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поискпоз всех совпадений в столбце и смещ в отд. ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!