Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывести и запомнить максимальное число из ячейки. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести и запомнить максимальное число из ячейки. (Формулы/Formulas)
Вывести и запомнить максимальное число из ячейки.
stalber Дата: Среда, 02.01.2019, 22:24 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 260
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый день, подскажите пожалуйста формулу.

Задача: Нужная мне формула стоит например в ячейки A2 и она выводит максимальное число которое появилось в ячейке A1 (в ячейки A1 периодически разные числа появляются, перезаписываются).
Допустим в ячейке A1 появилось число 10, в ячейки A2 тоже появилось число 10 и оно там так и останется, до тех пор пока в ячейке A1 не появится число большее чем 10, как только в ячейке A1 появилось например число 25 то в ячейке A2 теперь будет стоять число 25, до тех пор пока не появится большее число чем 25.

Получается, нужная мне формула будет привязана конкретно только к одной ячейки A1, и выводить максимальное число которое там появлялось.
 
Ответить
СообщениеДобрый день, подскажите пожалуйста формулу.

Задача: Нужная мне формула стоит например в ячейки A2 и она выводит максимальное число которое появилось в ячейке A1 (в ячейки A1 периодически разные числа появляются, перезаписываются).
Допустим в ячейке A1 появилось число 10, в ячейки A2 тоже появилось число 10 и оно там так и останется, до тех пор пока в ячейке A1 не появится число большее чем 10, как только в ячейке A1 появилось например число 25 то в ячейке A2 теперь будет стоять число 25, до тех пор пока не появится большее число чем 25.

Получается, нужная мне формула будет привязана конкретно только к одной ячейки A1, и выводить максимальное число которое там появлялось.

Автор - stalber
Дата добавления - 02.01.2019 в 22:24
AlexM Дата: Среда, 02.01.2019, 22:36 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3841
Репутация: 968 ±
Замечаний: 0% ±

Excel 2003
Формулой не получится. Макрос нужен, который запускается при изменении значения в ячейке А1
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Address <> "$A$1" Then Exit Sub
    If Target > Range("A2") Then Range("A2") = Target
End Sub
[/vba]



Номер мобильного модема (без голосовой связи)
9269171249 МегаФон, Московский регион.


Сообщение отредактировал AlexM - Среда, 02.01.2019, 22:43
 
Ответить
СообщениеФормулой не получится. Макрос нужен, который запускается при изменении значения в ячейке А1
[vba]
Код
Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Address <> "$A$1" Then Exit Sub
    If Target > Range("A2") Then Range("A2") = Target
End Sub
[/vba]

Автор - AlexM
Дата добавления - 02.01.2019 в 22:36
vikttur Дата: Четверг, 03.01.2019, 13:56 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Только для информации. Будете использовать - я не виноват :)
Файл-Параметры-Формулы. Здесь есть возможность включить итеративные вычисления. Инструмент разрешает использовать зацикливания при вычислениях. Предназначен для проведения точных вычислений (геодезия, например).

Использование итераций для хранения данных - костыль.
Итеративные вычисления имеют несколько неприятных моментов (игнорирование нежелательных зацикливаний, самопроизвольное включение итеративных вычислений в других открытых файлах...), поэтому применять можно только при полной уверенности в том, что инструмент неплохо изучен и последствия отслеживаются.

Разрешить итеративные вычисления, число итераций - для этой задачи достаточно 1. В А2 формула:
Код
=МАКС(A1;A2)

Можно предусмотреть какой-либо флаг сброса. Например, в В2 - 1 или 0. Тогда формула А2:
Код
=ЕСЛИ(B2;МАКС(A1;A2);)


Сообщение отредактировал vikttur - Четверг, 03.01.2019, 13:58
 
Ответить
СообщениеТолько для информации. Будете использовать - я не виноват :)
Файл-Параметры-Формулы. Здесь есть возможность включить итеративные вычисления. Инструмент разрешает использовать зацикливания при вычислениях. Предназначен для проведения точных вычислений (геодезия, например).

Использование итераций для хранения данных - костыль.
Итеративные вычисления имеют несколько неприятных моментов (игнорирование нежелательных зацикливаний, самопроизвольное включение итеративных вычислений в других открытых файлах...), поэтому применять можно только при полной уверенности в том, что инструмент неплохо изучен и последствия отслеживаются.

Разрешить итеративные вычисления, число итераций - для этой задачи достаточно 1. В А2 формула:
Код
=МАКС(A1;A2)

Можно предусмотреть какой-либо флаг сброса. Например, в В2 - 1 или 0. Тогда формула А2:
Код
=ЕСЛИ(B2;МАКС(A1;A2);)

Автор - vikttur
Дата добавления - 03.01.2019 в 13:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывести и запомнить максимальное число из ячейки. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!