Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Неточная работа ЕСЛИ, для времени. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Неточная работа ЕСЛИ, для времени. (Формулы/Formulas)
Неточная работа ЕСЛИ, для времени.
RagnarLodbrokovitch Дата: Вторник, 08.01.2019, 23:36 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Здравствуйте.
Ответьте на вопрос.

Почему не работает логическое условие ЕСЛИ, на проверку времени ?
Сейчас формула выдает неверный результат в ячейку C3, при анализе ячейки А1.
К сообщению приложен файл: 3040147.xls(27.5 Kb)
 
Ответить
СообщениеЗдравствуйте.
Ответьте на вопрос.

Почему не работает логическое условие ЕСЛИ, на проверку времени ?
Сейчас формула выдает неверный результат в ячейку C3, при анализе ячейки А1.

Автор - RagnarLodbrokovitch
Дата добавления - 08.01.2019 в 23:36
Hugo Дата: Среда, 09.01.2019, 00:13 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2869
Репутация: 641 ±
Замечаний: 0% ±

Доброй ночи :)
Вы пристальнее посмотрите на значение в А1 - там ведь 01.01.1900 0:06:54
Так что формула выдаёт всё верно.


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069


Сообщение отредактировал Hugo - Среда, 09.01.2019, 00:14
 
Ответить
СообщениеДоброй ночи :)
Вы пристальнее посмотрите на значение в А1 - там ведь 01.01.1900 0:06:54
Так что формула выдаёт всё верно.

Автор - Hugo
Дата добавления - 09.01.2019 в 00:13
RagnarLodbrokovitch Дата: Среда, 09.01.2019, 00:36 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Hugo, а как избавится от этой "01.01.1900 " ?
Откуда она появляется ?

Я ее уже несколько раз удалял, но эта вещь - появляется вновь и вновь.
 
Ответить
СообщениеHugo, а как избавится от этой "01.01.1900 " ?
Откуда она появляется ?

Я ее уже несколько раз удалял, но эта вещь - появляется вновь и вновь.

Автор - RagnarLodbrokovitch
Дата добавления - 09.01.2019 в 00:36
Hugo Дата: Среда, 09.01.2019, 00:55 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2869
Репутация: 641 ±
Замечаний: 0% ±

Я удалил без проблем, ничего снова не появляется.


excel@nxt.ru
webmoney: E265281470651 R418926282008 Z422237915069
 
Ответить
СообщениеЯ удалил без проблем, ничего снова не появляется.

Автор - Hugo
Дата добавления - 09.01.2019 в 00:55
Nic70y Дата: Среда, 09.01.2019, 14:10 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5054
Репутация: 1086 ±
Замечаний: 0% ±

Excel 2013
Код
=ЕСЛИ(И(ОСТАТ(A1;1)>--"00:00:01";ОСТАТ(A1;1)<--"06:00:00");"Ночь";1)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=ЕСЛИ(И(ОСТАТ(A1;1)>--"00:00:01";ОСТАТ(A1;1)<--"06:00:00");"Ночь";1)

Автор - Nic70y
Дата добавления - 09.01.2019 в 14:10
_Boroda_ Дата: Среда, 09.01.2019, 14:43 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 13925
Репутация: 5635 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще
Код
=ЕСЛИ((ОСТАТ(A1;1)<--"6:")*A1;"Ночь";1)

Код
=ЕСЛИ((A1<ОТБР(A1)+"6:")*A1;"Ночь";1)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще
Код
=ЕСЛИ((ОСТАТ(A1;1)<--"6:")*A1;"Ночь";1)

Код
=ЕСЛИ((A1<ОТБР(A1)+"6:")*A1;"Ночь";1)

Автор - _Boroda_
Дата добавления - 09.01.2019 в 14:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Неточная работа ЕСЛИ, для времени. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!