Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Использование знака Больше или Равно - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование знака Больше или Равно (Формулы/Formulas)
Использование знака Больше или Равно
Vsokolov Дата: Пятница, 11.01.2019, 01:33 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Возможно ли в Excel такое выражение? Имею в виду, знаки "больше или равно" обрамляют операнд с двух сторон.
Код
=ЕСЛИ(5<=D28<=6;$M$5;ЕСЛИ(7<=D28<=8;$M$6;ЕСЛИ(9<=D28<=19;$M$7;ЕСЛИ(20<=D28<=28;$M$8;"не_в_диапазоне"))))

Формула не работает


Сообщение отредактировал Vsokolov - Пятница, 11.01.2019, 01:33
 
Ответить
СообщениеВозможно ли в Excel такое выражение? Имею в виду, знаки "больше или равно" обрамляют операнд с двух сторон.
Код
=ЕСЛИ(5<=D28<=6;$M$5;ЕСЛИ(7<=D28<=8;$M$6;ЕСЛИ(9<=D28<=19;$M$7;ЕСЛИ(20<=D28<=28;$M$8;"не_в_диапазоне"))))

Формула не работает

Автор - Vsokolov
Дата добавления - 11.01.2019 в 01:33
vikttur Дата: Пятница, 11.01.2019, 02:38 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Естественно, не работает. Два условия записываются раздельно в функции И или ИЛИ:
Код
И(D28>=5;D28<=6)

Код
ИЛИ(D28=5;D28=6)

Код
ИЛИ(D28={5;6})

В каскаде функций ЕСЛИ одно из условий проверяется в предыдущей или последующей функции, поэтому проверять два условия - лишнее:
Код
=ЕСЛИ(ИЛИ(D28<5;D28>28);"не_в_диапазоне";ЕСЛИ(D28<=6;$M$5;ЕСЛИ(D28<=8;$M$6;ЕСЛИ(D28<=19;$M$7;ЕСЛИ(D28<=28;$M$8)))))

Каскад ЕСЛИ можно заменить:
Код
ИНДЕКС($M$5:$M$8;ПОИСКПОЗ(D28;{5;7;9;20}))

Код
=ПРОСМОТР(D28;{5;7;9;20};$M$5:$M$8)

Или указать значения диапазона в массиве консант:
Код
=ВПР(D28;{5;11:7;"ок":9;22:20;33};2)

где 11, "ок", 22, 33 - значения из M5:M8


Сообщение отредактировал vikttur - Пятница, 11.01.2019, 10:07
 
Ответить
СообщениеЕстественно, не работает. Два условия записываются раздельно в функции И или ИЛИ:
Код
И(D28>=5;D28<=6)

Код
ИЛИ(D28=5;D28=6)

Код
ИЛИ(D28={5;6})

В каскаде функций ЕСЛИ одно из условий проверяется в предыдущей или последующей функции, поэтому проверять два условия - лишнее:
Код
=ЕСЛИ(ИЛИ(D28<5;D28>28);"не_в_диапазоне";ЕСЛИ(D28<=6;$M$5;ЕСЛИ(D28<=8;$M$6;ЕСЛИ(D28<=19;$M$7;ЕСЛИ(D28<=28;$M$8)))))

Каскад ЕСЛИ можно заменить:
Код
ИНДЕКС($M$5:$M$8;ПОИСКПОЗ(D28;{5;7;9;20}))

Код
=ПРОСМОТР(D28;{5;7;9;20};$M$5:$M$8)

Или указать значения диапазона в массиве консант:
Код
=ВПР(D28;{5;11:7;"ок":9;22:20;33};2)

где 11, "ок", 22, 33 - значения из M5:M8

Автор - vikttur
Дата добавления - 11.01.2019 в 02:38
Gustav Дата: Пятница, 11.01.2019, 13:00 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1654
Репутация: 672 ±
Замечаний: 0% ±

начинал с Excel 4.0...
И(D28>=5;D28<=6)

Для придания некоторого визуального сходства с математическим неравенством я иногда записываю подобные условия в следующей форме:
Код
И(5<=D28;D28<=6)


Мой tip box - яд 41001663842605
 
Ответить
Сообщение
И(D28>=5;D28<=6)

Для придания некоторого визуального сходства с математическим неравенством я иногда записываю подобные условия в следующей форме:
Код
И(5<=D28;D28<=6)

Автор - Gustav
Дата добавления - 11.01.2019 в 13:00
_Boroda_ Дата: Пятница, 11.01.2019, 13:24 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще можно так поизвращаться
Код
=МЕДИАНА(5;6;D28)=D28

Медиана трех чисел дает среднее (по расположению на цифровой оси) из них. Среднее - это меньше или равно большего и больше или равно меньшего :) Если среднее равно искомому D28, то это D28 как раз находится между 5 и 6


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще можно так поизвращаться
Код
=МЕДИАНА(5;6;D28)=D28

Медиана трех чисел дает среднее (по расположению на цифровой оси) из них. Среднее - это меньше или равно большего и больше или равно меньшего :) Если среднее равно искомому D28, то это D28 как раз находится между 5 и 6

Автор - _Boroda_
Дата добавления - 11.01.2019 в 13:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Использование знака Больше или Равно (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!