Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Извлечь слово по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь слово по условию (Формулы/Formulas)
Извлечь слово по условию
exe Дата: Суббота, 12.01.2019, 14:13 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте!
Помогите решить задачку. Есть столбец с несколькими номерами РД, кол-во № в ячейке от 1 до 30 (с разделителями через запятую и пробел)
Необходимо извлечь только один с кодом «DC»
К сообщению приложен файл: ____2003.xls(27.0 Kb)
 
Ответить
СообщениеЗдравствуйте!
Помогите решить задачку. Есть столбец с несколькими номерами РД, кол-во № в ячейке от 1 до 30 (с разделителями через запятую и пробел)
Необходимо извлечь только один с кодом «DC»

Автор - exe
Дата добавления - 12.01.2019 в 14:13
vikttur Дата: Суббота, 12.01.2019, 14:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2808
Репутация: 504 ±
Замечаний: 0% ±

Если длина всех кодов одинакова:
Код
=ПСТР(A2;ПОИСК("DC";A2)-30;37)


Сообщение отредактировал vikttur - Суббота, 12.01.2019, 14:23
 
Ответить
СообщениеЕсли длина всех кодов одинакова:
Код
=ПСТР(A2;ПОИСК("DC";A2)-30;37)

Автор - vikttur
Дата добавления - 12.01.2019 в 14:22
exe Дата: Суббота, 12.01.2019, 16:59 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Отлично! Работает. Был почти рядом, походу мозгов не хватило
Убрал ошибку и закрыл тему!
Код
=ЕСЛИОШИБКА(ПСТР(A4;ПОИСК("DC";A4)-30;37);"Нет данных")

Спасибо!!!
 
Ответить
СообщениеОтлично! Работает. Был почти рядом, походу мозгов не хватило
Убрал ошибку и закрыл тему!
Код
=ЕСЛИОШИБКА(ПСТР(A4;ПОИСК("DC";A4)-30;37);"Нет данных")

Спасибо!!!

Автор - exe
Дата добавления - 12.01.2019 в 16:59
vikttur Дата: Суббота, 12.01.2019, 17:13 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2808
Репутация: 504 ±
Замечаний: 0% ±

Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("DC";A4));ПСТР(A4;ПОИСК("DC";A4)-30;37);"Нет данных")


Сообщение отредактировал vikttur - Суббота, 12.01.2019, 17:14
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСК("DC";A4));ПСТР(A4;ПОИСК("DC";A4)-30;37);"Нет данных")

Автор - vikttur
Дата добавления - 12.01.2019 в 17:13
exe Дата: Понедельник, 14.01.2019, 00:28 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
ОК! Спасибо
 
Ответить
СообщениеОК! Спасибо

Автор - exe
Дата добавления - 14.01.2019 в 00:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Извлечь слово по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!