Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/расчет суммы по столбцу, с нахождением символов других стлб - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет суммы по столбцу, с нахождением символов других стлб (Формулы/Formulas)
расчет суммы по столбцу, с нахождением символов других стлб
fran4esko Дата: Воскресенье, 13.01.2019, 15:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Необходимо что бы подсчиталась сумма (столбец 4) при условии:
в столбце 1 (B:B): все что начинается на 140;
в столбце 2 (C:C): все что содержит F и не содержит R;
в столбце 3 (D:D): дата сегодня()-1

примечание: создавать доп столбцы нельзя, сводные создавать нельзя, только формула для подсчета общей суммы
пробовал через суммеслимн но не берет F при прописывание "*F*"

заранее благодарен, пример прикладываю
К сообщению приложен файл: 3421239.xlsx(16.4 Kb)


Сообщение отредактировал fran4esko - Воскресенье, 13.01.2019, 16:12
 
Ответить
СообщениеНеобходимо что бы подсчиталась сумма (столбец 4) при условии:
в столбце 1 (B:B): все что начинается на 140;
в столбце 2 (C:C): все что содержит F и не содержит R;
в столбце 3 (D:D): дата сегодня()-1

примечание: создавать доп столбцы нельзя, сводные создавать нельзя, только формула для подсчета общей суммы
пробовал через суммеслимн но не берет F при прописывание "*F*"

заранее благодарен, пример прикладываю

Автор - fran4esko
Дата добавления - 13.01.2019 в 15:39
vikttur Дата: Воскресенье, 13.01.2019, 15:52 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Код
=СУММ(СЧЁТЕСЛИМН(B2:B196;">=14000";C2:C196;{"*F*";"*F*R*"};D2:D196;СЕГОДНЯ()-1)*{1;-1})

В примере во всех строках есть F. Возможно, достаточно проверки только на наличие R
Код
=СЧЁТЕСЛИМН(B2:B196;">=14000";C2:C196;"<>*R*";D2:D196;СЕГОДНЯ()-1)


Сообщение отредактировал vikttur - Воскресенье, 13.01.2019, 15:54
 
Ответить
Сообщение
Код
=СУММ(СЧЁТЕСЛИМН(B2:B196;">=14000";C2:C196;{"*F*";"*F*R*"};D2:D196;СЕГОДНЯ()-1)*{1;-1})

В примере во всех строках есть F. Возможно, достаточно проверки только на наличие R
Код
=СЧЁТЕСЛИМН(B2:B196;">=14000";C2:C196;"<>*R*";D2:D196;СЕГОДНЯ()-1)

Автор - vikttur
Дата добавления - 13.01.2019 в 15:52
Pelena Дата: Воскресенье, 13.01.2019, 15:57 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14342
Репутация: 3134 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Как вариант
Код
=СУММПРОИЗВ((ЛЕВСИМВ($B$2:$B$196;3)="140")*ЕЧИСЛО(ПОИСК("F";$C$2:$C$196))*ЕОШИБКА(ПОИСК("R";$C$2:$C$196))*($D$2:$D$196=СЕГОДНЯ()-1))
только это количество, а не сумма

для суммы
Код
=СУММПРОИЗВ($E$2:$E$196*(ЛЕВСИМВ($B$2:$B$196;3)="140")*ЕЧИСЛО(ПОИСК("F";$C$2:$C$196))*ЕОШИБКА(ПОИСК("R";$C$2:$C$196))*($D$2:$D$196=СЕГОДНЯ()-1))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеКак вариант
Код
=СУММПРОИЗВ((ЛЕВСИМВ($B$2:$B$196;3)="140")*ЕЧИСЛО(ПОИСК("F";$C$2:$C$196))*ЕОШИБКА(ПОИСК("R";$C$2:$C$196))*($D$2:$D$196=СЕГОДНЯ()-1))
только это количество, а не сумма

для суммы
Код
=СУММПРОИЗВ($E$2:$E$196*(ЛЕВСИМВ($B$2:$B$196;3)="140")*ЕЧИСЛО(ПОИСК("F";$C$2:$C$196))*ЕОШИБКА(ПОИСК("R";$C$2:$C$196))*($D$2:$D$196=СЕГОДНЯ()-1))

Автор - Pelena
Дата добавления - 13.01.2019 в 15:57
fran4esko Дата: Воскресенье, 13.01.2019, 16:22 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
для суммы

=СУММПРОИЗВ($E$2:$E$196*(ЛЕВСИМВ($B$2:$B$196;3)="140")*ЕЧИСЛО(ПОИСК("F";$C$2:$C$196))*ЕОШИБКА(ПОИСК("R";$C$2:$C$196))*($D$2:$D$196=СЕГОДНЯ()-1))

"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816



в сумме выдает 2, а сумма должна быть гораздо больше
 
Ответить
Сообщение
для суммы

=СУММПРОИЗВ($E$2:$E$196*(ЛЕВСИМВ($B$2:$B$196;3)="140")*ЕЧИСЛО(ПОИСК("F";$C$2:$C$196))*ЕОШИБКА(ПОИСК("R";$C$2:$C$196))*($D$2:$D$196=СЕГОДНЯ()-1))

"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816



в сумме выдает 2, а сумма должна быть гораздо больше

Автор - fran4esko
Дата добавления - 13.01.2019 в 16:22
fran4esko Дата: Воскресенье, 13.01.2019, 16:23 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, к сожалению в столбце есть и S и значения F1R1 например а надо только при F и все
 
Ответить
Сообщениеvikttur, к сожалению в столбце есть и S и значения F1R1 например а надо только при F и все

Автор - fran4esko
Дата добавления - 13.01.2019 в 16:23
Pelena Дата: Воскресенье, 13.01.2019, 16:28 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14342
Репутация: 3134 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
сумма должна быть гораздо больше

вчерашняя дата у Вас только одна. Откуда бОльшая сумма?

И не надо цитировать пост целиком. Это нарушение Правил форума. Исправьте


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
сумма должна быть гораздо больше

вчерашняя дата у Вас только одна. Откуда бОльшая сумма?

И не надо цитировать пост целиком. Это нарушение Правил форума. Исправьте

Автор - Pelena
Дата добавления - 13.01.2019 в 16:28
vikttur Дата: Воскресенье, 13.01.2019, 23:47 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

есть и S и значения F1R1

Об S Вы раньше ничего не писали...
Покажите пример, в котором будут отражены все возможные варианты и пример результата
 
Ответить
Сообщение
есть и S и значения F1R1

Об S Вы раньше ничего не писали...
Покажите пример, в котором будут отражены все возможные варианты и пример результата

Автор - vikttur
Дата добавления - 13.01.2019 в 23:47
bmv98rus Дата: Понедельник, 14.01.2019, 00:19 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Код
=SUMIFS(E:E;B:B;">14000";C:C;"*F*";C:C;"<>*R*";D:D;TODAY()-1)
К сообщению приложен файл: Copy_of_564.xlsx(16.8 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Код
=SUMIFS(E:E;B:B;">14000";C:C;"*F*";C:C;"<>*R*";D:D;TODAY()-1)

Автор - bmv98rus
Дата добавления - 14.01.2019 в 00:19
fran4esko Дата: Понедельник, 14.01.2019, 03:21 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Pelena, Спасибо большое вы очень помогли) все работает
 
Ответить
СообщениеPelena, Спасибо большое вы очень помогли) все работает

Автор - fran4esko
Дата добавления - 14.01.2019 в 03:21
fran4esko Дата: Понедельник, 14.01.2019, 03:21 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, посмотрите пожалуйста в изначально приложенном файле в столбце есть все наименования значений
 
Ответить
Сообщениеvikttur, посмотрите пожалуйста в изначально приложенном файле в столбце есть все наименования значений

Автор - fran4esko
Дата добавления - 14.01.2019 в 03:21
fran4esko Дата: Понедельник, 14.01.2019, 03:22 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, формат "*R*" не срабатывает, ищет не корректно)
 
Ответить
Сообщениеbmv98rus, формат "*R*" не срабатывает, ищет не корректно)

Автор - fran4esko
Дата добавления - 14.01.2019 в 03:22
bmv98rus Дата: Понедельник, 14.01.2019, 11:48 | Сообщение № 12
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
формат "*R*" не срабатывает,

скорее 140 обрабатывает не корректно
Код
=SUMIFS(E:E;B:B;">=14000";B:B;"<14100";C:C;"*F*";C:C;"<>*R*";D:D;TODAY()-1)
К сообщению приложен файл: 9211551.xlsx(95.2 Kb)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
формат "*R*" не срабатывает,

скорее 140 обрабатывает не корректно
Код
=SUMIFS(E:E;B:B;">=14000";B:B;"<14100";C:C;"*F*";C:C;"<>*R*";D:D;TODAY()-1)

Автор - bmv98rus
Дата добавления - 14.01.2019 в 11:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » расчет суммы по столбцу, с нахождением символов других стлб (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!