Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подтягивание значений из столбца подряд игнорирую нули - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание значений из столбца подряд игнорирую нули (Формулы/Formulas)
Подтягивание значений из столбца подряд игнорирую нули
alex7393 Дата: Вторник, 15.01.2019, 12:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Необходимо в первый столбец подряд подтянуть значения из второго столбца минуя нули, то есть значения, которые равны нулю. Нужно учитывать, что значения втором столбце будут изменяться. Думаю на рисунке всё будет понятно. Скажите пожалуйста как это можно сделать?
Заранее спасибо за помощь!
К сообщению приложен файл: 2110727.xlsx(12.0 Kb)


Сообщение отредактировал alex7393 - Вторник, 15.01.2019, 13:27
 
Ответить
СообщениеДобрый день!
Необходимо в первый столбец подряд подтянуть значения из второго столбца минуя нули, то есть значения, которые равны нулю. Нужно учитывать, что значения втором столбце будут изменяться. Думаю на рисунке всё будет понятно. Скажите пожалуйста как это можно сделать?
Заранее спасибо за помощь!

Автор - alex7393
Дата добавления - 15.01.2019 в 12:46
vikttur Дата: Вторник, 15.01.2019, 12:58 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Это можно сделать фломастером на Вашей картинке.
Или написать формулу в приложенном файле Excel
 
Ответить
СообщениеЭто можно сделать фломастером на Вашей картинке.
Или написать формулу в приложенном файле Excel

Автор - vikttur
Дата добавления - 15.01.2019 в 12:58
alex7393 Дата: Вторник, 15.01.2019, 13:05 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, Если бы можно было фломастером, то я бы сюда не постил даже :) . Какую формулу можно подставить, чтобы значения переходили в первый столбец, учитывая что количество значений во втором столбце всегда будет меняться? ? Всё перебрал уже, но решение так и не нашел %)
 
Ответить
Сообщениеvikttur, Если бы можно было фломастером, то я бы сюда не постил даже :) . Какую формулу можно подставить, чтобы значения переходили в первый столбец, учитывая что количество значений во втором столбце всегда будет меняться? ? Всё перебрал уже, но решение так и не нашел %)

Автор - alex7393
Дата добавления - 15.01.2019 в 13:05
vikttur Дата: Вторник, 15.01.2019, 13:07 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Вы прочитали половину моего сообщения.
 
Ответить
СообщениеВы прочитали половину моего сообщения.

Автор - vikttur
Дата добавления - 15.01.2019 в 13:07
alex7393 Дата: Вторник, 15.01.2019, 13:09 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, Прошу прощения за мою невнимательность. Не вижу приложенного файла просто.
 
Ответить
Сообщениеvikttur, Прошу прощения за мою невнимательность. Не вижу приложенного файла просто.

Автор - alex7393
Дата добавления - 15.01.2019 в 13:09
vikttur Дата: Вторник, 15.01.2019, 13:11 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

И я не вижу :)

Как хотите... Вставляйте в файл сами.
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$3:$C$100;НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$100;СТРОКА($C$3:$C$100)-2);СТРОКА(A1)));)

Если порядок чисел не важен, можно по возрастанию:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$100;$C$3:$C$100);СТРОКА(A1));)

Обе формулы массива, вводятся тремя клавишами


Сообщение отредактировал vikttur - Вторник, 15.01.2019, 13:23
 
Ответить
СообщениеИ я не вижу :)

Как хотите... Вставляйте в файл сами.
Код
=ЕСЛИОШИБКА(ИНДЕКС($C$3:$C$100;НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$100;СТРОКА($C$3:$C$100)-2);СТРОКА(A1)));)

Если порядок чисел не важен, можно по возрастанию:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$100;$C$3:$C$100);СТРОКА(A1));)

Обе формулы массива, вводятся тремя клавишами

Автор - vikttur
Дата добавления - 15.01.2019 в 13:11
alex7393 Дата: Вторник, 15.01.2019, 13:28 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, Файл приложил) И вставил, не работает почему-то. Везде нули выскакивают.


Сообщение отредактировал alex7393 - Вторник, 15.01.2019, 13:31
 
Ответить
Сообщениеvikttur, Файл приложил) И вставил, не работает почему-то. Везде нули выскакивают.

Автор - alex7393
Дата добавления - 15.01.2019 в 13:28
vikttur Дата: Вторник, 15.01.2019, 13:35 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Обе формулы массива
Об этом на форуме и в сети много информации.
На картинке - с данными столбец С, в файле - столбец В. Формула написана по картинке


Сообщение отредактировал vikttur - Вторник, 15.01.2019, 13:49
 
Ответить
Сообщение
Обе формулы массива
Об этом на форуме и в сети много информации.
На картинке - с данными столбец С, в файле - столбец В. Формула написана по картинке

Автор - vikttur
Дата добавления - 15.01.2019 в 13:35
alex7393 Дата: Вторник, 15.01.2019, 13:51 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, Не сочтите за наглость, но что я не так делаю? Вставляю как массив через три клавиши и ничего.Можете глянуть файл? Привёл его к тому виду, что был на картинке-бесполезно.
К сообщению приложен файл: 0415824.xlsx(12.5 Kb)


Сообщение отредактировал alex7393 - Вторник, 15.01.2019, 13:51
 
Ответить
Сообщениеvikttur, Не сочтите за наглость, но что я не так делаю? Вставляю как массив через три клавиши и ничего.Можете глянуть файл? Привёл его к тому виду, что был на картинке-бесполезно.

Автор - alex7393
Дата добавления - 15.01.2019 в 13:51
amfor Дата: Вторник, 15.01.2019, 14:07 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 176
Репутация: 50 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте. У Вас в таблице нули отформатированы как текст,поэтому формула и не считает.


Семь бед - один RESET.
 
Ответить
СообщениеЗдравствуйте. У Вас в таблице нули отформатированы как текст,поэтому формула и не считает.

Автор - amfor
Дата добавления - 15.01.2019 в 14:07
vikttur Дата: Вторник, 15.01.2019, 14:07 | Сообщение № 11
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Нули записаны как текст. Текст вызывает ошибку . ЕСЛИОШИБКА ее устраняет и показывает ноль.
Преобразуйте текстовые нули в числовые.
Можно обойти - добавить двойное отрицание:
Код
...ЕСЛИ(--$C$3:$C$100...


Сообщение отредактировал vikttur - Вторник, 15.01.2019, 14:13
 
Ответить
СообщениеНули записаны как текст. Текст вызывает ошибку . ЕСЛИОШИБКА ее устраняет и показывает ноль.
Преобразуйте текстовые нули в числовые.
Можно обойти - добавить двойное отрицание:
Код
...ЕСЛИ(--$C$3:$C$100...

Автор - vikttur
Дата добавления - 15.01.2019 в 14:07
alex7393 Дата: Вторник, 15.01.2019, 15:01 | Сообщение № 12
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всё заработало! Спасибо большое за помощь, тему можно закрывать.
 
Ответить
СообщениеВсё заработало! Спасибо большое за помощь, тему можно закрывать.

Автор - alex7393
Дата добавления - 15.01.2019 в 15:01
_Boroda_ Дата: Вторник, 15.01.2019, 15:09 | Сообщение № 13
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14885
Репутация: 5882 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если у Вас нули только сначала, то можно так
Код
=ИНДЕКС(C$4:C$999;СЧЁТЗ(C$4:C$999)-СЧЁТ(C$4:C$999)+СТРОКА(C1))

Формат еще можно поставить
0;-0;
К сообщению приложен файл: 0415824_1.xlsx(12.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли у Вас нули только сначала, то можно так
Код
=ИНДЕКС(C$4:C$999;СЧЁТЗ(C$4:C$999)-СЧЁТ(C$4:C$999)+СТРОКА(C1))

Формат еще можно поставить
0;-0;

Автор - _Boroda_
Дата добавления - 15.01.2019 в 15:09
vikttur Дата: Вторник, 15.01.2019, 15:14 | Сообщение № 14
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Я об этом не подумал... Чуть короче:
Код
=ИНДЕКС(C$3:C$999;СЧЁТЕСЛИ(C$3:C$999;)+СТРОКА(C1))
 
Ответить
СообщениеЯ об этом не подумал... Чуть короче:
Код
=ИНДЕКС(C$3:C$999;СЧЁТЕСЛИ(C$3:C$999;)+СТРОКА(C1))

Автор - vikttur
Дата добавления - 15.01.2019 в 15:14
jakim Дата: Вторник, 15.01.2019, 19:17 | Сообщение № 15
Группа: Друзья
Ранг: Ветеран
Сообщений: 890
Репутация: 232 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IFERROR(INDEX(B$1:B$200;AGGREGATE(15;6;ROW($1:$200)/(B$1:B$200<>0);ROWS($1:1)));"")
 
Ответить
Сообщение
Формула

Код
=IFERROR(INDEX(B$1:B$200;AGGREGATE(15;6;ROW($1:$200)/(B$1:B$200<>0);ROWS($1:1)));"")

Автор - jakim
Дата добавления - 15.01.2019 в 19:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подтягивание значений из столбца подряд игнорирую нули (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!