Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/При протягивании формулы массива выдает ошибку - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При протягивании формулы массива выдает ошибку (Формулы/Formulas)
При протягивании формулы массива выдает ошибку
EvA80 Дата: Вторник, 15.01.2019, 17:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Коллеги добрый день, подскажите, если сможете, что-то никак не могу увидеть, где косяк. При протягивании формулы массива (столбец T в примере) выдает ошибку ЧИСЛО.
Пробовала забить эту же формулу ( которая работает на 1 сточку выше) вручную, все равно выдает здесь ошибку.
К сообщению приложен файл: 3300363.xls(65.5 Kb)
 
Ответить
СообщениеКоллеги добрый день, подскажите, если сможете, что-то никак не могу увидеть, где косяк. При протягивании формулы массива (столбец T в примере) выдает ошибку ЧИСЛО.
Пробовала забить эту же формулу ( которая работает на 1 сточку выше) вручную, все равно выдает здесь ошибку.

Автор - EvA80
Дата добавления - 15.01.2019 в 17:50
_Boroda_ Дата: Вторник, 15.01.2019, 17:55 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не при каждом условии есть три наименьших (IFS считает все формулы, а потом выбирает)
попробуйте в каждом условии написать проверку на ошибку
Код
=СУММ(ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$31=$I3;$E$3:$E$31);{1;2;3});))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе при каждом условии есть три наименьших (IFS считает все формулы, а потом выбирает)
попробуйте в каждом условии написать проверку на ошибку
Код
=СУММ(ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$31=$I3;$E$3:$E$31);{1;2;3});))

Автор - _Boroda_
Дата добавления - 15.01.2019 в 17:55
EvA80 Дата: Вторник, 15.01.2019, 18:02 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Да, вы правы. Дело действительно в этом. Не додумалась поискать в этой стороне. Спасибо большое!
 
Ответить
СообщениеДа, вы правы. Дело действительно в этом. Не додумалась поискать в этой стороне. Спасибо большое!

Автор - EvA80
Дата добавления - 15.01.2019 в 18:02
_Boroda_ Дата: Вторник, 15.01.2019, 18:04 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
А вообще всю формулу можно вот так написать
Код
=СУММ(ЕСЛИОШИБКА((НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$31=$I3;$E$3:$E$31);ВЫБОР(3-(J$2<8)-(J$2<13);{1};{1;2};{1;2;3})));))

Код
=СУММ(ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$31=$I3;$E$3:$E$31);СТРОКА(L$1:ИНДЕКС(L:L;3-(J$2<8)-(J$2<13))));))


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеА вообще всю формулу можно вот так написать
Код
=СУММ(ЕСЛИОШИБКА((НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$31=$I3;$E$3:$E$31);ВЫБОР(3-(J$2<8)-(J$2<13);{1};{1;2};{1;2;3})));))

Код
=СУММ(ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ($C$3:$C$31=$I3;$E$3:$E$31);СТРОКА(L$1:ИНДЕКС(L:L;3-(J$2<8)-(J$2<13))));))

Автор - _Boroda_
Дата добавления - 15.01.2019 в 18:04
EvA80 Дата: Вторник, 15.01.2019, 18:11 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Красивое решение. Условие минус 3 наименьших, если игр меньше 16 достигается за счет (3-...) в формуле? не могу понять этот аргумент
 
Ответить
СообщениеКрасивое решение. Условие минус 3 наименьших, если игр меньше 16 достигается за счет (3-...) в формуле? не могу понять этот аргумент

Автор - EvA80
Дата добавления - 15.01.2019 в 18:11
_Boroda_ Дата: Вторник, 15.01.2019, 19:29 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, вы все правильно поняли
кусок J$2<8 дает или ИСТИНА, или ЛОЖЬ, арифметические действия с которыми автоматически преобразуют их в 1 или 0 соответственно. Аналогично с куском J$2<13
Если J2 меньше 13, но больше 8, то получаем 3-0-1=2
Если J2 меньше 8, то оно автоматически и меньше 13 и тогда получаем 3-1-1=1
Если же J2 больше 13, то получаем 3-0-0=3


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, вы все правильно поняли
кусок J$2<8 дает или ИСТИНА, или ЛОЖЬ, арифметические действия с которыми автоматически преобразуют их в 1 или 0 соответственно. Аналогично с куском J$2<13
Если J2 меньше 13, но больше 8, то получаем 3-0-1=2
Если J2 меньше 8, то оно автоматически и меньше 13 и тогда получаем 3-1-1=1
Если же J2 больше 13, то получаем 3-0-0=3

Автор - _Boroda_
Дата добавления - 15.01.2019 в 19:29
jakim Дата: Вторник, 15.01.2019, 20:35 | Сообщение № 7
Группа: Друзья
Ранг: Ветеран
Сообщений: 901
Репутация: 233 ±
Замечаний: 0% ±

Excel 2010
Ещё одна формула без массивного ввода

Код
SUMPRODUCT(IFERROR(AGGREGATE(15;6;E$3:E$31/($C$3:$C$31=I3);{1;2;3});""))
 
Ответить
Сообщение
Ещё одна формула без массивного ввода

Код
SUMPRODUCT(IFERROR(AGGREGATE(15;6;E$3:E$31/($C$3:$C$31=I3);{1;2;3});""))

Автор - jakim
Дата добавления - 15.01.2019 в 20:35
EvA80 Дата: Среда, 16.01.2019, 19:38 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Спасибо. Логику построения формулы поняла.
 
Ответить
Сообщение_Boroda_, Спасибо. Логику построения формулы поняла.

Автор - EvA80
Дата добавления - 16.01.2019 в 19:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При протягивании формулы массива выдает ошибку (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!