Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование данных таблицы с несколькими условиями - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных таблицы с несколькими условиями (Формулы/Formulas)
Суммирование данных таблицы с несколькими условиями
AVI Дата: Среда, 16.01.2019, 11:10 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 470
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
Добрый день!
Подскажите, пожалуйста, как суммировать данные верхней таблицы и отобразить их в нижней таблице
Пример результата указан в первых двух столбцах нижней таблицы.
Помучился я с индексами и ничего так и не сделал. Видимо, это не индексами надо делать.
К сообщению приложен файл: _Microsoft_Exce.xlsx(10.5 Kb)
 
Ответить
СообщениеДобрый день!
Подскажите, пожалуйста, как суммировать данные верхней таблицы и отобразить их в нижней таблице
Пример результата указан в первых двух столбцах нижней таблицы.
Помучился я с индексами и ничего так и не сделал. Видимо, это не индексами надо делать.

Автор - AVI
Дата добавления - 16.01.2019 в 11:10
Nic70y Дата: Среда, 16.01.2019, 11:13 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5112
Репутация: 1099 ±
Замечаний: 0% ±

Excel 2013
Код
=СУММПРОИЗВ(($C$3:$L$3=C$19)*($B$4:$B$8=$B20);$C$4:$L$8)


ЯД(poison) 41001841029809
+7 978 049 98 74 (мтс)
 
Ответить
Сообщение
Код
=СУММПРОИЗВ(($C$3:$L$3=C$19)*($B$4:$B$8=$B20);$C$4:$L$8)

Автор - Nic70y
Дата добавления - 16.01.2019 в 11:13
_Boroda_ Дата: Среда, 16.01.2019, 11:20 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14089
Репутация: 5686 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Индекс обычно используется там, где нужно одно значение, а у нас их несколько по столбцам
Еще вариант
Код
=СУММЕСЛИ($C$3:$L$3;C$19;ИНДЕКС($C$4:$L$8;ПОИСКПОЗ($B20;$B$4:$B$8;);))

Но СУММПРОИЗВ конечно проще (про скорость не уверен, особенно если массив большой)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеИндекс обычно используется там, где нужно одно значение, а у нас их несколько по столбцам
Еще вариант
Код
=СУММЕСЛИ($C$3:$L$3;C$19;ИНДЕКС($C$4:$L$8;ПОИСКПОЗ($B20;$B$4:$B$8;);))

Но СУММПРОИЗВ конечно проще (про скорость не уверен, особенно если массив большой)

Автор - _Boroda_
Дата добавления - 16.01.2019 в 11:20
AVI Дата: Среда, 16.01.2019, 11:24 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 470
Репутация: 7 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Во, я так же делал, но не получилось.
Видимо, не так же))

Спасибо!
Nic70y, Спасибо!
 
Ответить
Сообщение_Boroda_, Во, я так же делал, но не получилось.
Видимо, не так же))

Спасибо!
Nic70y, Спасибо!

Автор - AVI
Дата добавления - 16.01.2019 в 11:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование данных таблицы с несколькими условиями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!