Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос и сортировка данных по нескольким критериям - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос и сортировка данных по нескольким критериям (Формулы/Formulas)
Перенос и сортировка данных по нескольким критериям
denis-tab Дата: Пятница, 25.01.2019, 10:49 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите пожалуйста структурировать исходные данные в таблицу. Есть 4 условия в столбцах исходных данных, необходимо в определенную ячейку поместить число из крайнего правого сотлбца, которое по строке совпадает с четырьмя условиями.

Код
=ИНДЕКС(Лист1!B2:H2000;ПОИСКПОЗ(M3;Лист1!B2:B2000;0);ПОИСКПОЗ(M1;Лист1!E2:E2000;0);ПОИСКПОЗ(M2;Лист1!F2:F2000;0);ПОИСКПОЗ(b4;Лист1!b2:b2000;0))
-> до чего я додумался, но это не работает( нужно что то подобное. Думаю ВПР поможет, но я не справляюсь((

Во вложении: Лист1 - исходные данные (необходимые критерии выделены цветом, в столбце Н - искомое число); Лист2 - Таблица, в которую необходимо поместить искомые числа в структурированном порядке
К сообщению приложен файл: 4798250.xlsx(66.7 Kb)
 
Ответить
СообщениеПомогите пожалуйста структурировать исходные данные в таблицу. Есть 4 условия в столбцах исходных данных, необходимо в определенную ячейку поместить число из крайнего правого сотлбца, которое по строке совпадает с четырьмя условиями.

Код
=ИНДЕКС(Лист1!B2:H2000;ПОИСКПОЗ(M3;Лист1!B2:B2000;0);ПОИСКПОЗ(M1;Лист1!E2:E2000;0);ПОИСКПОЗ(M2;Лист1!F2:F2000;0);ПОИСКПОЗ(b4;Лист1!b2:b2000;0))
-> до чего я додумался, но это не работает( нужно что то подобное. Думаю ВПР поможет, но я не справляюсь((

Во вложении: Лист1 - исходные данные (необходимые критерии выделены цветом, в столбце Н - искомое число); Лист2 - Таблица, в которую необходимо поместить искомые числа в структурированном порядке

Автор - denis-tab
Дата добавления - 25.01.2019 в 10:49
_Boroda_ Дата: Пятница, 25.01.2019, 11:19 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММЕСЛИМН(Лист1!$H$2:$H$2000;Лист1!$B$2:$B$2000;$B5;Лист1!$E$2:$E$2000;РИМСКОЕ(ЛЕВБ(ПРОСМОТР("я";$D$1:M$1);2))&" *";Лист1!$F$2:$F$2000;L$2&M$2;Лист1!$G$2:$G$2000;M$3&"*")
К сообщению приложен файл: 4798250_1.xlsx(62.8 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММЕСЛИМН(Лист1!$H$2:$H$2000;Лист1!$B$2:$B$2000;$B5;Лист1!$E$2:$E$2000;РИМСКОЕ(ЛЕВБ(ПРОСМОТР("я";$D$1:M$1);2))&" *";Лист1!$F$2:$F$2000;L$2&M$2;Лист1!$G$2:$G$2000;M$3&"*")

Автор - _Boroda_
Дата добавления - 25.01.2019 в 11:19
denis-tab Дата: Пятница, 25.01.2019, 11:33 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, :o
Спасибо от души!!!!)
Я пока не понял как это работает, но это работает! Спасибо!!!
hands hands hands
(я в шоке)
 
Ответить
Сообщение_Boroda_, :o
Спасибо от души!!!!)
Я пока не понял как это работает, но это работает! Спасибо!!!
hands hands hands
(я в шоке)

Автор - denis-tab
Дата добавления - 25.01.2019 в 11:33
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос и сортировка данных по нескольким критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!