Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Нахождение N максимумов в массиве, в т.ч. повторяющихся - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение N максимумов в массиве, в т.ч. повторяющихся (Формулы/Formulas)
Нахождение N максимумов в массиве, в т.ч. повторяющихся
Pelena Дата: Вторник, 05.02.2019, 22:43 | Сообщение № 21
Группа: Админы
Ранг: Местный житель
Сообщений: 14125
Репутация: 3087 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=ИНДЕКС($A$1:$C$1;ПОИСКПОЗ(НАИБОЛЬШИЙ($A2:$C2;СТОЛБЕЦ(A:A));$A2:$C2;0))
К сообщению приложен файл: 9701584.xlsx(11.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ИНДЕКС($A$1:$C$1;ПОИСКПОЗ(НАИБОЛЬШИЙ($A2:$C2;СТОЛБЕЦ(A:A));$A2:$C2;0))

Автор - Pelena
Дата добавления - 05.02.2019 в 22:43
daledale Дата: Вторник, 05.02.2019, 23:34 | Сообщение № 22
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena
Большое вам спасибо, но я тут опять прокололся)). Всё работает в изначальной постановке задачи! Но, в общем таки есть повторяющиеся. Сильно затруднительно изменить формулу?
 
Ответить
СообщениеPelena
Большое вам спасибо, но я тут опять прокололся)). Всё работает в изначальной постановке задачи! Но, в общем таки есть повторяющиеся. Сильно затруднительно изменить формулу?

Автор - daledale
Дата добавления - 05.02.2019 в 23:34
daledale Дата: Вторник, 05.02.2019, 23:45 | Сообщение № 23
Группа: Пользователи
Ранг: Новичок
Сообщений: 34
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Всё, прошу прощения. Вопрос закрыт. Использовал для предварительной сортировки одну из предыдущих ваших формул. Огромное Вам спасибо!
 
Ответить
СообщениеВсё, прошу прощения. Вопрос закрыт. Использовал для предварительной сортировки одну из предыдущих ваших формул. Огромное Вам спасибо!

Автор - daledale
Дата добавления - 05.02.2019 в 23:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Нахождение N максимумов в массиве, в т.ч. повторяющихся (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!