Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/сумма наибольших с изменением количества результатов - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма наибольших с изменением количества результатов (Формулы/Formulas)
сумма наибольших с изменением количества результатов
blax8 Дата: Понедельник, 28.01.2019, 08:16 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Помогите пожалуйста. Нужно найти сумму наибольших чисел из столбце сумма, но количество чисел может меняться от числа в L4
К сообщению приложен файл: __.xlsx(12.2 Kb)
 
Ответить
СообщениеДобрый день. Помогите пожалуйста. Нужно найти сумму наибольших чисел из столбце сумма, но количество чисел может меняться от числа в L4

Автор - blax8
Дата добавления - 28.01.2019 в 08:16
китин Дата: Понедельник, 28.01.2019, 08:26 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5682
Репутация: 897 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
а вдруг правильно: формула массива
Код
=СУММ(ЕСЛИ($C3:$J3>=НАИБОЛЬШИЙ($C3:$J3;$L$2);$C3:$J3))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеа вдруг правильно: формула массива
Код
=СУММ(ЕСЛИ($C3:$J3>=НАИБОЛЬШИЙ($C3:$J3;$L$2);$C3:$J3))

Автор - китин
Дата добавления - 28.01.2019 в 08:26
blax8 Дата: Понедельник, 28.01.2019, 09:04 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Извините , наверное не правильно написал условие. Мне нужно из колонки K3-K8 сумму наибольших чисел, а количество чисел задается числом L4. Во тором варианте когда чисел меньше чем нужно суммировать
 
Ответить
Сообщениекитин, Извините , наверное не правильно написал условие. Мне нужно из колонки K3-K8 сумму наибольших чисел, а количество чисел задается числом L4. Во тором варианте когда чисел меньше чем нужно суммировать

Автор - blax8
Дата добавления - 28.01.2019 в 09:04
blax8 Дата: Понедельник, 28.01.2019, 09:05 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
blax8, извините L2
 
Ответить
Сообщениеblax8, извините L2

Автор - blax8
Дата добавления - 28.01.2019 в 09:05
китин Дата: Понедельник, 28.01.2019, 09:11 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 5682
Репутация: 897 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну дык аналогично
Код
=СУММ(ЕСЛИ($K$3:$K$8>=НАИБОЛЬШИЙ($K$3:$K$8;$L$2);$K$3:$K$8))

формула массива
К сообщению приложен файл: blax8.xlsx(11.9 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену дык аналогично
Код
=СУММ(ЕСЛИ($K$3:$K$8>=НАИБОЛЬШИЙ($K$3:$K$8;$L$2);$K$3:$K$8))

формула массива

Автор - китин
Дата добавления - 28.01.2019 в 09:11
blax8 Дата: Понедельник, 28.01.2019, 09:41 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
китин, Большое спасибо.
 
Ответить
Сообщениекитин, Большое спасибо.

Автор - blax8
Дата добавления - 28.01.2019 в 09:41
blax8 Дата: Понедельник, 28.01.2019, 09:45 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
blax8, Если сумма повторяется, то считает их все, а надо только заданное число. Если нужна сумма 3 а третий результат у 2-3 человек, то он считает их все, а надо только заданное количество.
 
Ответить
Сообщениеblax8, Если сумма повторяется, то считает их все, а надо только заданное число. Если нужна сумма 3 а третий результат у 2-3 человек, то он считает их все, а надо только заданное количество.

Автор - blax8
Дата добавления - 28.01.2019 в 09:45
sboy Дата: Понедельник, 28.01.2019, 10:19 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2566
Репутация: 722 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Код
=СУММ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(ДВССЫЛ("a1:a"&L2))))
К сообщению приложен файл: 8150241.xlsx(12.0 Kb)


Яндекс: 410016850021169
 
Ответить
СообщениеДобрый день.
Код
=СУММ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(ДВССЫЛ("a1:a"&L2))))

Автор - sboy
Дата добавления - 28.01.2019 в 10:19
Светлый Дата: Понедельник, 28.01.2019, 10:25 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 1152
Репутация: 292 ±
Замечаний: 0% ±

Excel 2010
Добрый день!
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(C3:J3;СТРОКА(ДВССЫЛ("1:"&L$2))))
*Или с учётом ошибок массивная:
Код
=СУММ(ЕСЛИОШИБКА(НАИБОЛЬШИЙ(C3:J3;СТРОКА(ДВССЫЛ("1:"&L$2)));))
**Что-то я тормознул:
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(ДВССЫЛ("1:"&L2))))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 28.01.2019, 10:47
 
Ответить
СообщениеДобрый день!
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(C3:J3;СТРОКА(ДВССЫЛ("1:"&L$2))))
*Или с учётом ошибок массивная:
Код
=СУММ(ЕСЛИОШИБКА(НАИБОЛЬШИЙ(C3:J3;СТРОКА(ДВССЫЛ("1:"&L$2)));))
**Что-то я тормознул:
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(ДВССЫЛ("1:"&L2))))

Автор - Светлый
Дата добавления - 28.01.2019 в 10:25
vikttur Дата: Понедельник, 28.01.2019, 10:25 | Сообщение № 10
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

То же, без летучести:
Код
=СУММ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(A1:ИНДЕКС(A:A;L2))))

Формула массива

Светлый напомнил - без массивности:
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(A1:ИНДЕКС(A:A;L2))))


Сообщение отредактировал vikttur - Понедельник, 28.01.2019, 10:27
 
Ответить
СообщениеТо же, без летучести:
Код
=СУММ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(A1:ИНДЕКС(A:A;L2))))

Формула массива

Светлый напомнил - без массивности:
Код
=СУММПРОИЗВ(НАИБОЛЬШИЙ(K3:K8;СТРОКА(A1:ИНДЕКС(A:A;L2))))

Автор - vikttur
Дата добавления - 28.01.2019 в 10:25
blax8 Дата: Понедельник, 28.01.2019, 12:07 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 32
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
vikttur, sboy? Светлый, СПАСИБО большое. на ваших формулах решу задачу дальше сам.
 
Ответить
Сообщениеvikttur, sboy? Светлый, СПАСИБО большое. на ваших формулах решу задачу дальше сам.

Автор - blax8
Дата добавления - 28.01.2019 в 12:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » сумма наибольших с изменением количества результатов (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!