Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск строки с выполнением и поиском 2ух условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строки с выполнением и поиском 2ух условий
Поиск строки с выполнением и поиском 2ух условий
Mahp_dn Дата: Вторник, 29.01.2019, 08:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

10
Добрый день!
Прошу помощь в решении одной проблемы в решении задачи:
Есть данные в 2 столбцах. И задано 2 числа. Нужно найти строку, где выполняется условие - приблеженное значение для 1го числа из столбцах #1, а для 2го из 2го столбцах, тоже приблеженное.
Сам пытался не получается. Помогите, очень надо. Спасибо большое!


Очень позитивный человек
 
Ответить
СообщениеДобрый день!
Прошу помощь в решении одной проблемы в решении задачи:
Есть данные в 2 столбцах. И задано 2 числа. Нужно найти строку, где выполняется условие - приблеженное значение для 1го числа из столбцах #1, а для 2го из 2го столбцах, тоже приблеженное.
Сам пытался не получается. Помогите, очень надо. Спасибо большое!

Автор - Mahp_dn
Дата добавления - 29.01.2019 в 08:03
китин Дата: Вторник, 29.01.2019, 09:58 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5451
Репутация: 872 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Mahp_dn, с вашим файлом примером помощь может придти быстрее


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеMahp_dn, с вашим файлом примером помощь может придти быстрее

Автор - китин
Дата добавления - 29.01.2019 в 09:58
Mahp_dn Дата: Вторник, 29.01.2019, 13:06 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

10
Файл вложил.
К сообщению приложен файл: 0237013.xlsx(9.9 Kb)


Очень позитивный человек
 
Ответить
СообщениеФайл вложил.

Автор - Mahp_dn
Дата добавления - 29.01.2019 в 13:06
Mahp_dn Дата: Вторник, 29.01.2019, 13:13 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

10
Нужно чтобы в выводе показалась строка с максимально приблеженными значениями по столбцу А и столбцу Б


Очень позитивный человек
 
Ответить
СообщениеНужно чтобы в выводе показалась строка с максимально приблеженными значениями по столбцу А и столбцу Б

Автор - Mahp_dn
Дата добавления - 29.01.2019 в 13:13
sboy Дата: Вторник, 29.01.2019, 13:55 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 2448
Репутация: 689 ±
Замечаний: 0% ±

Excel 2010
максимально приблеженными значениями

очень условная формулировка. Сделал по наименьшей сумме отклонений параметров. Формула массива
Код
=ИНДЕКС(A3:A22;ПОИСКПОЗ(МИН(ABS($E$3-$B$3:$B$22)+ABS($F$3-$C$3:$C$22));ABS($E$3-$B$3:$B$22)+ABS($F$3-$C$3:$C$22);))
К сообщению приложен файл: 5021163.xlsx(9.6 Kb)


Яндекс: 410016850021169
 
Ответить
Сообщение
максимально приблеженными значениями

очень условная формулировка. Сделал по наименьшей сумме отклонений параметров. Формула массива
Код
=ИНДЕКС(A3:A22;ПОИСКПОЗ(МИН(ABS($E$3-$B$3:$B$22)+ABS($F$3-$C$3:$C$22));ABS($E$3-$B$3:$B$22)+ABS($F$3-$C$3:$C$22);))

Автор - sboy
Дата добавления - 29.01.2019 в 13:55
Mahp_dn Дата: Вторник, 29.01.2019, 16:27 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

10
ооо! Очень благодарен! Спасибо большое! Сейчас его попробую погонять и по экспериментировать. Спасибо, очень помогли.


Очень позитивный человек
 
Ответить
Сообщениеооо! Очень благодарен! Спасибо большое! Сейчас его попробую погонять и по экспериментировать. Спасибо, очень помогли.

Автор - Mahp_dn
Дата добавления - 29.01.2019 в 16:27
Светлый Дата: Вторник, 29.01.2019, 17:51 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 1009
Репутация: 259 ±
Замечаний: 0% ±

Excel 2010
И мой вариант. Массивная:
Код
=--ПРАВБ(МИН(МУМНОЖ((E3:F3-B3:C22)^2;A3:A4^0)*100+A3:A22);2)
*Минимизация среднеквадратичного отклонения даёт немного другой результат.
**По абсолютной разнице значений:
Код
=--ПРАВБ(МИН(МУМНОЖ(ABS(E3:F3-B3:C22);A3:A4^0)*100+A3:A22);2)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 29.01.2019, 18:14
 
Ответить
СообщениеИ мой вариант. Массивная:
Код
=--ПРАВБ(МИН(МУМНОЖ((E3:F3-B3:C22)^2;A3:A4^0)*100+A3:A22);2)
*Минимизация среднеквадратичного отклонения даёт немного другой результат.
**По абсолютной разнице значений:
Код
=--ПРАВБ(МИН(МУМНОЖ(ABS(E3:F3-B3:C22);A3:A4^0)*100+A3:A22);2)

Автор - Светлый
Дата добавления - 29.01.2019 в 17:51
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск строки с выполнением и поиском 2ух условий
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!