Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вложение дат в формулу - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вложение дат в формулу (Формулы/Formulas)
Вложение дат в формулу
slava230160 Дата: Вторник, 29.01.2019, 20:02 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер. Подскажите, как в функцию ЕСЛИ вложить период между датами. Например, если дата в ячейке (А) входит в этот период, то значение, если истина -1, значение, если ложь 0. И чтобы находились значения не зависимо от года. И чтобы можно было изменять диапазон дат и их количество.
02.01.19 14.02.19 1
14.02.19 10.03.19 -1
05.08.19 03.09.19 1
06.09.19 01.10.19 -1
04.10.19 15.10.19 1
03.12.19 17.12.19 -1


Сообщение отредактировал slava230160 - Вторник, 29.01.2019, 20:03
 
Ответить
СообщениеДобрый вечер. Подскажите, как в функцию ЕСЛИ вложить период между датами. Например, если дата в ячейке (А) входит в этот период, то значение, если истина -1, значение, если ложь 0. И чтобы находились значения не зависимо от года. И чтобы можно было изменять диапазон дат и их количество.
02.01.19 14.02.19 1
14.02.19 10.03.19 -1
05.08.19 03.09.19 1
06.09.19 01.10.19 -1
04.10.19 15.10.19 1
03.12.19 17.12.19 -1

Автор - slava230160
Дата добавления - 29.01.2019 в 20:02
vikttur Дата: Вторник, 29.01.2019, 21:10 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2895
Репутация: 519 ±
Замечаний: 0% ±

Код
=МИН(ЕСЛИ(дата>=A2:A7;ЕСЛИ(дата<=B2:B7;СТРОКА(B2:B7))))

Покажет номер строки с диапазоном, в который входит дата.
Без Вашего файла-примера только так, на коленке


Сообщение отредактировал vikttur - Вторник, 29.01.2019, 21:10
 
Ответить
Сообщение
Код
=МИН(ЕСЛИ(дата>=A2:A7;ЕСЛИ(дата<=B2:B7;СТРОКА(B2:B7))))

Покажет номер строки с диапазоном, в который входит дата.
Без Вашего файла-примера только так, на коленке

Автор - vikttur
Дата добавления - 29.01.2019 в 21:10
bmv98rus Дата: Вторник, 29.01.2019, 21:15 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1581
Репутация: 259 ±
Замечаний: 0% ±

Excel 2013/2016
[offtop] vikttur, HOSTS excelworld.ru 127.0.0.1[/offtop]
 
Ответить
Сообщение[offtop] vikttur, HOSTS excelworld.ru 127.0.0.1[/offtop]

Автор - bmv98rus
Дата добавления - 29.01.2019 в 21:15
vikttur Дата: Вторник, 29.01.2019, 21:32 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2895
Репутация: 519 ±
Замечаний: 0% ±

[offtop]Э, нет - перерыв! Имею полное моральное право )[/offtop]
 
Ответить
Сообщение[offtop]Э, нет - перерыв! Имею полное моральное право )[/offtop]

Автор - vikttur
Дата добавления - 29.01.2019 в 21:32
slava230160 Дата: Среда, 30.01.2019, 15:56 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
vikttur, Спасибо за отклик. Вот файл.
К сообщению приложен файл: 9151968.xlsx(80.6 Kb)
 
Ответить
Сообщениеvikttur, Спасибо за отклик. Вот файл.

Автор - slava230160
Дата добавления - 30.01.2019 в 15:56
bmv98rus Дата: Среда, 30.01.2019, 16:59 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1581
Репутация: 259 ±
Замечаний: 0% ±

Excel 2013/2016
Вот файл.
И что с ним делать? Он соотносится с #1 только тем, что и там и там даты.
 
Ответить
Сообщение
Вот файл.
И что с ним делать? Он соотносится с #1 только тем, что и там и там даты.

Автор - bmv98rus
Дата добавления - 30.01.2019 в 16:59
Pelena Дата: Среда, 30.01.2019, 18:18 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 13660
Репутация: 3004 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Код
=СУММЕСЛИМН($F$1:$F$6;$D$1:$D$6;"<="&A4;$E$1:$E$6;">="&A4)
К сообщению приложен файл: 9102832.xlsx(25.4 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=СУММЕСЛИМН($F$1:$F$6;$D$1:$D$6;"<="&A4;$E$1:$E$6;">="&A4)

Автор - Pelena
Дата добавления - 30.01.2019 в 18:18
bmv98rus Дата: Среда, 30.01.2019, 19:34 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1581
Репутация: 259 ±
Замечаний: 0% ±

Excel 2013/2016
ну тогда так можно
Код
=-(COUNTIFS($D$1:$D$6;"<="&A4;$E$1:$E$6;">="&A4)>0)


Pelena, Елена, ох балуете Вы ТС своими домыслами, ох балуете :-)
 
Ответить
Сообщениену тогда так можно
Код
=-(COUNTIFS($D$1:$D$6;"<="&A4;$E$1:$E$6;">="&A4)>0)


Pelena, Елена, ох балуете Вы ТС своими домыслами, ох балуете :-)

Автор - bmv98rus
Дата добавления - 30.01.2019 в 19:34
Pelena Дата: Среда, 30.01.2019, 21:40 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 13660
Репутация: 3004 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
своими домыслами

А "вдруг правильно"? (с) :)

А что это у вас с Виктором за тайнопись?
HOSTS excelworld.ru 127.0.0.1


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
своими домыслами

А "вдруг правильно"? (с) :)

А что это у вас с Виктором за тайнопись?
HOSTS excelworld.ru 127.0.0.1

Автор - Pelena
Дата добавления - 30.01.2019 в 21:40
bmv98rus Дата: Среда, 30.01.2019, 23:08 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1581
Репутация: 259 ±
Замечаний: 0% ±

Excel 2013/2016
[offtop]
А что это у вас с Виктором за тайнопись?

да он днем жаловался, что работа мешает, от форумов отвлекает, я ему рецепт предложил :-) . Запись в файл HOSTS заблокирует доступ к сайту. [/offtop]
 
Ответить
Сообщение[offtop]
А что это у вас с Виктором за тайнопись?

да он днем жаловался, что работа мешает, от форумов отвлекает, я ему рецепт предложил :-) . Запись в файл HOSTS заблокирует доступ к сайту. [/offtop]

Автор - bmv98rus
Дата добавления - 30.01.2019 в 23:08
Pelena Дата: Четверг, 31.01.2019, 09:18 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 13660
Репутация: 3004 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
[offtop]по мотивам Григория Остера? :) [/offtop]


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение[offtop]по мотивам Григория Остера? :) [/offtop]

Автор - Pelena
Дата добавления - 31.01.2019 в 09:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вложение дат в формулу (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!