Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расстановка выходных дней - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расстановка выходных дней (Формулы/Formulas)
Расстановка выходных дней
DjiM Дата: Среда, 30.01.2019, 14:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте
В столбцах В8:В22 по формуле проставляются выходные дни (субботы и воскресенья), возможно ли изменить формулу, чтобы туда добавлялись автоматически праздничные дни из столбцов D9:D22 и удалялись рабочие из столбцов Е9:Е22. (Рабочие дни я там добавил для проверки :) )
В итоге мне надо чтобы в столбцах В8:В22 автоматически отображались все выходные дни указанного месяца.
К сообщению приложен файл: 1111111111.xlsm(17.4 Kb)
 
Ответить
СообщениеЗдравствуйте
В столбцах В8:В22 по формуле проставляются выходные дни (субботы и воскресенья), возможно ли изменить формулу, чтобы туда добавлялись автоматически праздничные дни из столбцов D9:D22 и удалялись рабочие из столбцов Е9:Е22. (Рабочие дни я там добавил для проверки :) )
В итоге мне надо чтобы в столбцах В8:В22 автоматически отображались все выходные дни указанного месяца.

Автор - DjiM
Дата добавления - 30.01.2019 в 14:35
dude Дата: Среда, 30.01.2019, 16:59 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 136
Репутация: 19 ±
Замечаний: 0% ±

2016
Код
=ЕСЛИ($B$2="";"";ЕСЛИОШИБКА(АГРЕГАТ(15;6;($B$2+СТРОКА($1:$31)-1)/(ДЕНЬНЕД($B$2+СТРОКА($1:$31)-1;2)+5*ЕЧИСЛО(ПОИСКПОЗ($B$2+СТРОКА($1:$31)-1;$D$9:$D$22;))-10*ЕЧИСЛО(ПОИСКПОЗ($B$2+СТРОКА($1:$31)-1;$E$9:$E$22;))>5);СТРОКА(B1));""))
 
Ответить
Сообщение
Код
=ЕСЛИ($B$2="";"";ЕСЛИОШИБКА(АГРЕГАТ(15;6;($B$2+СТРОКА($1:$31)-1)/(ДЕНЬНЕД($B$2+СТРОКА($1:$31)-1;2)+5*ЕЧИСЛО(ПОИСКПОЗ($B$2+СТРОКА($1:$31)-1;$D$9:$D$22;))-10*ЕЧИСЛО(ПОИСКПОЗ($B$2+СТРОКА($1:$31)-1;$E$9:$E$22;))>5);СТРОКА(B1));""))

Автор - dude
Дата добавления - 30.01.2019 в 16:59
DjiM Дата: Четверг, 31.01.2019, 08:55 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
dude, Спасибо
 
Ответить
Сообщениеdude, Спасибо

Автор - DjiM
Дата добавления - 31.01.2019 в 08:55
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расстановка выходных дней (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!