Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/посчитать количество повторяющихся цифр - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать количество повторяющихся цифр (Формулы/Formulas)
посчитать количество повторяющихся цифр
renby Дата: Четверг, 31.01.2019, 13:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте! Помогите пожалуйста решить такую задачу: Нужно в столбце посчитать количество цифр (не количество повторений), повторяющихся 2 раза и количество цифр, повторяющихся в столбце 3 и более раз.
 
Ответить
СообщениеЗдравствуйте! Помогите пожалуйста решить такую задачу: Нужно в столбце посчитать количество цифр (не количество повторений), повторяющихся 2 раза и количество цифр, повторяющихся в столбце 3 и более раз.

Автор - renby
Дата добавления - 31.01.2019 в 13:17
китин Дата: Четверг, 31.01.2019, 13:31 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5370
Репутация: 866 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
СЧЁТЕСЛИ вам в помощь. точнее при наличии файла примера


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеСЧЁТЕСЛИ вам в помощь. точнее при наличии файла примера

Автор - китин
Дата добавления - 31.01.2019 в 13:31
_Boroda_ Дата: Четверг, 31.01.2019, 13:31 | Сообщение № 3
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Без Вашего примера не совсем понятна фраза
посчитать количество цифр (не количество повторений)

Так?
Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:A20)=2)/2)

Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:A20)>2)/СЧЁТЕСЛИ(A:A;A1:A20))
К сообщению приложен файл: 51765.xlsm(8.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеБез Вашего примера не совсем понятна фраза
посчитать количество цифр (не количество повторений)

Так?
Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:A20)=2)/2)

Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:A20)>2)/СЧЁТЕСЛИ(A:A;A1:A20))

Автор - _Boroda_
Дата добавления - 31.01.2019 в 13:31
renby Дата: Четверг, 31.01.2019, 14:03 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Да, наверное так. В первом случае я посчитал так
Код
СЧЕТЕСЛИ(B1:b20;=2)
, потом результат поделил на 2, так как цифры повторяются по 2 раза. А вот со вторым случаем так и не сообразил как сделать. К сожалению у меня очень мало опыта работы с эксель и я не совсем понимаю, как считает вторая формула. У меня столбец неопределенной длины и будут постоянно добавляться цифры. Как заменить аргумент A1:A20? Вернее это будет критерий A1:A20


Сообщение отредактировал renby - Четверг, 31.01.2019, 14:19
 
Ответить
СообщениеДа, наверное так. В первом случае я посчитал так
Код
СЧЕТЕСЛИ(B1:b20;=2)
, потом результат поделил на 2, так как цифры повторяются по 2 раза. А вот со вторым случаем так и не сообразил как сделать. К сожалению у меня очень мало опыта работы с эксель и я не совсем понимаю, как считает вторая формула. У меня столбец неопределенной длины и будут постоянно добавляться цифры. Как заменить аргумент A1:A20? Вернее это будет критерий A1:A20

Автор - renby
Дата добавления - 31.01.2019 в 14:03
_Boroda_ Дата: Четверг, 31.01.2019, 14:12 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Опыт ладно, дело наживное. А вот Правила форума прочитайте прямо сейчас. И поправьте свой предыдущий пост - формулу нужно засунуть в теги (ссылка на пояснялку есть в Правилах)

Да, в моем примере столбец В сделан только для облегчения проверки. Для расчетов он не нужен


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеОпыт ладно, дело наживное. А вот Правила форума прочитайте прямо сейчас. И поправьте свой предыдущий пост - формулу нужно засунуть в теги (ссылка на пояснялку есть в Правилах)

Да, в моем примере столбец В сделан только для облегчения проверки. Для расчетов он не нужен

Автор - _Boroda_
Дата добавления - 31.01.2019 в 14:12
renby Дата: Четверг, 31.01.2019, 14:28 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прошу прощения, исправил. Если я заменю критерий А1:А20 на А:А формула работать не будет. Происходит деление на 0 Как поступить, если длинна столбца не известна и будет увеличиваться?
 
Ответить
СообщениеПрошу прощения, исправил. Если я заменю критерий А1:А20 на А:А формула работать не будет. Происходит деление на 0 Как поступить, если длинна столбца не известна и будет увеличиваться?

Автор - renby
Дата добавления - 31.01.2019 в 14:28
_Boroda_ Дата: Четверг, 31.01.2019, 14:35 | Сообщение № 7
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14486
Репутация: 5788 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:ИНДЕКС(A:A;СЧЁТ(A:A)))=2)/2)

Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:ИНДЕКС(A:A;СЧЁТ(A:A)))>2)/СЧЁТЕСЛИ(A:A;A1:ИНДЕКС(A:A;СЧЁТ(A:A))))


Пояснение для второй формулы из предыдущего поста
1. СЧЁТЕСЛИ(A:A;A1:A20) - дает количество повторов для каждой ячейки
2. п.1 > 2 - если больше 2, то ИСТИНА (или 1), иначе - ЛОЖЬ (или 0)
3. делим п.2 на п.1, получаем если 2 или меньше повтора, то 0 (из п.2), иначе - 1, деленную на кол-во повторов
Далее пример
1-2-2-2-1-3-3-3-3-4
получаем
0-1/3-1/3-1/3-0-1/4-1/4-1/4-1/4-0
Заметьте, что двоек у нас триштуки и значений 1/3 конечно тоже штуки. Было бы двоек четыре, то получилось бы 4 штуки значений 1/4 (как для троек). Если сложить 3 раза по 1/3, то получим 1. В общем случае n раз по 1/n будет 1
4. СУММПРОИЗВ (п.3) - даст как раз нужное кол-во - 0+3*1/3+0+4*1/4=0+1+0+1=2
К сообщению приложен файл: 517656.xlsm(10.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:ИНДЕКС(A:A;СЧЁТ(A:A)))=2)/2)

Код
=СУММПРОИЗВ((СЧЁТЕСЛИ(A:A;A1:ИНДЕКС(A:A;СЧЁТ(A:A)))>2)/СЧЁТЕСЛИ(A:A;A1:ИНДЕКС(A:A;СЧЁТ(A:A))))


Пояснение для второй формулы из предыдущего поста
1. СЧЁТЕСЛИ(A:A;A1:A20) - дает количество повторов для каждой ячейки
2. п.1 > 2 - если больше 2, то ИСТИНА (или 1), иначе - ЛОЖЬ (или 0)
3. делим п.2 на п.1, получаем если 2 или меньше повтора, то 0 (из п.2), иначе - 1, деленную на кол-во повторов
Далее пример
1-2-2-2-1-3-3-3-3-4
получаем
0-1/3-1/3-1/3-0-1/4-1/4-1/4-1/4-0
Заметьте, что двоек у нас триштуки и значений 1/3 конечно тоже штуки. Было бы двоек четыре, то получилось бы 4 штуки значений 1/4 (как для троек). Если сложить 3 раза по 1/3, то получим 1. В общем случае n раз по 1/n будет 1
4. СУММПРОИЗВ (п.3) - даст как раз нужное кол-во - 0+3*1/3+0+4*1/4=0+1+0+1=2

Автор - _Boroda_
Дата добавления - 31.01.2019 в 14:35
renby Дата: Четверг, 31.01.2019, 14:39 | Сообщение № 8
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо большое, очень помогли. Сам бы в жизни не догадался.
 
Ответить
СообщениеСпасибо большое, очень помогли. Сам бы в жизни не догадался.

Автор - renby
Дата добавления - 31.01.2019 в 14:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » посчитать количество повторяющихся цифр (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!