Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование чисел в массиве по столбцам - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование чисел в массиве по столбцам (Формулы/Formulas)
Суммирование чисел в массиве по столбцам
daledale Дата: Пятница, 01.02.2019, 12:02 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Доброго. Снова обращаюсь к гуру Excel. Есть массив, состоящий из значений (только 0 и 1).
Есть некая ячейка, в которую вписывается некоторое число N.
Нужно получить массив, состоящий из одной строки, в каждом столбце которого будет сумма N значений соответствующего столбца массива 1, начиная с конца. Т.е. при значении N=1 - в примере в новом массиве дб 1 0 1, при N=2 - 2 1 1, N=3 - 3 1 2, N=4 3 1 3 итд. См. влож.файл.
Спасибо в очередной раз большое.
К сообщению приложен файл: sum_matrx.xlsx(8.2 Kb)
 
Ответить
СообщениеДоброго. Снова обращаюсь к гуру Excel. Есть массив, состоящий из значений (только 0 и 1).
Есть некая ячейка, в которую вписывается некоторое число N.
Нужно получить массив, состоящий из одной строки, в каждом столбце которого будет сумма N значений соответствующего столбца массива 1, начиная с конца. Т.е. при значении N=1 - в примере в новом массиве дб 1 0 1, при N=2 - 2 1 1, N=3 - 3 1 2, N=4 3 1 3 итд. См. влож.файл.
Спасибо в очередной раз большое.

Автор - daledale
Дата добавления - 01.02.2019 в 12:02
китин Дата: Пятница, 01.02.2019, 12:12 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5308
Репутация: 834 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
и вам не хворать!!! :D
так надо? формула массива
Код
=СУММ(ИНДЕКС(A$2:A$7;ЧСТРОК($A$2:$A$7)-$E$9+1):ИНДЕКС(A$2:A$7;ЧСТРОК($A$2:$A$7)))
К сообщению приложен файл: daledale.xlsx(9.1 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеи вам не хворать!!! :D
так надо? формула массива
Код
=СУММ(ИНДЕКС(A$2:A$7;ЧСТРОК($A$2:$A$7)-$E$9+1):ИНДЕКС(A$2:A$7;ЧСТРОК($A$2:$A$7)))

Автор - китин
Дата добавления - 01.02.2019 в 12:12
daledale Дата: Пятница, 01.02.2019, 12:15 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
китин
В очередной раз спасибо Гуру! Проверил. Работает. То, что надо!


Сообщение отредактировал daledale - Пятница, 01.02.2019, 12:16
 
Ответить
Сообщениекитин
В очередной раз спасибо Гуру! Проверил. Работает. То, что надо!

Автор - daledale
Дата добавления - 01.02.2019 в 12:15
vikttur Дата: Пятница, 01.02.2019, 12:23 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2895
Репутация: 519 ±
Замечаний: 0% ±

Код
=СУММ(ИНДЕКС(A2:A7;СЧЁТ(A2:A7)-$E$9+1):A7)
 
Ответить
Сообщение
Код
=СУММ(ИНДЕКС(A2:A7;СЧЁТ(A2:A7)-$E$9+1):A7)

Автор - vikttur
Дата добавления - 01.02.2019 в 12:23
daledale Дата: Пятница, 01.02.2019, 12:35 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
vikttur
Спасибо большое!
 
Ответить
Сообщениеvikttur
Спасибо большое!

Автор - daledale
Дата добавления - 01.02.2019 в 12:35
_Boroda_ Дата: Пятница, 01.02.2019, 12:42 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14125
Репутация: 5696 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Еще вариант. Правда, волатильный. Но зато можно добавлять данные (в предыдущие формулы тоже добавлять конечно можно, чуть переписать только)
Код
=СУММ(СМЕЩ(A1;СЧЁТ(A:A);;-$E9))


* Кстати, обратите внимание на справку для СМЕЩ -
Цитата
Высота Необязательный. Высота (число строк) возвращаемой ссылки. Значение аргумента "высота" должно быть положительным числом.

https://support.office.com/ru-ru....6d11b66
Косячок-с. Я об этом писал на форумах много лет назад еще для 2003 Excel. Так и не поправили


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕще вариант. Правда, волатильный. Но зато можно добавлять данные (в предыдущие формулы тоже добавлять конечно можно, чуть переписать только)
Код
=СУММ(СМЕЩ(A1;СЧЁТ(A:A);;-$E9))


* Кстати, обратите внимание на справку для СМЕЩ -
Цитата
Высота Необязательный. Высота (число строк) возвращаемой ссылки. Значение аргумента "высота" должно быть положительным числом.

https://support.office.com/ru-ru....6d11b66
Косячок-с. Я об этом писал на форумах много лет назад еще для 2003 Excel. Так и не поправили

Автор - _Boroda_
Дата добавления - 01.02.2019 в 12:42
daledale Дата: Пятница, 01.02.2019, 21:38 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Огромное спасибо всем. И вам, _Boroda_. Применил самый первый вариант китин'a. Этот вариант завёлся "с пол-оборота", его и оставил.
 
Ответить
СообщениеОгромное спасибо всем. И вам, _Boroda_. Применил самый первый вариант китин'a. Этот вариант завёлся "с пол-оборота", его и оставил.

Автор - daledale
Дата добавления - 01.02.2019 в 21:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование чисел в массиве по столбцам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!