Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Самое частое слово в столбце при условии из другого столбца - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Самое частое слово в столбце при условии из другого столбца (Формулы/Formulas)
Самое частое слово в столбце при условии из другого столбца
Annafreya Дата: Понедельник, 04.02.2019, 13:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Ребята, помогите, пожалуйста, с формулой!

Задача такая: определить самое часто встречающееся слово из диапазона G17:G116, если напротив этого слова в M17:M116 заполнены данные.

Самое часто втреч. слово я находила по формуле
Код
=INDEX($G$17:$G$116,MATCH(MAX(COUNTIF($G$17:$G$116,$G$17:$G$116)),COUNTIF($G$17:$G$116,$G$17:$G$116),0))


Чтобы исключить из условия пустые ячейки из M17:M116, думала применить формулу:
Код
=IF(ISBLANK(M17:M116)," "INDEX($G$17:$G$116:$G$17:$G$116,MATCH(MAX(COUNTIF($G$17:$G$116,$G$17:$G$116)),COUNTIF($G$17:$G$116,$G$17:$G$116),0)))


Если пустая ячейка в столбце, значит ничего, если не пустая, значит нужно определить часто втреч. слово.

Не получается(((

Я в excel новичок. Наверняка, что-то не так делаю.
 
Ответить
СообщениеРебята, помогите, пожалуйста, с формулой!

Задача такая: определить самое часто встречающееся слово из диапазона G17:G116, если напротив этого слова в M17:M116 заполнены данные.

Самое часто втреч. слово я находила по формуле
Код
=INDEX($G$17:$G$116,MATCH(MAX(COUNTIF($G$17:$G$116,$G$17:$G$116)),COUNTIF($G$17:$G$116,$G$17:$G$116),0))


Чтобы исключить из условия пустые ячейки из M17:M116, думала применить формулу:
Код
=IF(ISBLANK(M17:M116)," "INDEX($G$17:$G$116:$G$17:$G$116,MATCH(MAX(COUNTIF($G$17:$G$116,$G$17:$G$116)),COUNTIF($G$17:$G$116,$G$17:$G$116),0)))


Если пустая ячейка в столбце, значит ничего, если не пустая, значит нужно определить часто втреч. слово.

Не получается(((

Я в excel новичок. Наверняка, что-то не так делаю.

Автор - Annafreya
Дата добавления - 04.02.2019 в 13:48
_Boroda_ Дата: Понедельник, 04.02.2019, 13:53 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Да, кое-что действительно не так. Для того, чтобы с формулой поиграться, нужен файлик. Можно его, конечно, и сделать, но гораздо лучше будет, если, согласно п.3 Правил форума, Вы положите сюда свой

* И что делать, если наиболее частых не одно, а несколько слов? Судя по Вашей первой формуле, нужно только одно из них (верхнее) вывести?


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДа, кое-что действительно не так. Для того, чтобы с формулой поиграться, нужен файлик. Можно его, конечно, и сделать, но гораздо лучше будет, если, согласно п.3 Правил форума, Вы положите сюда свой

* И что делать, если наиболее частых не одно, а несколько слов? Судя по Вашей первой формуле, нужно только одно из них (верхнее) вывести?

Автор - _Boroda_
Дата добавления - 04.02.2019 в 13:53
китин Дата: Понедельник, 04.02.2019, 13:54 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
с вашим файлом было бы гораздо проще вам помочь.


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениес вашим файлом было бы гораздо проще вам помочь.

Автор - китин
Дата добавления - 04.02.2019 в 13:54
Annafreya Дата: Понедельник, 04.02.2019, 14:05 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Прикладываю файл. Надеюсь, в таком виде пойдет). Если причина увольн. не указана, значит, чел. еще работает.
Спасибо за помощь!
К сообщению приложен файл: Book2.xlsx(11.7 Kb)
 
Ответить
СообщениеПрикладываю файл. Надеюсь, в таком виде пойдет). Если причина увольн. не указана, значит, чел. еще работает.
Спасибо за помощь!

Автор - Annafreya
Дата добавления - 04.02.2019 в 14:05
_Boroda_ Дата: Понедельник, 04.02.2019, 14:26 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Формула массива
Код
=ИНДЕКС(A2:A12;МОДА(ЕСЛИ(B2:B12="";СТРОКА(B2:B12)+999;ПОИСКПОЗ(A2:A12;A2:A12;))))
При равенстве количеств даст того, кто первым попался

Или еще вариант. Немассивный
Код
=ТЕКСТ(СУММПРОИЗВ(СЧЁТЕСЛИМН(A:A;{"ж*";"м*"};B:B;"*")*{1;-1});"ж;\м;равно")
К сообщению приложен файл: Book2-4-1.xlsx(12.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Формула массива
Код
=ИНДЕКС(A2:A12;МОДА(ЕСЛИ(B2:B12="";СТРОКА(B2:B12)+999;ПОИСКПОЗ(A2:A12;A2:A12;))))
При равенстве количеств даст того, кто первым попался

Или еще вариант. Немассивный
Код
=ТЕКСТ(СУММПРОИЗВ(СЧЁТЕСЛИМН(A:A;{"ж*";"м*"};B:B;"*")*{1;-1});"ж;\м;равно")

Автор - _Boroda_
Дата добавления - 04.02.2019 в 14:26
Светлый Дата: Понедельник, 04.02.2019, 14:29 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1070
Репутация: 274 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(A2:A14;ПОИСКПОЗ(МАКС(СЧЁТЕСЛИМН(A2:A14;A2:A14;B2:B14;"<>"));СЧЁТЕСЛИМН(A2:A14;A2:A14;B2:B14;"<>");))
Исправил формулу.
*Исправил обратно. Формула массива.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 04.02.2019, 15:04
 
Ответить
Сообщение
Код
=ИНДЕКС(A2:A14;ПОИСКПОЗ(МАКС(СЧЁТЕСЛИМН(A2:A14;A2:A14;B2:B14;"<>"));СЧЁТЕСЛИМН(A2:A14;A2:A14;B2:B14;"<>");))
Исправил формулу.
*Исправил обратно. Формула массива.

Автор - Светлый
Дата добавления - 04.02.2019 в 14:29
Annafreya Дата: Понедельник, 04.02.2019, 14:43 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, СПАСИБО вам огромное! получается). попробую разобраться с составляющими этой формулы)).
 
Ответить
Сообщение_Boroda_, СПАСИБО вам огромное! получается). попробую разобраться с составляющими этой формулы)).

Автор - Annafreya
Дата добавления - 04.02.2019 в 14:43
_Boroda_ Дата: Понедельник, 04.02.2019, 14:44 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15009
Репутация: 5926 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Цитата Светлый, 04.02.2019 в 14:29, в сообщении № 6 ()
Исправил формулу

А сначала лучше была :D
Сергей, поставь в столбец А всех "м" и двух "б". У обеих "б" по причине, а у "м" пусть все пусто останется


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение
Цитата Светлый, 04.02.2019 в 14:29, в сообщении № 6 ()
Исправил формулу

А сначала лучше была :D
Сергей, поставь в столбец А всех "м" и двух "б". У обеих "б" по причине, а у "м" пусть все пусто останется

Автор - _Boroda_
Дата добавления - 04.02.2019 в 14:44
Annafreya Дата: Понедельник, 04.02.2019, 14:52 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, и вам спасибо большое!!! пробую. пока не получилось))
 
Ответить
СообщениеСветлый, и вам спасибо большое!!! пробую. пока не получилось))

Автор - Annafreya
Дата добавления - 04.02.2019 в 14:52
Светлый Дата: Понедельник, 04.02.2019, 14:59 | Сообщение № 10
Группа: Проверенные
Ранг: Старожил
Сообщений: 1070
Репутация: 274 ±
Замечаний: 0% ±

Excel 2010
пока не получилось
Формула массива.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
пока не получилось
Формула массива.

Автор - Светлый
Дата добавления - 04.02.2019 в 14:59
Светлый Дата: Понедельник, 04.02.2019, 15:03 | Сообщение № 11
Группа: Проверенные
Ранг: Старожил
Сообщений: 1070
Репутация: 274 ±
Замечаний: 0% ±

Excel 2010
А сначала лучше была
Совершенно верно. Условие Уволили, совсем запутался.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
А сначала лучше была
Совершенно верно. Условие Уволили, совсем запутался.

Автор - Светлый
Дата добавления - 04.02.2019 в 15:03
китин Дата: Понедельник, 04.02.2019, 15:22 | Сообщение № 12
Группа: Модераторы
Ранг: Экселист
Сообщений: 5530
Репутация: 881 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
[offtop]
всех "м" и двух "б"

хм. вторые кавычки как то смущают :D


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение[offtop]
всех "м" и двух "б"

хм. вторые кавычки как то смущают :D

Автор - китин
Дата добавления - 04.02.2019 в 15:22
Светлый Дата: Понедельник, 04.02.2019, 17:04 | Сообщение № 13
Группа: Проверенные
Ранг: Старожил
Сообщений: 1070
Репутация: 274 ±
Замечаний: 0% ±

Excel 2010
Покороче. Массивные:
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС(СЧЁТЕСЛИМН(A2:A24;A2:A24;B2:B24;"<>")+СТРОКА(2:24)%);1)/1%)
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС(СЧЁТЕСЛИМН(A2:A24;A2:A24;B2:B24;"<>")*100+СТРОКА(2:24));100))
*
Код
=СМЕЩ(A1;ОСТАТ(МАКС(СЧЁТЕСЛИМН(A2:A24;A2:A24;B2:B24;"<>")+СТРОКА(1:23)%);1)/1%;)


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Понедельник, 04.02.2019, 17:19
 
Ответить
СообщениеПокороче. Массивные:
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС(СЧЁТЕСЛИМН(A2:A24;A2:A24;B2:B24;"<>")+СТРОКА(2:24)%);1)/1%)
Код
=ИНДЕКС(A:A;ОСТАТ(МАКС(СЧЁТЕСЛИМН(A2:A24;A2:A24;B2:B24;"<>")*100+СТРОКА(2:24));100))
*
Код
=СМЕЩ(A1;ОСТАТ(МАКС(СЧЁТЕСЛИМН(A2:A24;A2:A24;B2:B24;"<>")+СТРОКА(1:23)%);1)/1%;)

Автор - Светлый
Дата добавления - 04.02.2019 в 17:04
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Самое частое слово в столбце при условии из другого столбца (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!