Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/При выборе нужной даты без данных прописываем ноль - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При выборе нужной даты без данных прописываем ноль (Формулы/Formulas)
При выборе нужной даты без данных прописываем ноль
BiteR Дата: Суббота, 09.02.2019, 08:30 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Добрый день!
Суть вопроса: Имеем таблицу с определёнными датами, на каждую дату имеем данные- план и факт. При выборе даты, в строке "Заполняемая дата", получаем необходимые данные, но если выбрать дату, которой нет, в строке с датами, то подгружаются данные с ближайшей даты. Как сделать, чтобы при выборе даты, которой нет в строке с датами, в ячейках план и факт прописывался 0.
К сообщению приложен файл: 1051669.xls(52.5 Kb)
 
Ответить
СообщениеДобрый день!
Суть вопроса: Имеем таблицу с определёнными датами, на каждую дату имеем данные- план и факт. При выборе даты, в строке "Заполняемая дата", получаем необходимые данные, но если выбрать дату, которой нет, в строке с датами, то подгружаются данные с ближайшей даты. Как сделать, чтобы при выборе даты, которой нет в строке с датами, в ячейках план и факт прописывался 0.

Автор - BiteR
Дата добавления - 09.02.2019 в 08:30
Pelena Дата: Суббота, 09.02.2019, 08:45 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 13866
Репутация: 3041 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Здравствуйте.
Именно при таких данных формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(G14:Y14;ПОИСКПОЗ(I29;ОТБР(G13:Y13);0));0)

Но если предусмотреть в источнике сводной доп. столбец, отбрасывающий время, то можно обойтись простой формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(G14:Y14;ПОИСКПОЗ(I29;G13:Y13;0));0)


========== Добавлено
Или в сводной даты сгруппировать по дням и использовать формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС(G14:Y14;ПОИСКПОЗ(ТЕКСТ(I29;"Д.МММ");G13:Y13;0));0)
К сообщению приложен файл: 0173395.xls(68.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Именно при таких данных формула массива
Код
=ЕСЛИОШИБКА(ИНДЕКС(G14:Y14;ПОИСКПОЗ(I29;ОТБР(G13:Y13);0));0)

Но если предусмотреть в источнике сводной доп. столбец, отбрасывающий время, то можно обойтись простой формулой
Код
=ЕСЛИОШИБКА(ИНДЕКС(G14:Y14;ПОИСКПОЗ(I29;G13:Y13;0));0)


========== Добавлено
Или в сводной даты сгруппировать по дням и использовать формулу
Код
=ЕСЛИОШИБКА(ИНДЕКС(G14:Y14;ПОИСКПОЗ(ТЕКСТ(I29;"Д.МММ");G13:Y13;0));0)

Автор - Pelena
Дата добавления - 09.02.2019 в 08:45
BiteR Дата: Суббота, 09.02.2019, 09:03 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Проблема в том, что в компании, где я работаю, excel 2003 и данный способ, к сожалению, не работает.
 
Ответить
СообщениеПроблема в том, что в компании, где я работаю, excel 2003 и данный способ, к сожалению, не работает.

Автор - BiteR
Дата добавления - 09.02.2019 в 09:03
Pelena Дата: Суббота, 09.02.2019, 09:28 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13866
Репутация: 3041 ±
Замечаний: ±

Excel 2010, 2016 & Mac Excel
Формулы можно адаптировать. Например, первая
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(I29;ОТБР(G13:Y13);0));0;ИНДЕКС(G14:Y14;ПОИСКПОЗ(I29;ОТБР(G13:Y13);0)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормулы можно адаптировать. Например, первая
Код
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(I29;ОТБР(G13:Y13);0));0;ИНДЕКС(G14:Y14;ПОИСКПОЗ(I29;ОТБР(G13:Y13);0)))

Автор - Pelena
Дата добавления - 09.02.2019 в 09:28
Светлый Дата: Суббота, 09.02.2019, 10:58 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1003
Репутация: 258 ±
Замечаний: 0% ±

Excel 2010
Можно так. Массивная протягиваемая формула:
Код
=ЕСЛИ(ИЛИ($I29=ОТБР($G13:$L13));ИНДЕКС(14:15;СТОЛБЕЦ(A29);ПОИСКПОЗ($I29;ОТБР(13:13);));)


Программировать проще, чем писать стихи.
 
Ответить
СообщениеМожно так. Массивная протягиваемая формула:
Код
=ЕСЛИ(ИЛИ($I29=ОТБР($G13:$L13));ИНДЕКС(14:15;СТОЛБЕЦ(A29);ПОИСКПОЗ($I29;ОТБР(13:13);));)

Автор - Светлый
Дата добавления - 09.02.2019 в 10:58
bmv98rus Дата: Суббота, 09.02.2019, 13:55 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
В кроссе предупреждать надо что 2003
Код
=SUMIF(G13:L13;">="& I29+"9:00";G14:L14)


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеВ кроссе предупреждать надо что 2003
Код
=SUMIF(G13:L13;">="& I29+"9:00";G14:L14)

Автор - bmv98rus
Дата добавления - 09.02.2019 в 13:55
vikttur Дата: Суббота, 09.02.2019, 14:11 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

9/24 быстрее набирается и короче )
И не требует преобразования


Сообщение отредактировал vikttur - Суббота, 09.02.2019, 14:16
 
Ответить
Сообщение9/24 быстрее набирается и короче )
И не требует преобразования

Автор - vikttur
Дата добавления - 09.02.2019 в 14:11
bmv98rus Дата: Суббота, 09.02.2019, 14:29 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 2023
Репутация: 320 ±
Замечаний: 20% ±

Excel 2013/2016
vikttur, Потом пояснять, что это за дробь :-) но в целом согласен, на 3/8 :-)
Странно, вроде в 2003 и это получилось бы
Код
=SUMPRODUCT((INT(G13:L13)=I29)*G14:L14)


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Суббота, 09.02.2019, 14:32
 
Ответить
Сообщениеvikttur, Потом пояснять, что это за дробь :-) но в целом согласен, на 3/8 :-)
Странно, вроде в 2003 и это получилось бы
Код
=SUMPRODUCT((INT(G13:L13)=I29)*G14:L14)

Автор - bmv98rus
Дата добавления - 09.02.2019 в 14:29
vikttur Дата: Суббота, 09.02.2019, 14:48 | Сообщение № 9
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Э, нет, 3/8 - это уже МШ )
 
Ответить
СообщениеЭ, нет, 3/8 - это уже МШ )

Автор - vikttur
Дата добавления - 09.02.2019 в 14:48
BiteR Дата: Суббота, 09.02.2019, 15:55 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
Извиняюсь, за 2003 забыл предупредить.
 
Ответить
СообщениеИзвиняюсь, за 2003 забыл предупредить.

Автор - BiteR
Дата добавления - 09.02.2019 в 15:55
BiteR Дата: Суббота, 09.02.2019, 15:58 | Сообщение № 11
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Excel 2003
=СУММПРОИЗВ((ЦЕЛОЕ(G13:L13)=I29)*G14:L14)

Всё заработало, спасибо).
 
Ответить
Сообщение
=СУММПРОИЗВ((ЦЕЛОЕ(G13:L13)=I29)*G14:L14)

Всё заработало, спасибо).

Автор - BiteR
Дата добавления - 09.02.2019 в 15:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » При выборе нужной даты без данных прописываем ноль (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!