Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование чисел написанных через дробь в excel - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование чисел написанных через дробь в excel (Формулы/Formulas)
Суммирование чисел написанных через дробь в excel
Aleksey_62 Дата: Суббота, 09.02.2019, 22:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте. Помогите с формулой. Нужно посчитать отдельно до знака "/" и отдельно после, при этом число записанное без знака "/" суммировалось к значению перед знаком "/", а пустая ячейка была как бы нулем, но оставалась пустой. Пытался делать с примерами которые тут находил, но ничего не получилось.
К сообщению приложен файл: 5449453.xls(32.5 Kb)
 
Ответить
СообщениеЗдравствуйте. Помогите с формулой. Нужно посчитать отдельно до знака "/" и отдельно после, при этом число записанное без знака "/" суммировалось к значению перед знаком "/", а пустая ячейка была как бы нулем, но оставалась пустой. Пытался делать с примерами которые тут находил, но ничего не получилось.

Автор - Aleksey_62
Дата добавления - 09.02.2019 в 22:16
Светлый Дата: Суббота, 09.02.2019, 22:53 | Сообщение № 2
Группа: Проверенные
Ранг: Ветеран
Сообщений: 944
Репутация: 233 ±
Замечаний: 0% ±

Excel 2010
Здравствуйте!
Может быть, так:
Код
=СУММ(--ЛЕВБ(ПОДСТАВИТЬ(0&A2:E2&"/";"/";"     ");5))&"/"&СУММ(--ПСТР(ПОДСТАВИТЬ(A2:E2&"/0";"/";"     ");5;5))


Программировать проще, чем писать стихи.
 
Ответить
СообщениеЗдравствуйте!
Может быть, так:
Код
=СУММ(--ЛЕВБ(ПОДСТАВИТЬ(0&A2:E2&"/";"/";"     ");5))&"/"&СУММ(--ПСТР(ПОДСТАВИТЬ(A2:E2&"/0";"/";"     ");5;5))

Автор - Светлый
Дата добавления - 09.02.2019 в 22:53
krosav4ig Дата: Суббота, 09.02.2019, 22:55 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1984
Репутация: 840 ±
Замечаний: 0% ±

Excel 2007,2010,2013
как вариант, массивная формула (вводится комбинацией Ctrl+Sift+Enter)
Код
=ТЕКСТ(СУММ(--(0&СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A2:E2;"/";"     ");{1:6};5)))*10^{3:0});"000\/000")


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460

Сообщение отредактировал krosav4ig - Суббота, 09.02.2019, 22:56
 
Ответить
Сообщениекак вариант, массивная формула (вводится комбинацией Ctrl+Sift+Enter)
Код
=ТЕКСТ(СУММ(--(0&СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A2:E2;"/";"     ");{1:6};5)))*10^{3:0});"000\/000")

Автор - krosav4ig
Дата добавления - 09.02.2019 в 22:55
Karataev Дата: Суббота, 09.02.2019, 23:03 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1294
Репутация: 504 ±
Замечаний: 0% ±

Excel
Формула массива для "F2". Завершайте ввод формулы не клавишей Enter (как Вы это обычно делаете), а сочетанием клавиш Ctrl+Shift+Enter.
Код
=СУММ(--ЕСЛИ(ЕОШ(ПОИСК("/";A2:E2));A2:E2;ЗАМЕНИТЬ(A2:E2;ПОИСК("/";A2:E2);255;"")))&"/"&СУММ(--ЕСЛИ(ЕОШ(ПОИСК("/";A2:E2));0;ЗАМЕНИТЬ(A2:E2;1;ПОИСК("/";A2:E2);"")))
К сообщению приложен файл: 5449453-kar.xls(34.0 Kb)


Киви-кошелек: 9166309108
Яндекс-деньги: 410014131888288


Сообщение отредактировал Karataev - Суббота, 09.02.2019, 23:16
 
Ответить
СообщениеФормула массива для "F2". Завершайте ввод формулы не клавишей Enter (как Вы это обычно делаете), а сочетанием клавиш Ctrl+Shift+Enter.
Код
=СУММ(--ЕСЛИ(ЕОШ(ПОИСК("/";A2:E2));A2:E2;ЗАМЕНИТЬ(A2:E2;ПОИСК("/";A2:E2);255;"")))&"/"&СУММ(--ЕСЛИ(ЕОШ(ПОИСК("/";A2:E2));0;ЗАМЕНИТЬ(A2:E2;1;ПОИСК("/";A2:E2);"")))

Автор - Karataev
Дата добавления - 09.02.2019 в 23:03
vikttur Дата: Суббота, 09.02.2019, 23:08 | Сообщение № 5
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Светлый, для левого палочку можно не цеплять:
Код
=СУММ(--ЛЕВБ(ПОДСТАВИТЬ(0&A2:E2;"/";"     ");5))


Сообщение отредактировал vikttur - Суббота, 09.02.2019, 23:08
 
Ответить
СообщениеСветлый, для левого палочку можно не цеплять:
Код
=СУММ(--ЛЕВБ(ПОДСТАВИТЬ(0&A2:E2;"/";"     ");5))

Автор - vikttur
Дата добавления - 09.02.2019 в 23:08
bmv98rus Дата: Суббота, 09.02.2019, 23:27 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 1797
Репутация: 293 ±
Замечаний: 0% ±

Excel 2013/2016
Естесвенно есть ограничения.
Код
=SUBSTITUTE(SUM(--(0&SUBSTITUTE(A2:E2;"/";",")));",";"/")
 
Ответить
СообщениеЕстесвенно есть ограничения.
Код
=SUBSTITUTE(SUM(--(0&SUBSTITUTE(A2:E2;"/";",")));",";"/")

Автор - bmv98rus
Дата добавления - 09.02.2019 в 23:27
vikttur Дата: Суббота, 09.02.2019, 23:30 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Видимо, качественная сегодня самокрутка :)
 
Ответить
СообщениеВидимо, качественная сегодня самокрутка :)

Автор - vikttur
Дата добавления - 09.02.2019 в 23:30
bmv98rus Дата: Суббота, 09.02.2019, 23:36 | Сообщение № 8
Группа: Проверенные
Ранг: Старожил
Сообщений: 1797
Репутация: 293 ±
Замечаний: 0% ±

Excel 2013/2016
А че сразу самокрутка, просто купаж винца удачный попался. :-)
 
Ответить
СообщениеА че сразу самокрутка, просто купаж винца удачный попался. :-)

Автор - bmv98rus
Дата добавления - 09.02.2019 в 23:36
Светлый Дата: Воскресенье, 10.02.2019, 00:06 | Сообщение № 9
Группа: Проверенные
Ранг: Ветеран
Сообщений: 944
Репутация: 233 ±
Замечаний: 0% ±

Excel 2010
Какие замечательные идеи:
Код
=ПОДСТАВИТЬ(СУММ(--ПОДСТАВИТЬ(0&A2:E2;"/";",0"));",";"/")
Код
=ТЕКСТ(СУММ(ПСТР(ПОДСТАВИТЬ(0&A2:E2&"/0";"/";"     ");{1:7};5)*{100:1});"0\/00")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Воскресенье, 10.02.2019, 00:18
 
Ответить
СообщениеКакие замечательные идеи:
Код
=ПОДСТАВИТЬ(СУММ(--ПОДСТАВИТЬ(0&A2:E2;"/";",0"));",";"/")
Код
=ТЕКСТ(СУММ(ПСТР(ПОДСТАВИТЬ(0&A2:E2&"/0";"/";"     ");{1:7};5)*{100:1});"0\/00")

Автор - Светлый
Дата добавления - 10.02.2019 в 00:06
Aleksey_62 Дата: Воскресенье, 10.02.2019, 08:06 | Сообщение № 10
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем спасибо, получилось.
 
Ответить
СообщениеВсем спасибо, получилось.

Автор - Aleksey_62
Дата добавления - 10.02.2019 в 08:06
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование чисел написанных через дробь в excel (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!