Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для вывода результата по данным из 2-х ячеек. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для вывода результата по данным из 2-х ячеек. (Формулы/Formulas)
Формула для вывода результата по данным из 2-х ячеек.
Tolyan Дата: Понедельник, 11.02.2019, 06:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
Здравствуйте!

Есть такой вид гороскопа как Восточно-зодиакальный.
Но суть в другом, необходимо из 2-х ячеек по формуле сделать 1.
К примеру в ячейки А: КРЫСА, в ячейке В: ОВЕН, из ник в ячейке С по формуле должно получится: КОРОЛЬ, всего существуйте 7 видов: АРИСТОКРАТ, ВЕКТОР, ВОЖДЬ, КОРОЛЬ, ПРОФЕССОР, РЫЦАРЬ и ШУТ, в файле приведены все примеры.
К сообщению приложен файл: 5499878.xlsx(11.6 Kb)


Сообщение отредактировал Tolyan - Понедельник, 11.02.2019, 07:38
 
Ответить
СообщениеЗдравствуйте!

Есть такой вид гороскопа как Восточно-зодиакальный.
Но суть в другом, необходимо из 2-х ячеек по формуле сделать 1.
К примеру в ячейки А: КРЫСА, в ячейке В: ОВЕН, из ник в ячейке С по формуле должно получится: КОРОЛЬ, всего существуйте 7 видов: АРИСТОКРАТ, ВЕКТОР, ВОЖДЬ, КОРОЛЬ, ПРОФЕССОР, РЫЦАРЬ и ШУТ, в файле приведены все примеры.

Автор - Tolyan
Дата добавления - 11.02.2019 в 06:06
китин Дата: Понедельник, 11.02.2019, 07:10 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5682
Репутация: 897 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Tolyan, дайте теме более конкретное название.
[moder]исправлено[/moder]


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538


Сообщение отредактировал китин - Понедельник, 11.02.2019, 09:52
 
Ответить
СообщениеTolyan, дайте теме более конкретное название.
[moder]исправлено[/moder]

Автор - китин
Дата добавления - 11.02.2019 в 07:10
китин Дата: Понедельник, 11.02.2019, 09:52 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 5682
Репутация: 897 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так надо?
массивная
Код
=ИНДЕКС($C$1:$C$144;ПОИСКПОЗ($F$3&$G$3;$A$1:$A$144&$B$1:$B$144;0))

простая
Код
=ПРОСМОТР(2;1/($F$3&$G$3=$A$1:$A$144&$B$1:$B$144);$C$1:$C$144)
К сообщению приложен файл: Tolyan.xlsx(13.5 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак надо?
массивная
Код
=ИНДЕКС($C$1:$C$144;ПОИСКПОЗ($F$3&$G$3;$A$1:$A$144&$B$1:$B$144;0))

простая
Код
=ПРОСМОТР(2;1/($F$3&$G$3=$A$1:$A$144&$B$1:$B$144);$C$1:$C$144)

Автор - китин
Дата добавления - 11.02.2019 в 09:52
_Boroda_ Дата: Понедельник, 11.02.2019, 09:53 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15427
Репутация: 6035 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Не совсем ясно - приведенная в файле таблица дана изначально или ее как раз и нужно получить?
Если дана и по ней нужно выбрать, то так можно
Код
=ПРОСМОТР(;-1/(A1:A144=E2)/(B1:B144=F2);C1:C144)

Код
=ПРОСМОТР(;-1/(A1:A144&B1:B144=E2&F2);C1:C144)

Если ее нужно получить, то распишите словами логику зависимости третьего столбца от первых двух
К сообщению приложен файл: 5499878_1.xlsx(13.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеНе совсем ясно - приведенная в файле таблица дана изначально или ее как раз и нужно получить?
Если дана и по ней нужно выбрать, то так можно
Код
=ПРОСМОТР(;-1/(A1:A144=E2)/(B1:B144=F2);C1:C144)

Код
=ПРОСМОТР(;-1/(A1:A144&B1:B144=E2&F2);C1:C144)

Если ее нужно получить, то распишите словами логику зависимости третьего столбца от первых двух

Автор - _Boroda_
Дата добавления - 11.02.2019 в 09:53
Tolyan Дата: Вторник, 12.02.2019, 04:39 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Excel 2007
китин, _Boroda_,
В ваших примерах указан уже конечный результат что хотелось видеть, но нужно как сказал _Boroda_, получить таблицу, т.е. все расписанные данные указать в формуле, чтобы не по таблице выбирать а в формуле были данные, если такое возможно.
А логику зависимости я брал с сайта, не сам придумал.
 
Ответить
Сообщениекитин, _Boroda_,
В ваших примерах указан уже конечный результат что хотелось видеть, но нужно как сказал _Boroda_, получить таблицу, т.е. все расписанные данные указать в формуле, чтобы не по таблице выбирать а в формуле были данные, если такое возможно.
А логику зависимости я брал с сайта, не сам придумал.

Автор - Tolyan
Дата добавления - 12.02.2019 в 04:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для вывода результата по данным из 2-х ячеек. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!