Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск числа из ячейки с условием что перед ним не цифра - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск числа из ячейки с условием что перед ним не цифра (Формулы/Formulas)
Поиск числа из ячейки с условием что перед ним не цифра
Jelvis Дата: Вторник, 12.02.2019, 15:17 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 17
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Суть вопроса:
Существует ячейка A1 в которой находится текст - абаывфывыя07Март2004.xlsm
Нужно:

В ячейку A2 (Имя) поместить - абаывфывыя (С условием что длина этого текста будет заканчиваться перед первой попавшейся цифрой)
В ячейку А3 (День) поместить - 07 (С условием что перед 0 не стоит цифра и что после 7 не стоит цифра, иначе путается с текстом 2004)
В ячейку А4 (Месяц) поместить Март (РЕШЕНО)
В ячейку А5 (Год) поместить 2004 (РЕШЕНО)
В ячейку А6 (Формат) поместить .xlsm (РЕШЕНО)

Проблема только с Именем и Днем.

Решение для Месяца, года и формата следующее:
Код
=ЕСЛИ(ЕОШ(ПОИСК("Январь";A27));"";"Январь ") На примере месяца.


Сообщение отредактировал Jelvis - Вторник, 12.02.2019, 15:21
 
Ответить
СообщениеДобрый день! Суть вопроса:
Существует ячейка A1 в которой находится текст - абаывфывыя07Март2004.xlsm
Нужно:

В ячейку A2 (Имя) поместить - абаывфывыя (С условием что длина этого текста будет заканчиваться перед первой попавшейся цифрой)
В ячейку А3 (День) поместить - 07 (С условием что перед 0 не стоит цифра и что после 7 не стоит цифра, иначе путается с текстом 2004)
В ячейку А4 (Месяц) поместить Март (РЕШЕНО)
В ячейку А5 (Год) поместить 2004 (РЕШЕНО)
В ячейку А6 (Формат) поместить .xlsm (РЕШЕНО)

Проблема только с Именем и Днем.

Решение для Месяца, года и формата следующее:
Код
=ЕСЛИ(ЕОШ(ПОИСК("Январь";A27));"";"Январь ") На примере месяца.

Автор - Jelvis
Дата добавления - 12.02.2019 в 15:17
китин Дата: Вторник, 12.02.2019, 15:18 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 5682
Репутация: 897 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Jelvis, не надо дублировать темы. Это тоже нарушение правил форума. Дубль закрыт


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеJelvis, не надо дублировать темы. Это тоже нарушение правил форума. Дубль закрыт

Автор - китин
Дата добавления - 12.02.2019 в 15:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск числа из ячейки с условием что перед ним не цифра (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!