Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Из всех данных, отобрать данные с определённым названием. - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из всех данных, отобрать данные с определённым названием. (Формулы/Formulas)
Из всех данных, отобрать данные с определённым названием.
stalber Дата: Вторник, 12.02.2019, 18:21 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 232
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Подскажите пожалуйста формулу.

Из всего списка данных необходимо вывести нужные названия и 6 ячеек справа от этих названий.

Не массивная формула нужна.
К сообщению приложен файл: vopros13022019.xlsx(8.1 Kb)


Сообщение отредактировал stalber - Вторник, 12.02.2019, 18:27
 
Ответить
СообщениеПодскажите пожалуйста формулу.

Из всего списка данных необходимо вывести нужные названия и 6 ячеек справа от этих названий.

Не массивная формула нужна.

Автор - stalber
Дата добавления - 12.02.2019 в 18:21
krosav4ig Дата: Вторник, 12.02.2019, 18:43 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1871
Репутация: 801 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Код
=ИНДЕКС(6:6;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ($C6:$AD6)/(ПОИСК($J$11:$J$12;$C6:$AD6)=1);"");ОТБР(СТОЛБЕЦ(G14)/7))+ОСТАТ(СТОЛБЕЦ(G14);7))


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщение
Код
=ИНДЕКС(6:6;НАИМЕНЬШИЙ(ЕСЛИОШИБКА(СТОЛБЕЦ($C6:$AD6)/(ПОИСК($J$11:$J$12;$C6:$AD6)=1);"");ОТБР(СТОЛБЕЦ(G14)/7))+ОСТАТ(СТОЛБЕЦ(G14);7))

Автор - krosav4ig
Дата добавления - 12.02.2019 в 18:43
stalber Дата: Вторник, 12.02.2019, 19:15 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 232
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
krosav4ig спасибо, но нужна не массивная формула. Из-за того что формул таких очень много ни одна сотня, проблематично внедрить будет.
 
Ответить
Сообщениеkrosav4ig спасибо, но нужна не массивная формула. Из-за того что формул таких очень много ни одна сотня, проблематично внедрить будет.

Автор - stalber
Дата добавления - 12.02.2019 в 19:15
Светлый Дата: Вторник, 12.02.2019, 19:45 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 939
Репутация: 230 ±
Замечаний: 0% ±

Excel 2010
проблематично внедрить будет.
А в чём проблема?Может быть, поможет.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 12.02.2019, 19:48
 
Ответить
Сообщение
проблематично внедрить будет.
А в чём проблема?Может быть, поможет.

Автор - Светлый
Дата добавления - 12.02.2019 в 19:45
stalber Дата: Вторник, 12.02.2019, 22:03 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 232
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Спасибо помогло. А что означает столбце а точнее ячейка G14, к чему она привязана?
 
Ответить
СообщениеСпасибо помогло. А что означает столбце а точнее ячейка G14, к чему она привязана?

Автор - stalber
Дата добавления - 12.02.2019 в 22:03
krosav4ig Дата: Вторник, 12.02.2019, 23:21 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1871
Репутация: 801 ±
Замечаний: 0% ±

Excel 2007,2010,2013
stalber,
Код
СТОЛБЕЦ(G14)=7


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениеstalber,
Код
СТОЛБЕЦ(G14)=7

Автор - krosav4ig
Дата добавления - 12.02.2019 в 23:21
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Из всех данных, отобрать данные с определённым названием. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!