Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Задачка - поиск релевантных значений, где впр не справляется - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Задачка - поиск релевантных значений, где впр не справляется (Формулы/Formulas)
Задачка - поиск релевантных значений, где впр не справляется
Goshakatarakta Дата: Четверг, 14.02.2019, 22:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
В прикрепленном документе задачка расписана более подробно. Если в общем, то суть в том, чтобы сгруппировать данные по определенному критерию. Данные представлены списком фраз. Критерий - содержащееся в фразах слова.
Дооолго пытался играть длиной строки, макросами, впр и прочим, но мне ощутимо не хватает опыта :'(
Буду очень благодарен за помощь, коллеги yes
К сообщению приложен файл: 1839097.xlsx(12.2 Kb)


Hola!
 
Ответить
СообщениеВ прикрепленном документе задачка расписана более подробно. Если в общем, то суть в том, чтобы сгруппировать данные по определенному критерию. Данные представлены списком фраз. Критерий - содержащееся в фразах слова.
Дооолго пытался играть длиной строки, макросами, впр и прочим, но мне ощутимо не хватает опыта :'(
Буду очень благодарен за помощь, коллеги yes

Автор - Goshakatarakta
Дата добавления - 14.02.2019 в 22:58
_Boroda_ Дата: Пятница, 15.02.2019, 00:41 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15020
Репутация: 5929 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Если групп не больше 9 (как у Вас в примере), то можно так
Код
=ПОДСТАВИТЬ(СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(C$3:C$9;D3))*10^(ЧСТРОК(C$3:C$9)-СТРОКА(C$1:C$7))*СТРОКА(C$1:C$7));0;)

Код
=ПОДСТАВИТЬ(СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(C$3:C$9;D3))*10^B$3:B$9*B$3:B$9);0;)


* Окончания в искомых словах убрал
К сообщению приложен файл: 1839097_1.xlsx(12.5 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеЕсли групп не больше 9 (как у Вас в примере), то можно так
Код
=ПОДСТАВИТЬ(СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(C$3:C$9;D3))*10^(ЧСТРОК(C$3:C$9)-СТРОКА(C$1:C$7))*СТРОКА(C$1:C$7));0;)

Код
=ПОДСТАВИТЬ(СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(C$3:C$9;D3))*10^B$3:B$9*B$3:B$9);0;)


* Окончания в искомых словах убрал

Автор - _Boroda_
Дата добавления - 15.02.2019 в 00:41
Светлый Дата: Пятница, 15.02.2019, 06:13 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 1072
Репутация: 274 ±
Замечаний: 0% ±

Excel 2010
Как вариант. Массивная:
Код
=ЕСЛИОШИБКА(МИН(ЕСЛИ(ЕОШ(ПОИСК(C$3:C$9;D3));"";B$3:B$9));"")
Если надо несколько групп:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК(C$3:C$9;D3));"";B$3:B$9);1);"")&ЕСЛИОШИБКА(", "&НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК(C$3:C$9;D3));"";B$3:B$9);2);"")
*А можно вправо растянуть на несколько ячеек:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($C$3:$C$9;$D3));"";$B$3:$B$9);СТОЛБЕЦ(A3));"")


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Пятница, 15.02.2019, 06:20
 
Ответить
СообщениеКак вариант. Массивная:
Код
=ЕСЛИОШИБКА(МИН(ЕСЛИ(ЕОШ(ПОИСК(C$3:C$9;D3));"";B$3:B$9));"")
Если надо несколько групп:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК(C$3:C$9;D3));"";B$3:B$9);1);"")&ЕСЛИОШИБКА(", "&НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК(C$3:C$9;D3));"";B$3:B$9);2);"")
*А можно вправо растянуть на несколько ячеек:
Код
=ЕСЛИОШИБКА(НАИМЕНЬШИЙ(ЕСЛИ(ЕОШ(ПОИСК($C$3:$C$9;$D3));"";$B$3:$B$9);СТОЛБЕЦ(A3));"")

Автор - Светлый
Дата добавления - 15.02.2019 в 06:13
Goshakatarakta Дата: Пятница, 15.02.2019, 11:11 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем большое спасибо, сейчас буду тестировать)
Очень надеюсь, что сегодня еще до обеда постигну успех hands


Hola!
 
Ответить
СообщениеВсем большое спасибо, сейчас буду тестировать)
Очень надеюсь, что сегодня еще до обеда постигну успех hands

Автор - Goshakatarakta
Дата добавления - 15.02.2019 в 11:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Задачка - поиск релевантных значений, где впр не справляется (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!