Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычесть из последнего числа предыдущее (число 0 игнорируем) - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычесть из последнего числа предыдущее (число 0 игнорируем) (Формулы/Formulas)
Вычесть из последнего числа предыдущее (число 0 игнорируем)
stalber Дата: Суббота, 16.02.2019, 16:37 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 261
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Добрый день, подскажите пожалуйста формулу.

Вычесть из последнего числа (оно не может быть 0) предыдущее (которое тоже не может быть 0).
А затем из полученных данных, вывести 10 последних чисел.

Извините пожалуйста за формулировку, не представляю возможности как сформулировать тему. Файл прикрепил, на примере проще показать, что именно мне нужно.
К сообщению приложен файл: vopros16022019.xlsx(9.3 Kb)
 
Ответить
СообщениеДобрый день, подскажите пожалуйста формулу.

Вычесть из последнего числа (оно не может быть 0) предыдущее (которое тоже не может быть 0).
А затем из полученных данных, вывести 10 последних чисел.

Извините пожалуйста за формулировку, не представляю возможности как сформулировать тему. Файл прикрепил, на примере проще показать, что именно мне нужно.

Автор - stalber
Дата добавления - 16.02.2019 в 16:37
vikttur Дата: Суббота, 16.02.2019, 16:42 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Для F5
Код
=ЕСЛИ(B5;B5-ПРОСМОТР(9E+307;$B$1:B3);)
 
Ответить
СообщениеДля F5
Код
=ЕСЛИ(B5;B5-ПРОСМОТР(9E+307;$B$1:B3);)

Автор - vikttur
Дата добавления - 16.02.2019 в 16:42
stalber Дата: Суббота, 16.02.2019, 16:58 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 261
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Vikttur не совсем понял действие данной формулы, я вставил её в F5 и опустил донизу, но там числа другие появились в отличие от оригинальных.
 
Ответить
СообщениеVikttur не совсем понял действие данной формулы, я вставил её в F5 и опустил донизу, но там числа другие появились в отличие от оригинальных.

Автор - stalber
Дата добавления - 16.02.2019 в 16:58
vikttur Дата: Суббота, 16.02.2019, 17:05 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Да, извините, в этой задаче такой вариант неприменим. Этот берите:
Код
=ЕСЛИ(B5;B5-ПРОСМОТР(2;1/($B$1:B3<>0);$B$1:B3);)


Сообщение отредактировал vikttur - Суббота, 16.02.2019, 17:05
 
Ответить
СообщениеДа, извините, в этой задаче такой вариант неприменим. Этот берите:
Код
=ЕСЛИ(B5;B5-ПРОСМОТР(2;1/($B$1:B3<>0);$B$1:B3);)

Автор - vikttur
Дата добавления - 16.02.2019 в 17:05
stalber Дата: Суббота, 16.02.2019, 17:27 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 261
Репутация: 7 ±
Замечаний: 0% ±

Excel 2007
Благодарю.

Подскажите пожалуйста ещё как вывести из данных полученных числах, последние самые нижние 10 чисел из столбца G (0 не учитывается, он пропускается).
Пример то что нужно увидеть в столбце J
К сообщению приложен файл: vopros160220192.xlsx(10.2 Kb)
 
Ответить
СообщениеБлагодарю.

Подскажите пожалуйста ещё как вывести из данных полученных числах, последние самые нижние 10 чисел из столбца G (0 не учитывается, он пропускается).
Пример то что нужно увидеть в столбце J

Автор - stalber
Дата добавления - 16.02.2019 в 17:27
vikttur Дата: Суббота, 16.02.2019, 17:33 | Сообщение № 6
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Это другая тема
 
Ответить
СообщениеЭто другая тема

Автор - vikttur
Дата добавления - 16.02.2019 в 17:33
krosav4ig Дата: Суббота, 16.02.2019, 17:37 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 2148
Репутация: 893 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Без вычисления столбца F массивная формула
Код
=СУММ(ИНДЕКС(B$1:B$99;НАИМЕНЬШИЙ(9^9^(B$1:B$99=0)*СТРОКА(B$1:B$99);Ч(ИНДЕКС(СЧЁТЕСЛИ(B:B;">0")-10+СТРОКА(J1)-{1;0};;))))*{-1;1})
К сообщению приложен файл: 2439803.xlsx(10.8 Kb)


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
СообщениеБез вычисления столбца F массивная формула
Код
=СУММ(ИНДЕКС(B$1:B$99;НАИМЕНЬШИЙ(9^9^(B$1:B$99=0)*СТРОКА(B$1:B$99);Ч(ИНДЕКС(СЧЁТЕСЛИ(B:B;">0")-10+СТРОКА(J1)-{1;0};;))))*{-1;1})

Автор - krosav4ig
Дата добавления - 16.02.2019 в 17:37
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычесть из последнего числа предыдущее (число 0 игнорируем) (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!