Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как посчитать количество четных и не четных цифр - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать количество четных и не четных цифр (Формулы/Formulas)
Как посчитать количество четных и не четных цифр
928-922 Дата: Среда, 20.02.2019, 16:33 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день! Подскажите пожалуйста, как посчитать количество четных и не четных цифр в одной строке, чтоб они выводились в 2 новые ячейки ? Одна будет с количеством четных цифр другая с количеством не четных, в основной таблице будут ещё пустые ячейки . Пример во вложении. Спасибо
К сообщению приложен файл: 6342792.xlsx(8.8 Kb)


Сообщение отредактировал 928-922 - Среда, 20.02.2019, 17:09
 
Ответить
СообщениеДобрый день! Подскажите пожалуйста, как посчитать количество четных и не четных цифр в одной строке, чтоб они выводились в 2 новые ячейки ? Одна будет с количеством четных цифр другая с количеством не четных, в основной таблице будут ещё пустые ячейки . Пример во вложении. Спасибо

Автор - 928-922
Дата добавления - 20.02.2019 в 16:33
_Boroda_ Дата: Среда, 20.02.2019, 16:44 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14954
Репутация: 5916 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Файл не приложился
Варианты ответов
Код
=СУММПРОИЗВ(--ЕНЕЧЁТ(-A2:K2))
Код
=СЧЁТ(A2:K2)-H6


Ниже формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter
Код
=СЧЁТ(1/ОСТАТ(A2:K2;2))
Код
=СЧЁТ(1/НЕ(ОСТАТ(A2:K2;2))/A2:K2)

Еще нечетные (четные лучше всего разницей - см. формулу 2)
Код
=СЧЁТ(1/(ОКРУГЛТ(+A2:K2;2)<>A2:K2))

Код
=СЧЁТ(ПОИСК(",";A2:K2/2))

Для любого разделителя дробной части
Код
=СЧЁТ(ПОИСК(ПСТР(1/2;2;1);A2:K2/2))
К сообщению приложен файл: 48149769.xlsm(8.6 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеФайл не приложился
Варианты ответов
Код
=СУММПРОИЗВ(--ЕНЕЧЁТ(-A2:K2))
Код
=СЧЁТ(A2:K2)-H6


Ниже формулы массива. Вводятся одновременным нажатием Ctrl+Shift+Enter
Код
=СЧЁТ(1/ОСТАТ(A2:K2;2))
Код
=СЧЁТ(1/НЕ(ОСТАТ(A2:K2;2))/A2:K2)

Еще нечетные (четные лучше всего разницей - см. формулу 2)
Код
=СЧЁТ(1/(ОКРУГЛТ(+A2:K2;2)<>A2:K2))

Код
=СЧЁТ(ПОИСК(",";A2:K2/2))

Для любого разделителя дробной части
Код
=СЧЁТ(ПОИСК(ПСТР(1/2;2;1);A2:K2/2))

Автор - _Boroda_
Дата добавления - 20.02.2019 в 16:44
928-922 Дата: Среда, 20.02.2019, 17:16 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_, Спасибо получилось hands
 
Ответить
Сообщение_Boroda_, Спасибо получилось hands

Автор - 928-922
Дата добавления - 20.02.2019 в 17:16
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как посчитать количество четных и не четных цифр (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!