Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подставлять значение на основании повторяющихся значений - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставлять значение на основании повторяющихся значений (Формулы/Formulas)
Подставлять значение на основании повторяющихся значений
fczen1t Дата: Воскресенье, 24.02.2019, 01:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, друзья! Постараюсь без воды, только самую суть :)

Есть задача по таблице:
В таблице по клиентам указаны суммы и кол-во продаж по месяцам. В некоторых месяцах могут быть нулевые значения если клиент не показывал активности. Можно ли выводить значение "умер" на основании 4х нулевых значение подряд? Есть ли такая формула, которая проверяла бы диапазон и постоянно отслеживала последние нулевые значения по количеству? И может ли эта формула проверять несколько диапазонов? т.е. значения по кол-ву продаж идут не подряд, а через 2 клетки, т.е. проверять на наличие нулевого значения нужно каждую 3ю клетку.

Вообще, эта таблица в "гугл таблицах", но если там не получится реализовать это, то перейду на экселевский документ.
К сообщению приложен файл: _1.ods(15.9 Kb)


Я смею все, что можно человеку... кто смеет больше, тот не человек

Сообщение отредактировал fczen1t - Воскресенье, 24.02.2019, 15:09
 
Ответить
СообщениеДобрый день, друзья! Постараюсь без воды, только самую суть :)

Есть задача по таблице:
В таблице по клиентам указаны суммы и кол-во продаж по месяцам. В некоторых месяцах могут быть нулевые значения если клиент не показывал активности. Можно ли выводить значение "умер" на основании 4х нулевых значение подряд? Есть ли такая формула, которая проверяла бы диапазон и постоянно отслеживала последние нулевые значения по количеству? И может ли эта формула проверять несколько диапазонов? т.е. значения по кол-ву продаж идут не подряд, а через 2 клетки, т.е. проверять на наличие нулевого значения нужно каждую 3ю клетку.

Вообще, эта таблица в "гугл таблицах", но если там не получится реализовать это, то перейду на экселевский документ.

Автор - fczen1t
Дата добавления - 24.02.2019 в 01:48
krosav4ig Дата: Воскресенье, 24.02.2019, 05:12 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2164
Репутация: 905 ±
Замечаний: 0% ±

Excel 2007,2010,2013
Можно ли
Можно
Есть ли такая формула
Есть
может ли эта формула проверять несколько диапазонов
Может


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщение
Можно ли
Можно
Есть ли такая формула
Есть
может ли эта формула проверять несколько диапазонов
Может

Автор - krosav4ig
Дата добавления - 24.02.2019 в 05:12
fczen1t Дата: Воскресенье, 24.02.2019, 13:12 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
krosav4ig, спасибо) это уже вселяет надежду) Вы подскажите написание этих формул?


Я смею все, что можно человеку... кто смеет больше, тот не человек
 
Ответить
Сообщениеkrosav4ig, спасибо) это уже вселяет надежду) Вы подскажите написание этих формул?

Автор - fczen1t
Дата добавления - 24.02.2019 в 13:12
Nic70y Дата: Воскресенье, 24.02.2019, 13:59 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 5601
Репутация: 1224 ±
Замечаний: 0% ±

ru13;10;03
fczen1t, Вы бы файл приложили.


ЯД(poison) 41001841029809
 
Ответить
Сообщениеfczen1t, Вы бы файл приложили.

Автор - Nic70y
Дата добавления - 24.02.2019 в 13:59
fczen1t Дата: Воскресенье, 24.02.2019, 15:11 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, приложил)


Я смею все, что можно человеку... кто смеет больше, тот не человек
 
Ответить
СообщениеNic70y, приложил)

Автор - fczen1t
Дата добавления - 24.02.2019 в 15:11
Nic70y Дата: Воскресенье, 24.02.2019, 16:29 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 5601
Репутация: 1224 ±
Замечаний: 0% ±

ru13;10;03
вдруг правильно
Код
=ЕСЛИОШИБКА(ЕСЛИ(МАКС(СТОЛБЕЦ(F3:AR3))-НАИБОЛЬШИЙ(ЕСЛИ(ЕСЛИ(F$2:AR$2="Кол-во";F3:AR3)=0;СТОЛБЕЦ(F3:AR3));4)=9;"хана";"норм");"норм")
К сообщению приложен файл: 5222150.ods(8.4 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениевдруг правильно
Код
=ЕСЛИОШИБКА(ЕСЛИ(МАКС(СТОЛБЕЦ(F3:AR3))-НАИБОЛЬШИЙ(ЕСЛИ(ЕСЛИ(F$2:AR$2="Кол-во";F3:AR3)=0;СТОЛБЕЦ(F3:AR3));4)=9;"хана";"норм");"норм")

Автор - Nic70y
Дата добавления - 24.02.2019 в 16:29
fczen1t Дата: Воскресенье, 24.02.2019, 16:51 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, благодарю) Подскажите, а что в этой формуле за значение 9?


Я смею все, что можно человеку... кто смеет больше, тот не человек
 
Ответить
СообщениеNic70y, благодарю) Подскажите, а что в этой формуле за значение 9?

Автор - fczen1t
Дата добавления - 24.02.2019 в 16:51
Nic70y Дата: Воскресенье, 24.02.2019, 16:56 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 5601
Репутация: 1224 ±
Замечаний: 0% ±

ru13;10;03
разница между последним и нулевым 4 (с краю) столбцами.


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Воскресенье, 24.02.2019, 16:57
 
Ответить
Сообщениеразница между последним и нулевым 4 (с краю) столбцами.

Автор - Nic70y
Дата добавления - 24.02.2019 в 16:56
krosav4ig Дата: Воскресенье, 24.02.2019, 18:00 | Сообщение № 9
Группа: Друзья
Ранг: Старожил
Сообщений: 2164
Репутация: 905 ±
Замечаний: 0% ±

Excel 2007,2010,2013
может так?
для столбца AS
Код
=(СТОЛБЕЦ()-ПОИСКПОЗ(2;1/$A3:AR3)-1)/3>=4


email:krosav4ig26@gmail.com WMR R207627035142 WMZ Z821145374535 ЯД 410012026478460
 
Ответить
Сообщениеможет так?
для столбца AS
Код
=(СТОЛБЕЦ()-ПОИСКПОЗ(2;1/$A3:AR3)-1)/3>=4

Автор - krosav4ig
Дата добавления - 24.02.2019 в 18:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подставлять значение на основании повторяющихся значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!