Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вывод времени смены по условию - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод времени смены по условию (Формулы/Formulas)
Вывод времени смены по условию
gs1905 Дата: Среда, 27.02.2019, 11:05 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Всем привет. Только начинаю осваивать эту довольно-таки интересную программу. Такие условия:
Имеются две смены - дневная и ночная. Первая (смена "am") начинается от 08:00 AM и длится до 06:00 PM, вторая (ночная - "pm") от 06:00 PM до 03:00 AM.
Вопрос: как сделать так, чтобы при ручном вводе (допустим, "am") рядом с фамилией сотрудника в двух последующих ячейках (C2: D2) автоматически появлялись заданные временные интервалы?

P.S. вот на скрине примерно тот результат, которого мне хотелось бы добиться. Сам я сделал всё, скорее всего, максимально топорно. Повторюсь, нужно чтобы после введения am, в двух последующих ячейках (справа) появлялись данные, которые соответствуют выбранной смене (без лишних телодвижений).
К сообщению приложен файл: 2876193.jpg(56.1 Kb) · 8253986.xlsx(9.5 Kb)


Сообщение отредактировал gs1905 - Среда, 27.02.2019, 11:19
 
Ответить
СообщениеВсем привет. Только начинаю осваивать эту довольно-таки интересную программу. Такие условия:
Имеются две смены - дневная и ночная. Первая (смена "am") начинается от 08:00 AM и длится до 06:00 PM, вторая (ночная - "pm") от 06:00 PM до 03:00 AM.
Вопрос: как сделать так, чтобы при ручном вводе (допустим, "am") рядом с фамилией сотрудника в двух последующих ячейках (C2: D2) автоматически появлялись заданные временные интервалы?

P.S. вот на скрине примерно тот результат, которого мне хотелось бы добиться. Сам я сделал всё, скорее всего, максимально топорно. Повторюсь, нужно чтобы после введения am, в двух последующих ячейках (справа) появлялись данные, которые соответствуют выбранной смене (без лишних телодвижений).

Автор - gs1905
Дата добавления - 27.02.2019 в 11:05
_Boroda_ Дата: Среда, 27.02.2019, 11:11 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума. Поконкретнее как-то нужно, типа "Вывод времени смены по условию"
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
Сообщение- Прочитайте Правила форума
- Исправьте название темы согласно п.2 Правил форума. Поконкретнее как-то нужно, типа "Вывод времени смены по условию"
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 100кб согласно п.3 Правил форума

Автор - _Boroda_
Дата добавления - 27.02.2019 в 11:11
gs1905 Дата: Среда, 27.02.2019, 11:20 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_,
Спасибо большое за помощь с правильным оформлением темы. Исправил недочёты.
 
Ответить
Сообщение_Boroda_,
Спасибо большое за помощь с правильным оформлением темы. Исправил недочёты.

Автор - gs1905
Дата добавления - 27.02.2019 в 11:20
_Boroda_ Дата: Среда, 27.02.2019, 11:24 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=ЕСЛИ(B2="am";8/24;ЕСЛИ(B2="pm";18/24;""))

Код
=ЕСЛИ(B2="am";18/24;ЕСЛИ(B2="pm";3/24;""))

И список выпадающий в столбец В добавил Вам (Данные - Проверка данных)
К сообщению приложен файл: 8253986_1.xlsx(10.3 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=ЕСЛИ(B2="am";8/24;ЕСЛИ(B2="pm";18/24;""))

Код
=ЕСЛИ(B2="am";18/24;ЕСЛИ(B2="pm";3/24;""))

И список выпадающий в столбец В добавил Вам (Данные - Проверка данных)

Автор - _Boroda_
Дата добавления - 27.02.2019 в 11:24
gs1905 Дата: Среда, 27.02.2019, 11:32 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_,
Да, именно то, что и нужно было!
Спасибо вам.
А эту формулу только вручную можно вводить или имеется инструмент, куда просто нужно ввести значения?
 
Ответить
Сообщение_Boroda_,
Да, именно то, что и нужно было!
Спасибо вам.
А эту формулу только вручную можно вводить или имеется инструмент, куда просто нужно ввести значения?

Автор - gs1905
Дата добавления - 27.02.2019 в 11:32
_Boroda_ Дата: Среда, 27.02.2019, 11:36 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для простых формул есть кнопка fx слева наверху около строки формул, но обычно вручную вводят. Вы можете скопировать из моего поста и вставить к себе


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля простых формул есть кнопка fx слева наверху около строки формул, но обычно вручную вводят. Вы можете скопировать из моего поста и вставить к себе

Автор - _Boroda_
Дата добавления - 27.02.2019 в 11:36
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вывод времени смены по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!