Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос столбца в другую таблицу в зависимости от названия - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос столбца в другую таблицу в зависимости от названия (Формулы/Formulas)
Перенос столбца в другую таблицу в зависимости от названия
justice_09 Дата: Воскресенье, 03.03.2019, 13:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Помогите, пожалуйста, с формулой или подскажите оператор.
Есть столбец А. А1 название столбца. Есть 2 столбца D, E с названиями в D1, E1.
Необходимо переносить весь столбец D или E в А, если название A1 совпадает с названием в D1 или E1.
К сообщению приложен файл: 2636929.xlsx(9.0 Kb)


Сообщение отредактировал justice_09 - Воскресенье, 03.03.2019, 13:40
 
Ответить
СообщениеПомогите, пожалуйста, с формулой или подскажите оператор.
Есть столбец А. А1 название столбца. Есть 2 столбца D, E с названиями в D1, E1.
Необходимо переносить весь столбец D или E в А, если название A1 совпадает с названием в D1 или E1.

Автор - justice_09
Дата добавления - 03.03.2019 в 13:39
Nic70y Дата: Воскресенье, 03.03.2019, 13:44 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 5524
Репутация: 1203 ±
Замечаний: 0% ±

ru13;10;03
так красивее
Код
=ИНДЕКС(D:E;;ПОИСКПОЗ(A$1;D$1:E$1;))
а так правильнее
Код
=ИНДЕКС(D:E;СТРОКА();ПОИСКПОЗ(A$1;D$1:E$1;))
а так положено
Код
=ЕСЛИ(A$1=D$1;D2;ЕСЛИ(A$1=E$1;E2;""))


ЯД(poison) 41001841029809
 
Ответить
Сообщениетак красивее
Код
=ИНДЕКС(D:E;;ПОИСКПОЗ(A$1;D$1:E$1;))
а так правильнее
Код
=ИНДЕКС(D:E;СТРОКА();ПОИСКПОЗ(A$1;D$1:E$1;))
а так положено
Код
=ЕСЛИ(A$1=D$1;D2;ЕСЛИ(A$1=E$1;E2;""))

Автор - Nic70y
Дата добавления - 03.03.2019 в 13:44
justice_09 Дата: Воскресенье, 03.03.2019, 13:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Nic70y, Спасибо, четко!
 
Ответить
СообщениеNic70y, Спасибо, четко!

Автор - justice_09
Дата добавления - 03.03.2019 в 13:56
Che79 Дата: Воскресенье, 03.03.2019, 16:40 | Сообщение № 4
Группа: Проверенные
Ранг: Старожил
Сообщений: 1367
Репутация: 244 ±
Замечаний: 0% ±

Excel 2013, 365
а так... так себе :D
Код
=ЕСЛИОШИБКА(ГПР(A$1;D:E;СТРОКА(););"")


Делай нормально и будет нормально!
 
Ответить
Сообщениеа так... так себе :D
Код
=ЕСЛИОШИБКА(ГПР(A$1;D:E;СТРОКА(););"")

Автор - Che79
Дата добавления - 03.03.2019 в 16:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос столбца в другую таблицу в зависимости от названия (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!