Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух таблиц по 2 значениям с соблюдением условий - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух таблиц по 2 значениям с соблюдением условий (Формулы/Formulas)
Сравнение двух таблиц по 2 значениям с соблюдением условий
AnastasiyaBr Дата: Понедельник, 04.03.2019, 00:32 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте
Нужно сравнить 2 таблицы по двум значениям. Например: если значение ячейки D2 содержится в столбце B:B и значение ячейки C2 содержится в столбце А:А, то в ячейку Е2 нужно отобразить "внесен". Если же хотя бы одно условие не выполняется, как в 16 строке, то в ячейке должно быть отображено "не внесен"
К сообщению приложен файл: 7684840.xls(31.0 Kb)
 
Ответить
СообщениеЗдравствуйте
Нужно сравнить 2 таблицы по двум значениям. Например: если значение ячейки D2 содержится в столбце B:B и значение ячейки C2 содержится в столбце А:А, то в ячейку Е2 нужно отобразить "внесен". Если же хотя бы одно условие не выполняется, как в 16 строке, то в ячейке должно быть отображено "не внесен"

Автор - AnastasiyaBr
Дата добавления - 04.03.2019 в 00:32
vikttur Дата: Понедельник, 04.03.2019, 00:35 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Код
=ЕСЛИ(И(СЧЁТЕСЛИ(B:B;D2);СЧЁТЕСЛИ(A:A;C2));"внесен";"")
 
Ответить
Сообщение
Код
=ЕСЛИ(И(СЧЁТЕСЛИ(B:B;D2);СЧЁТЕСЛИ(A:A;C2));"внесен";"")

Автор - vikttur
Дата добавления - 04.03.2019 в 00:35
AnastasiyaBr Дата: Понедельник, 04.03.2019, 00:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Если в А7 я меняю значение на 62, то "внесен" так и остается
 
Ответить
СообщениеЕсли в А7 я меняю значение на 62, то "внесен" так и остается

Автор - AnastasiyaBr
Дата добавления - 04.03.2019 в 00:43
vikttur Дата: Понедельник, 04.03.2019, 00:58 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 2921
Репутация: 525 ±
Замечаний: 0% ±

Потому что значение 61 есть в столбце А. По Вашему условию:
Цитата
значение ячейки C2 содержится в столбце А:А

Если нужно сравнивать только по строке. то так и сравнивайте - не считать в столбце А и В, а сравнивать два значения и два другх значения.


Сообщение отредактировал vikttur - Понедельник, 04.03.2019, 00:59
 
Ответить
СообщениеПотому что значение 61 есть в столбце А. По Вашему условию:
Цитата
значение ячейки C2 содержится в столбце А:А

Если нужно сравнивать только по строке. то так и сравнивайте - не считать в столбце А и В, а сравнивать два значения и два другх значения.

Автор - vikttur
Дата добавления - 04.03.2019 в 00:58
AnastasiyaBr Дата: Понедельник, 04.03.2019, 01:01 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Все поняла, спасибо большое!
 
Ответить
СообщениеВсе поняла, спасибо большое!

Автор - AnastasiyaBr
Дата добавления - 04.03.2019 в 01:01
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух таблиц по 2 значениям с соблюдением условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!