Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Суммирование строк без точек под ними - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование строк без точек под ними (Формулы/Formulas)
Суммирование строк без точек под ними
Anis625 Дата: Четверг, 07.03.2019, 00:05 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
Добрый вечер, тем кто не спит.

Давняя задачка, к которой с определенной периодичностью пытаюсь решить. Увы пока ларчик не раскрылся. Даже принципиальное не обращался на форум чтобы попробовать самостоятельно решить. Сдаюсь. Нужен совет.

Таблица: № п.п. и сумма. Обычная нумерация строк 1,2,3,... Но имеют место быть случаи когда добавляется строка с подпунктом, т.е. верхняя строка 1 (без точки), новая строка 1.1. (с точками).

Суммирую в двух вариантах:
1) Все строки без точек, тут все получается:
[vba]
Код
=СУММЕСЛИ(A3:A8;"<>"&"*.*";B3:B8)
[/vba]

2) Все строки с точками в номере по порядку+строки без точек у которых нет под ними номера с точкой. Все что знаю перепробовал.

Есть рецепт "приготовления" у такого типа задачки?
К сообщению приложен файл: __.xlsx(8.8 Kb)


Сообщение отредактировал Anis625 - Четверг, 07.03.2019, 00:07
 
Ответить
СообщениеДобрый вечер, тем кто не спит.

Давняя задачка, к которой с определенной периодичностью пытаюсь решить. Увы пока ларчик не раскрылся. Даже принципиальное не обращался на форум чтобы попробовать самостоятельно решить. Сдаюсь. Нужен совет.

Таблица: № п.п. и сумма. Обычная нумерация строк 1,2,3,... Но имеют место быть случаи когда добавляется строка с подпунктом, т.е. верхняя строка 1 (без точки), новая строка 1.1. (с точками).

Суммирую в двух вариантах:
1) Все строки без точек, тут все получается:
[vba]
Код
=СУММЕСЛИ(A3:A8;"<>"&"*.*";B3:B8)
[/vba]

2) Все строки с точками в номере по порядку+строки без точек у которых нет под ними номера с точкой. Все что знаю перепробовал.

Есть рецепт "приготовления" у такого типа задачки?

Автор - Anis625
Дата добавления - 07.03.2019 в 00:05
gling Дата: Четверг, 07.03.2019, 00:44 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1925
Репутация: 480 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте так
Код
=СУММЕСЛИ(A4:A9;"<>*.*";C3:C8)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте. Попробуйте так
Код
=СУММЕСЛИ(A4:A9;"<>*.*";C3:C8)

Автор - gling
Дата добавления - 07.03.2019 в 00:44
Anis625 Дата: Четверг, 07.03.2019, 00:56 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
gling,
Я пробовал вариант со смещением вниз суммируемого столбца, а такой вариант я не пробовал =)

Класс. Очередное знание в копилку знаний. Спасибо Вам большое. Все гениальное просто ... исключение - макросы =)
 
Ответить
Сообщениеgling,
Я пробовал вариант со смещением вниз суммируемого столбца, а такой вариант я не пробовал =)

Класс. Очередное знание в копилку знаний. Спасибо Вам большое. Все гениальное просто ... исключение - макросы =)

Автор - Anis625
Дата добавления - 07.03.2019 в 00:56
gling Дата: Четверг, 07.03.2019, 05:37 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1925
Репутация: 480 ±
Замечаний: 0% ±

2010
=СУММЕСЛИ(A4:A9;"<>*.*";C3:C8)
Эта формула работает не правильно, если подпунктов два и более. Попробуйте такую формулу
Код
=СУММЕСЛИМН(C3:C8;A3:A8;"<>*.*";A4:A9;"<>*.*")+СУММЕСЛИ(A3:A8;"*.*";C3:C8)


ЯД-41001506838083

Сообщение отредактировал gling - Четверг, 07.03.2019, 05:39
 
Ответить
Сообщение
=СУММЕСЛИ(A4:A9;"<>*.*";C3:C8)
Эта формула работает не правильно, если подпунктов два и более. Попробуйте такую формулу
Код
=СУММЕСЛИМН(C3:C8;A3:A8;"<>*.*";A4:A9;"<>*.*")+СУММЕСЛИ(A3:A8;"*.*";C3:C8)

Автор - gling
Дата добавления - 07.03.2019 в 05:37
_Boroda_ Дата: Четверг, 07.03.2019, 09:35 | Сообщение № 5
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14954
Репутация: 5916 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Для произвольного количества подпунктов и произвольной степени подпунктизации
Код
=СУММПРОИЗВ(ЕНД(ПОИСКПОЗ(ПОДСТАВИТЬ(A3:A11&".?*";"..";".");A3:A11;))*C3:C11)
К сообщению приложен файл: -40-1.xlsx(9.0 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеДля произвольного количества подпунктов и произвольной степени подпунктизации
Код
=СУММПРОИЗВ(ЕНД(ПОИСКПОЗ(ПОДСТАВИТЬ(A3:A11&".?*";"..";".");A3:A11;))*C3:C11)

Автор - _Boroda_
Дата добавления - 07.03.2019 в 09:35
bmv98rus Дата: Четверг, 07.03.2019, 10:29 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2135
Репутация: 360 ±
Замечаний: 20% ±

Excel 2013/2016
Для указанного примера
Код
=SUM((COUNTIF(A3:A8;A3:A8&".*")=0)*C3:C8)

для произвольного количества подпунктов и произвольной степени подпунктизации Понять бы что нужно и что не нужно суммировать.


Замечательный медведь, процентов на 20.
 
Ответить
СообщениеДля указанного примера
Код
=SUM((COUNTIF(A3:A8;A3:A8&".*")=0)*C3:C8)

для произвольного количества подпунктов и произвольной степени подпунктизации Понять бы что нужно и что не нужно суммировать.

Автор - bmv98rus
Дата добавления - 07.03.2019 в 10:29
gling Дата: Четверг, 07.03.2019, 12:13 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1925
Репутация: 480 ±
Замечаний: 0% ±

2010
Понять бы что нужно

Все строки с точками в номере по порядку+строки без точек у которых нет под ними номера с точкой
Сам "родитель" подпункта в этом случае не берется. Или по другому, суммируются все подпункты и данные против номера у которого нет подпункта. Я понял так.


ЯД-41001506838083
 
Ответить
Сообщение
Понять бы что нужно

Все строки с точками в номере по порядку+строки без точек у которых нет под ними номера с точкой
Сам "родитель" подпункта в этом случае не берется. Или по другому, суммируются все подпункты и данные против номера у которого нет подпункта. Я понял так.

Автор - gling
Дата добавления - 07.03.2019 в 12:13
Nic70y Дата: Четверг, 07.03.2019, 22:21 | Сообщение № 8
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5262
Репутация: 1143 ±
Замечаний: 0% ±

Excel 2013
массивная, так для разнообразия
Код
=СУММ(ЕСЛИ(ЕНД(ПОИСКПОЗ(A3:A8;--ЕСЛИ(ЕЧИСЛО(ПОИСК(".";A3:A9));ЛЕВБ(ПОДСТАВИТЬ(A3:A8;".";"   ");3));));B3:B8))

[p.s.]кто сломал тЭги?[/p.s.]


ЯД(poison) 41001841029809

Сообщение отредактировал Nic70y - Четверг, 07.03.2019, 22:26
 
Ответить
Сообщениемассивная, так для разнообразия
Код
=СУММ(ЕСЛИ(ЕНД(ПОИСКПОЗ(A3:A8;--ЕСЛИ(ЕЧИСЛО(ПОИСК(".";A3:A9));ЛЕВБ(ПОДСТАВИТЬ(A3:A8;".";"   ");3));));B3:B8))

[p.s.]кто сломал тЭги?[/p.s.]

Автор - Nic70y
Дата добавления - 07.03.2019 в 22:21
_Boroda_ Дата: Пятница, 08.03.2019, 15:18 | Сообщение № 9
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14954
Репутация: 5916 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Про теги продолжение здесь
http://www.excelworld.ru/forum/12-41046-1


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеПро теги продолжение здесь
http://www.excelworld.ru/forum/12-41046-1

Автор - _Boroda_
Дата добавления - 08.03.2019 в 15:18
Anis625 Дата: Воскресенье, 10.03.2019, 09:02 | Сообщение № 10
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
Эта формула работает не правильно, если подпунктов два и более. Попробуйте такую формулу


Беру эту формулу себе на вооружение. Не думал, что столько вариантов есть у решении данной задачки. Благодарю Вас
 
Ответить
Сообщение
Эта формула работает не правильно, если подпунктов два и более. Попробуйте такую формулу


Беру эту формулу себе на вооружение. Не думал, что столько вариантов есть у решении данной задачки. Благодарю Вас

Автор - Anis625
Дата добавления - 10.03.2019 в 09:02
Anis625 Дата: Воскресенье, 10.03.2019, 09:05 | Сообщение № 11
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
Для произвольного количества подпунктов и произвольной степени подпунктизации


Интересное решение =) в свою копилку. Таким подходом и не только эту задачку можно решать. Благодарю Вас.
 
Ответить
Сообщение
Для произвольного количества подпунктов и произвольной степени подпунктизации


Интересное решение =) в свою копилку. Таким подходом и не только эту задачку можно решать. Благодарю Вас.

Автор - Anis625
Дата добавления - 10.03.2019 в 09:05
Anis625 Дата: Воскресенье, 10.03.2019, 09:07 | Сообщение № 12
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
массивная, так для разнообразия


И правда массивная =) Ее отдельно поизучаю. С функцией ЛЕВБ ни разу не приходилось "общаться". Что-то новое для меня. Благодарю Вас.
 
Ответить
Сообщение
массивная, так для разнообразия


И правда массивная =) Ее отдельно поизучаю. С функцией ЛЕВБ ни разу не приходилось "общаться". Что-то новое для меня. Благодарю Вас.

Автор - Anis625
Дата добавления - 10.03.2019 в 09:07
Anis625 Дата: Воскресенье, 10.03.2019, 09:09 | Сообщение № 13
Группа: Проверенные
Ранг: Обитатель
Сообщений: 265
Репутация: 3 ±
Замечаний: 0% ±

Excel 2013
Я думал, что в Excel отлично разбираюсь. Но могу сказать, что я, наверно не скромно скажу, лучший по Excel в яслях. В старшей возрастной категорией с вами - я новичок =) Благодарю всех за варианты решения задачки =)
 
Ответить
СообщениеЯ думал, что в Excel отлично разбираюсь. Но могу сказать, что я, наверно не скромно скажу, лучший по Excel в яслях. В старшей возрастной категорией с вами - я новичок =) Благодарю всех за варианты решения задачки =)

Автор - Anis625
Дата добавления - 10.03.2019 в 09:09
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Суммирование строк без точек под ними (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!