Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/формула. ряд из диапазонов нечетных чисел - Страница 2 - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 2 из 2
  • «
  • 1
  • 2
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула. ряд из диапазонов нечетных чисел (Формулы/Formulas)
формула. ряд из диапазонов нечетных чисел
Artemon Дата: Вторник, 12.03.2019, 21:41 | Сообщение № 21
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, все ок, спасибо
 
Ответить
Сообщениеbmv98rus, все ок, спасибо

Автор - Artemon
Дата добавления - 12.03.2019 в 21:41
Artemon Дата: Четверг, 21.03.2019, 13:16 | Сообщение № 22
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, а можете переделать эту формулу только для четных диапазонов также, чтобы последний четный диапазон не учитывался
я так понял просто ЕЧЁТН поменять на ЕНЕЧЕТ не будет работать?
Код
=ЕСЛИ(ЕЧЁТН($A15);ЕСЛИОШИБКА(ПРОСМОТР(ПОИСКПОЗ(0;ОСТАТ($A16:$A$123;2););ВЫБОР({1:2:3};0;N$15+1;N$15+2);{"":2:1});"");"")&N17
 
Ответить
Сообщениеbmv98rus, а можете переделать эту формулу только для четных диапазонов также, чтобы последний четный диапазон не учитывался
я так понял просто ЕЧЁТН поменять на ЕНЕЧЕТ не будет работать?
Код
=ЕСЛИ(ЕЧЁТН($A15);ЕСЛИОШИБКА(ПРОСМОТР(ПОИСКПОЗ(0;ОСТАТ($A16:$A$123;2););ВЫБОР({1:2:3};0;N$15+1;N$15+2);{"":2:1});"");"")&N17

Автор - Artemon
Дата добавления - 21.03.2019 в 13:16
bmv98rus Дата: Четверг, 21.03.2019, 20:36 | Сообщение № 23
Группа: Проверенные
Ранг: Старожил
Сообщений: 2154
Репутация: 365 ±
Замечаний: 20% ±

Excel 2013/2016
Код
=IF(ISODD($A15);IFERROR(LOOKUP(MATCH(1;MOD($A16:$A$123;2););CHOOSE({1;2;3};0;N$15+1;N$15+2);{"";2;1});"");"")&N17
К сообщению приложен файл: Copy_of_713_2.xlsx(31.2 Kb)


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
Код
=IF(ISODD($A15);IFERROR(LOOKUP(MATCH(1;MOD($A16:$A$123;2););CHOOSE({1;2;3};0;N$15+1;N$15+2);{"";2;1});"");"")&N17

Автор - bmv98rus
Дата добавления - 21.03.2019 в 20:36
Artemon Дата: Четверг, 21.03.2019, 22:48 | Сообщение № 24
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, шикарно, спасибо!!!
 
Ответить
Сообщениеbmv98rus, шикарно, спасибо!!!

Автор - Artemon
Дата добавления - 21.03.2019 в 22:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » формула. ряд из диапазонов нечетных чисел (Формулы/Formulas)
  • Страница 2 из 2
  • «
  • 1
  • 2
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!