Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/В СЧЁТЕСЛИМН условие не 1 значение, а любое из диапазона - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В СЧЁТЕСЛИМН условие не 1 значение, а любое из диапазона (Формулы/Formulas)
В СЧЁТЕСЛИМН условие не 1 значение, а любое из диапазона
arxon Дата: Воскресенье, 10.03.2019, 17:58 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Здравствуйте.
Составил вот такую формулу:
Код
=СЧЁТЕСЛИМН(Лист1!$B:$B;$B5;Лист1!$E:$E;B$4)
Итого получаем число - количество упоминаний $B5 в диапазоне $B:$B.

А мне нужно получить число упоминаний всех значений ячеек $B5:$B999 в диапазоне $B:$B.

Был бы маленький диапазон $B5:$B7, я бы написал формулу
Код
=СУММ((СЧЁТЕСЛИМН(Лист1!$B:$B;$B5;Лист1!$E:$E;B$4))+(СЧЁТЕСЛИМН(Лист1!$B:$B;$B6;Лист1!$E:$E;B$4)+(СЧЁТЕСЛИМН(Лист1!$B:$B;$B7;Лист1!$E:$E;B$4))
но тут формула слишком длинная будет
думаю файл тут прикреплять необязательно?


Сообщение отредактировал arxon - Воскресенье, 10.03.2019, 18:34
 
Ответить
СообщениеЗдравствуйте.
Составил вот такую формулу:
Код
=СЧЁТЕСЛИМН(Лист1!$B:$B;$B5;Лист1!$E:$E;B$4)
Итого получаем число - количество упоминаний $B5 в диапазоне $B:$B.

А мне нужно получить число упоминаний всех значений ячеек $B5:$B999 в диапазоне $B:$B.

Был бы маленький диапазон $B5:$B7, я бы написал формулу
Код
=СУММ((СЧЁТЕСЛИМН(Лист1!$B:$B;$B5;Лист1!$E:$E;B$4))+(СЧЁТЕСЛИМН(Лист1!$B:$B;$B6;Лист1!$E:$E;B$4)+(СЧЁТЕСЛИМН(Лист1!$B:$B;$B7;Лист1!$E:$E;B$4))
но тут формула слишком длинная будет
думаю файл тут прикреплять необязательно?

Автор - arxon
Дата добавления - 10.03.2019 в 17:58
gling Дата: Воскресенье, 10.03.2019, 19:14 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1898
Репутация: 476 ±
Замечаний: 0% ±

2010
Здравствуйте. Попробуйте такую формулу
Код
=СУММПРОИЗВ(СЧЁТЕСЛИМН(Лист1!$B:$B;$B5:$B999;Лист1!$E:$E;B$4))
Как долго будет пересчитывать сказать не могу, смотря сколько у вас данных. Но лучше ограничить диапазоны $B:$B и $E:$E, типа B1:B10000 и E1:E10000.


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 10.03.2019, 19:24
 
Ответить
СообщениеЗдравствуйте. Попробуйте такую формулу
Код
=СУММПРОИЗВ(СЧЁТЕСЛИМН(Лист1!$B:$B;$B5:$B999;Лист1!$E:$E;B$4))
Как долго будет пересчитывать сказать не могу, смотря сколько у вас данных. Но лучше ограничить диапазоны $B:$B и $E:$E, типа B1:B10000 и E1:E10000.

Автор - gling
Дата добавления - 10.03.2019 в 19:14
arxon Дата: Воскресенье, 10.03.2019, 20:23 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
нет, так не получается. неадекватные числа выдает.
например: "83328" при том, что диапазон $B5:$B999 очистил, а в диапазоне $B:$B у меня всего 26тыс строк
 
Ответить
Сообщениенет, так не получается. неадекватные числа выдает.
например: "83328" при том, что диапазон $B5:$B999 очистил, а в диапазоне $B:$B у меня всего 26тыс строк

Автор - arxon
Дата добавления - 10.03.2019 в 20:23
gling Дата: Воскресенье, 10.03.2019, 20:49 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1898
Репутация: 476 ±
Замечаний: 0% ±

2010
а в диапазоне $B:$B у меня всего 26тыс строк
Это заполненных, а сколько пустых в В:В? Ведь формула ищет пустые ячейки раз В5:В999 очищен. Если ограничите диапазон 26 тыс.строк то больше и не насчитает, а В:В это до конца листа > 1 млн строк.


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 10.03.2019, 20:51
 
Ответить
Сообщение
а в диапазоне $B:$B у меня всего 26тыс строк
Это заполненных, а сколько пустых в В:В? Ведь формула ищет пустые ячейки раз В5:В999 очищен. Если ограничите диапазон 26 тыс.строк то больше и не насчитает, а В:В это до конца листа > 1 млн строк.

Автор - gling
Дата добавления - 10.03.2019 в 20:49
bmv98rus Дата: Воскресенье, 10.03.2019, 21:16 | Сообщение № 5
Группа: Проверенные
Ранг: Старожил
Сообщений: 1786
Репутация: 292 ±
Замечаний: 0% ±

Excel 2013/2016
arxon, Пример бы приложили все ж. в любом случае для СЧЁТЕСЛИМН вредно работать с целым столбцом.
 
Ответить
Сообщениеarxon, Пример бы приложили все ж. в любом случае для СЧЁТЕСЛИМН вредно работать с целым столбцом.

Автор - bmv98rus
Дата добавления - 10.03.2019 в 21:16
arxon Дата: Понедельник, 11.03.2019, 00:43 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 19
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
мне кажется теперь все нормально считается, если есть погрешность, то небольшая
Код
=СУММПРОИЗВ(СЧЁТЕСЛИМН(Лист1!$B$2:$B$50000;B$5:B$300;Лист1!$E$2:$E$50000;B$4))


спасибо за содействие!
 
Ответить
Сообщениемне кажется теперь все нормально считается, если есть погрешность, то небольшая
Код
=СУММПРОИЗВ(СЧЁТЕСЛИМН(Лист1!$B$2:$B$50000;B$5:B$300;Лист1!$E$2:$E$50000;B$4))


спасибо за содействие!

Автор - arxon
Дата добавления - 11.03.2019 в 00:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В СЧЁТЕСЛИМН условие не 1 значение, а любое из диапазона (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!