Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/СУММПРОИЗВ с фильтрацией строк - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с фильтрацией строк (Формулы/Formulas)
СУММПРОИЗВ с фильтрацией строк
kubuspb Дата: Вторник, 12.03.2019, 16:04 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день.
Не получается посчитать сумму произведений при выборе какого то одного объекта уборки каждый день.
Не могу сообразить как заставить считать только видимые после фильтрации ячейки.
Получается складывать их, используя промежуточные итоги, но не перемножить с ячейкой площадь уборки.
Подскажите пожалуйста, куда копать.
Спасибо!
К сообщению приложен файл: 6454159.xlsx(9.6 Kb)
 
Ответить
СообщениеДобрый день.
Не получается посчитать сумму произведений при выборе какого то одного объекта уборки каждый день.
Не могу сообразить как заставить считать только видимые после фильтрации ячейки.
Получается складывать их, используя промежуточные итоги, но не перемножить с ячейкой площадь уборки.
Подскажите пожалуйста, куда копать.
Спасибо!

Автор - kubuspb
Дата добавления - 12.03.2019 в 16:04
_Boroda_ Дата: Вторник, 12.03.2019, 16:08 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 14425
Репутация: 5774 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СУММПРОИЗВ(E3:E10;$C3:$C10;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;ДВССЫЛ("B"&СТРОКА(3:10))))

Код
=СУММПРОИЗВ($C3:$C10;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(E1;СТРОКА(3:10)-1;)))

Код
=СУММПРОИЗВ($C3:$C10;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;ДВССЫЛ("R"&СТРОКА(3:10)&"C";)))
К сообщению приложен файл: 6454159_1.xlsx(10.1 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СУММПРОИЗВ(E3:E10;$C3:$C10;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(3;ДВССЫЛ("B"&СТРОКА(3:10))))

Код
=СУММПРОИЗВ($C3:$C10;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(E1;СТРОКА(3:10)-1;)))

Код
=СУММПРОИЗВ($C3:$C10;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;ДВССЫЛ("R"&СТРОКА(3:10)&"C";)))

Автор - _Boroda_
Дата добавления - 12.03.2019 в 16:08
kubuspb Дата: Вторник, 12.03.2019, 16:31 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Спасибо!!!
Хватило первого варианта, но сохраню все три и пойду гуглить как так получается.


Сообщение отредактировал kubuspb - Вторник, 12.03.2019, 16:32
 
Ответить
СообщениеСпасибо!!!
Хватило первого варианта, но сохраню все три и пойду гуглить как так получается.

Автор - kubuspb
Дата добавления - 12.03.2019 в 16:31
Мир MS Excel » Вопросы и решения » Вопросы по Excel » СУММПРОИЗВ с фильтрацией строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!