Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск ближайшего числа в массиве - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшего числа в массиве (Формулы/Formulas)
Поиск ближайшего числа в массиве
ilyxa1234 Дата: Вторник, 12.03.2019, 21:34 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
имеется таблиц 11х10(не считая заголовки) и произвольное значение в ячейке А1, не могу додуматься как найти номер столбца ближайшего к А1 числа, подскажите пожалуйста как это сделать, не задействуя вспомогательные ячейки?
К сообщению приложен файл: 2955144.xls(26.5 Kb)
 
Ответить
Сообщениеимеется таблиц 11х10(не считая заголовки) и произвольное значение в ячейке А1, не могу додуматься как найти номер столбца ближайшего к А1 числа, подскажите пожалуйста как это сделать, не задействуя вспомогательные ячейки?

Автор - ilyxa1234
Дата добавления - 12.03.2019 в 21:34
Nic70y Дата: Вторник, 12.03.2019, 21:44 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 5262
Репутация: 1143 ±
Замечаний: 0% ±

Excel 2013
формула массива
Код
=ИНДЕКС(5:5;МИН(ЕСЛИ(МИН(ABS(E6:N16-A2))=ABS(E6:N16-A2);СТОЛБЕЦ(E6:N16))))
так нужно?
К сообщению приложен файл: 4035149.xls(27.5 Kb)


ЯД(poison) 41001841029809
 
Ответить
Сообщениеформула массива
Код
=ИНДЕКС(5:5;МИН(ЕСЛИ(МИН(ABS(E6:N16-A2))=ABS(E6:N16-A2);СТОЛБЕЦ(E6:N16))))
так нужно?

Автор - Nic70y
Дата добавления - 12.03.2019 в 21:44
bmv98rus Дата: Вторник, 12.03.2019, 21:46 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2135
Репутация: 360 ±
Замечаний: 20% ±

Excel 2013/2016
Код
=MIN(IF(ABS(E6:N16-A2)=MIN(ABS(E6:N16-A2));E5:N5))

тоже массивная


Замечательный медведь, процентов на 20.

Сообщение отредактировал bmv98rus - Вторник, 12.03.2019, 21:46
 
Ответить
Сообщение
Код
=MIN(IF(ABS(E6:N16-A2)=MIN(ABS(E6:N16-A2));E5:N5))

тоже массивная

Автор - bmv98rus
Дата добавления - 12.03.2019 в 21:46
ilyxa1234 Дата: Вторник, 12.03.2019, 22:28 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
формула массива

=ИНДЕКС(5:5;МИН(ЕСЛИ(МИН(ABS(E6:N16-A2))=ABS(E6:N16-A2);СТОЛБЕЦ(E6:N16))))
так нужно?

да, спасибо
 
Ответить
Сообщение
формула массива

=ИНДЕКС(5:5;МИН(ЕСЛИ(МИН(ABS(E6:N16-A2))=ABS(E6:N16-A2);СТОЛБЕЦ(E6:N16))))
так нужно?

да, спасибо

Автор - ilyxa1234
Дата добавления - 12.03.2019 в 22:28
ilyxa1234 Дата: Среда, 13.03.2019, 21:57 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
формула массива

=ИНДЕКС(5:5;МИН(ЕСЛИ(МИН(ABS(E6:N16-A2))=ABS(E6:N16-A2);СТОЛБЕЦ(E6:N16))))
так нужно?

а как вывести два ближайших числа между которыми находится А1?
 
Ответить
Сообщение
формула массива

=ИНДЕКС(5:5;МИН(ЕСЛИ(МИН(ABS(E6:N16-A2))=ABS(E6:N16-A2);СТОЛБЕЦ(E6:N16))))
так нужно?

а как вывести два ближайших числа между которыми находится А1?

Автор - ilyxa1234
Дата добавления - 13.03.2019 в 21:57
bmv98rus Дата: Среда, 13.03.2019, 22:28 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2135
Репутация: 360 ±
Замечаний: 20% ±

Excel 2013/2016
Код
=MAX(IF(MIN(IF(E6:N16<A2;A2-E6:N16))=A2-E6:N16;E6:N16))

Код
=MIN(IF(MIN(IF(A2<E6:N16;E6:N16-A2))=E6:N16-A2;E6:N16))


Замечательный медведь, процентов на 20.
 
Ответить
Сообщение
Код
=MAX(IF(MIN(IF(E6:N16<A2;A2-E6:N16))=A2-E6:N16;E6:N16))

Код
=MIN(IF(MIN(IF(A2<E6:N16;E6:N16-A2))=E6:N16-A2;E6:N16))

Автор - bmv98rus
Дата добавления - 13.03.2019 в 22:28
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск ближайшего числа в массиве (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!