Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение нескольких ячеек - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение нескольких ячеек (Формулы/Formulas)
Сравнение нескольких ячеек
sekii Дата: Среда, 13.03.2019, 14:13 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
Добрый день.
Подскажите, как сравнить несколько ячеек между собой?
Нужно отсеять из массива строки, где все значения одинаковые, а если хотя бы одно значение отличается от других - оставить эту строку.
Пример во вложении.
Спасибо.
К сообщению приложен файл: 3113165.xlsx(8.3 Kb)
 
Ответить
СообщениеДобрый день.
Подскажите, как сравнить несколько ячеек между собой?
Нужно отсеять из массива строки, где все значения одинаковые, а если хотя бы одно значение отличается от других - оставить эту строку.
Пример во вложении.
Спасибо.

Автор - sekii
Дата добавления - 13.03.2019 в 14:13
_Boroda_ Дата: Среда, 13.03.2019, 14:21 | Сообщение № 2
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Так нужно?
Код
=СЧЁТ(B2:F2)=СЧЁТЕСЛИ(B2:F2;B2)

Код
=СЧЁТЕСЛИ(B2:F2;"<>"&B2)=0


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеТак нужно?
Код
=СЧЁТ(B2:F2)=СЧЁТЕСЛИ(B2:F2;B2)

Код
=СЧЁТЕСЛИ(B2:F2;"<>"&B2)=0

Автор - _Boroda_
Дата добавления - 13.03.2019 в 14:21
bmv98rus Дата: Среда, 13.03.2019, 14:21 | Сообщение № 3
Группа: Проверенные
Ранг: Старожил
Сообщений: 2451
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
например
Код
=COUNTIF(B2:F2;F2)=COUNTA(B2:F2)


Александр, подумал немного,
Код
=COUNTIF(B2:F2;"<>"&B2)=0


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Среда, 13.03.2019, 14:30
 
Ответить
Сообщениенапример
Код
=COUNTIF(B2:F2;F2)=COUNTA(B2:F2)


Александр, подумал немного,
Код
=COUNTIF(B2:F2;"<>"&B2)=0

Автор - bmv98rus
Дата добавления - 13.03.2019 в 14:21
sekii Дата: Среда, 13.03.2019, 14:27 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
=СЧЁТ(B2:F2)=СЧЁТЕСЛИ(B2:F2;B2)


почти
забыл сказать, что в ячейках могут быть буквы
 
Ответить
Сообщение
=СЧЁТ(B2:F2)=СЧЁТЕСЛИ(B2:F2;B2)


почти
забыл сказать, что в ячейках могут быть буквы

Автор - sekii
Дата добавления - 13.03.2019 в 14:27
sekii Дата: Среда, 13.03.2019, 14:29 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 20% ±

Excel 2013
=СЧЁТЕСЛИ(B2:F2;"<>"&B2)=0

вот это работает
спасибо!


Сообщение отредактировал sekii - Среда, 13.03.2019, 14:29
 
Ответить
Сообщение
=СЧЁТЕСЛИ(B2:F2;"<>"&B2)=0

вот это работает
спасибо!

Автор - sekii
Дата добавления - 13.03.2019 в 14:29
_Boroda_ Дата: Среда, 13.03.2019, 14:29 | Сообщение № 6
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
СЧЁТЗ вместо СЧЁТ
Или вторая формула в том же посте


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеСЧЁТЗ вместо СЧЁТ
Или вторая формула в том же посте

Автор - _Boroda_
Дата добавления - 13.03.2019 в 14:29
bmv98rus Дата: Среда, 13.03.2019, 14:32 | Сообщение № 7
Группа: Проверенные
Ранг: Старожил
Сообщений: 2451
Репутация: 421 ±
Замечаний: 0% ±

Excel 2013/2016
_Boroda_, #2 и #3 сегодня шедовральны :-)


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение_Boroda_, #2 и #3 сегодня шедовральны :-)

Автор - bmv98rus
Дата добавления - 13.03.2019 в 14:32
_Boroda_ Дата: Среда, 13.03.2019, 14:57 | Сообщение № 8
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15567
Репутация: 6074 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
Ага


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеАга

Автор - _Boroda_
Дата добавления - 13.03.2019 в 14:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение нескольких ячеек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!