Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/поиск значения соответствующее максимальному числу из указан - Мир MS Excel

Регистрация · Логин: · Пароль: · · Забыли пароль?
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения соответствующее максимальному числу из указан (Формулы/Formulas)
поиск значения соответствующее максимальному числу из указан
Artemon Дата: Пятница, 15.03.2019, 15:47 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый день, уважаемые гуру
Нужно, чтобы формула выдавала номер, которому соответствует максимальное число из диапазона [0,6-0,9]
прикрепляю файл
подскажите как реализовать, пожалуйста
К сообщению приложен файл: _Microsoft_Exce.xlsx(8.6 Kb)


Сообщение отредактировал Artemon - Пятница, 15.03.2019, 16:48
 
Ответить
СообщениеДобрый день, уважаемые гуру
Нужно, чтобы формула выдавала номер, которому соответствует максимальное число из диапазона [0,6-0,9]
прикрепляю файл
подскажите как реализовать, пожалуйста

Автор - Artemon
Дата добавления - 15.03.2019 в 15:47
bmv98rus Дата: Пятница, 15.03.2019, 16:31 | Сообщение № 2
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Ну например массивно
Код
=INDEX(A2:A7;MATCH(MAX(IFERROR((D2:D7>=0,6)*(D2:D7<=0,9)*D2:D7;):);D2:D7))

Код
=INDEX(A2:A7;MATCH(MAX(IFERROR((ABS(D2:D7-0,75)<=0,15)*D2:D7;););D2:D7))

Код
=INDEX(A2:A7;MATCH(MAX(IFERROR((ABS(D2:D7-3/4)<=0,15)*D2:D7;););D2:D7))


Тему бы подправить. У вас поиск значения советующего максимальному числу из указанного диапазона чисел.
К сообщению приложен файл: Copy_of_725.xlsx(9.0 Kb)


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 15.03.2019, 18:14
 
Ответить
СообщениеНу например массивно
Код
=INDEX(A2:A7;MATCH(MAX(IFERROR((D2:D7>=0,6)*(D2:D7<=0,9)*D2:D7;):);D2:D7))

Код
=INDEX(A2:A7;MATCH(MAX(IFERROR((ABS(D2:D7-0,75)<=0,15)*D2:D7;););D2:D7))

Код
=INDEX(A2:A7;MATCH(MAX(IFERROR((ABS(D2:D7-3/4)<=0,15)*D2:D7;););D2:D7))


Тему бы подправить. У вас поиск значения советующего максимальному числу из указанного диапазона чисел.

Автор - bmv98rus
Дата добавления - 15.03.2019 в 16:31
Artemon Дата: Пятница, 15.03.2019, 16:45 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
bmv98rus, при замене значений считает неправильно, записал видео https://yadi.sk/i/I4wzt5Hgd0S1Vw
 
Ответить
Сообщениеbmv98rus, при замене значений считает неправильно, записал видео https://yadi.sk/i/I4wzt5Hgd0S1Vw

Автор - Artemon
Дата добавления - 15.03.2019 в 16:45
_Boroda_ Дата: Пятница, 15.03.2019, 16:52 | Сообщение № 4
Группа: Модераторы
Ранг: Местный житель
Сообщений: 15578
Репутация: 6075 ±
Замечаний: 0% ±

2003; 2007; 2010; 2013 RUS
С некоторой натяжкой
Код
=СУММЕСЛИ(D2:D7;МАКС(ЕСЛИОШИБКА(,6+ТЕКСТ(D2:D7-,6;"[>,3]в");""));A2:A7)

Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА(,6+ТЕКСТ(D2:D7-,6;"[>,3]в");""));D2:D7;)

Так получше
Код
=СУММЕСЛИ(D2:D7;МАКС(ЕСЛИОШИБКА(--ТЕКСТ(D2:D7;"[>,9]в;[<,6]в;основной");""));A2:A7)

Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА(--ТЕКСТ(D2:D7;"[>,9]в;[<,6]в;основной");""));D2:D7;)


*А медведь просто запятую случайно пропустил перед второй справа скобкой
Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА((D2:D7>=0,6)*(D2:D7<=0,9)*D2:D7;));D2:D7;)
К сообщению приложен файл: 8296576.xlsx(9.2 Kb)


Скажи мне, кудесник, любимец ба’гов...
Платная помощь:
Boroda_Excel@mail.ru
Яндекс-деньги: 41001632713405 | Webmoney: R289877159277; Z102172301748; E177867141995
 
Ответить
СообщениеС некоторой натяжкой
Код
=СУММЕСЛИ(D2:D7;МАКС(ЕСЛИОШИБКА(,6+ТЕКСТ(D2:D7-,6;"[>,3]в");""));A2:A7)

Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА(,6+ТЕКСТ(D2:D7-,6;"[>,3]в");""));D2:D7;)

Так получше
Код
=СУММЕСЛИ(D2:D7;МАКС(ЕСЛИОШИБКА(--ТЕКСТ(D2:D7;"[>,9]в;[<,6]в;основной");""));A2:A7)

Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА(--ТЕКСТ(D2:D7;"[>,9]в;[<,6]в;основной");""));D2:D7;)


*А медведь просто запятую случайно пропустил перед второй справа скобкой
Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА((D2:D7>=0,6)*(D2:D7<=0,9)*D2:D7;));D2:D7;)

Автор - _Boroda_
Дата добавления - 15.03.2019 в 16:52
Artemon Дата: Пятница, 15.03.2019, 17:04 | Сообщение № 5
Группа: Пользователи
Ранг: Участник
Сообщений: 55
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
_Boroda_,
Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА((D2:D7>=0,6)*(D2:D7<=0,9)*D2:D7;));D2:D7;)

да эта формула на 10 разных таблицах показала все правильно
спасибо, гуру
 
Ответить
Сообщение_Boroda_,
Код
=ПОИСКПОЗ(МАКС(ЕСЛИОШИБКА((D2:D7>=0,6)*(D2:D7<=0,9)*D2:D7;));D2:D7;)

да эта формула на 10 разных таблицах показала все правильно
спасибо, гуру

Автор - Artemon
Дата добавления - 15.03.2019 в 17:04
bmv98rus Дата: Пятница, 15.03.2019, 17:42 | Сообщение № 6
Группа: Проверенные
Ранг: Старожил
Сообщений: 2470
Репутация: 427 ±
Замечаний: 0% ±

Excel 2013/2016
Ну хоть с названием темы не наКОСЯКчил. :-)
Только вот теперь, если использовать последнюю формулу надо в теме не значение а порядковый номер искать.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 15.03.2019, 18:17
 
Ответить
СообщениеНу хоть с названием темы не наКОСЯКчил. :-)
Только вот теперь, если использовать последнюю формулу надо в теме не значение а порядковый номер искать.

Автор - bmv98rus
Дата добавления - 15.03.2019 в 17:42
Мир MS Excel » Вопросы и решения » Вопросы по Excel » поиск значения соответствующее максимальному числу из указан (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования
© 2010-2019 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!